All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
@ 2016-02-23  0:57 Simon Horman
  2016-02-23  8:17 ` Geert Uytterhoeven
  2016-02-23  8:19 ` Geert Uytterhoeven
  0 siblings, 2 replies; 6+ messages in thread
From: Simon Horman @ 2016-02-23  0:57 UTC (permalink / raw)
  To: Mike Turquette, Stephen Boyd
  Cc: Geert Uytterhoeven, Magnus Damm, linux-clk, linux-renesas-soc,
	Simon Horman

As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.

This is part of an ongoing process to migrate from ARCH_SHMOBILE to
ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.

Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
---
 drivers/clk/Makefile | 1 -
 1 file changed, 1 deletion(-)

 Based on clk-next

diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
index bae4be6501df..b19af449d2f3 100644
--- a/drivers/clk/Makefile
+++ b/drivers/clk/Makefile
@@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)		+= pxa/
 obj-$(CONFIG_COMMON_CLK_QCOM)		+= qcom/
 obj-$(CONFIG_ARCH_ROCKCHIP)		+= rockchip/
 obj-$(CONFIG_COMMON_CLK_SAMSUNG)	+= samsung/
-obj-$(CONFIG_ARCH_SHMOBILE_MULTI)	+= shmobile/
 obj-$(CONFIG_ARCH_RENESAS)		+= shmobile/
 obj-$(CONFIG_ARCH_SIRF)			+= sirf/
 obj-$(CONFIG_ARCH_SOCFPGA)		+= socfpga/
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
  2016-02-23  0:57 [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI Simon Horman
@ 2016-02-23  8:17 ` Geert Uytterhoeven
  2016-02-23  8:19 ` Geert Uytterhoeven
  1 sibling, 0 replies; 6+ messages in thread
From: Geert Uytterhoeven @ 2016-02-23  8:17 UTC (permalink / raw)
  To: Simon Horman
  Cc: Mike Turquette, Stephen Boyd, Geert Uytterhoeven, Magnus Damm,
	linux-clk, linux-renesas-soc

On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
<horms+renesas@verge.net.au> wrote:
> As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
>
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
>
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> ---
>  drivers/clk/Makefile | 1 -
>  1 file changed, 1 deletion(-)

> -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
>  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/

Should we rename clk/shmobile/ to clk/renesas/?
Or is that too much of a hassle?

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
  2016-02-23  0:57 [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI Simon Horman
  2016-02-23  8:17 ` Geert Uytterhoeven
@ 2016-02-23  8:19 ` Geert Uytterhoeven
  2016-02-23  9:10   ` Simon Horman
  1 sibling, 1 reply; 6+ messages in thread
From: Geert Uytterhoeven @ 2016-02-23  8:19 UTC (permalink / raw)
  To: Simon Horman
  Cc: Michael Turquette, Stephen Boyd, Geert Uytterhoeven, Magnus Damm,
	linux-clk, linux-renesas-soc

CC The New Mike ;-)

On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
<horms+renesas@verge.net.au> wrote:
> As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
>
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
>
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> ---
>  drivers/clk/Makefile | 1 -
>  1 file changed, 1 deletion(-)
>
>  Based on clk-next
>
> diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> index bae4be6501df..b19af449d2f3 100644
> --- a/drivers/clk/Makefile
> +++ b/drivers/clk/Makefile
> @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
>  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
>  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
>  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/

Should we rename clk/shmobile/ to clk/renesas/?
Or is that too much of a hassle?

>  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/
>  obj-$(CONFIG_ARCH_SIRF)                        += sirf/
>  obj-$(CONFIG_ARCH_SOCFPGA)             += socfpga/

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
  2016-02-23  8:19 ` Geert Uytterhoeven
@ 2016-02-23  9:10   ` Simon Horman
  2016-02-25 23:44     ` Stephen Boyd
  0 siblings, 1 reply; 6+ messages in thread
From: Simon Horman @ 2016-02-23  9:10 UTC (permalink / raw)
  To: Geert Uytterhoeven
  Cc: Michael Turquette, Stephen Boyd, Geert Uytterhoeven, Magnus Damm,
	linux-clk, linux-renesas-soc

On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> CC The New Mike ;-)
> 
> On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> <horms+renesas@verge.net.au> wrote:
> > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> >
> > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> >
> > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> 
> Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> 
> > ---
> >  drivers/clk/Makefile | 1 -
> >  1 file changed, 1 deletion(-)
> >
> >  Based on clk-next
> >
> > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > index bae4be6501df..b19af449d2f3 100644
> > --- a/drivers/clk/Makefile
> > +++ b/drivers/clk/Makefile
> > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> 
> Should we rename clk/shmobile/ to clk/renesas/?
> Or is that too much of a hassle?

I think it is a good idea.  And I suspect it shouldn't be too difficult if
we coordinate things with Mike to handle any in-flight patches for that
directory.

> >  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/
> >  obj-$(CONFIG_ARCH_SIRF)                        += sirf/
> >  obj-$(CONFIG_ARCH_SOCFPGA)             += socfpga/

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
  2016-02-23  9:10   ` Simon Horman
@ 2016-02-25 23:44     ` Stephen Boyd
  2016-03-03  5:02       ` Simon Horman
  0 siblings, 1 reply; 6+ messages in thread
From: Stephen Boyd @ 2016-02-25 23:44 UTC (permalink / raw)
  To: Simon Horman
  Cc: Geert Uytterhoeven, Michael Turquette, Geert Uytterhoeven,
	Magnus Damm, linux-clk, linux-renesas-soc

On 02/23, Simon Horman wrote:
> On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> > CC The New Mike ;-)
> > 
> > On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> > <horms+renesas@verge.net.au> wrote:
> > > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> > >
> > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > >
> > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > 
> > Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> > 

Applied to clk-next

> > >  drivers/clk/Makefile | 1 -
> > >  1 file changed, 1 deletion(-)
> > >
> > >  Based on clk-next
> > >
> > > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > > index bae4be6501df..b19af449d2f3 100644
> > > --- a/drivers/clk/Makefile
> > > +++ b/drivers/clk/Makefile
> > > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> > >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> > >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> > >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> > 
> > Should we rename clk/shmobile/ to clk/renesas/?
> > Or is that too much of a hassle?
> 
> I think it is a good idea.  And I suspect it shouldn't be too difficult if
> we coordinate things with Mike to handle any in-flight patches for that
> directory.

Feel free to send the patch.

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI
  2016-02-25 23:44     ` Stephen Boyd
@ 2016-03-03  5:02       ` Simon Horman
  0 siblings, 0 replies; 6+ messages in thread
From: Simon Horman @ 2016-03-03  5:02 UTC (permalink / raw)
  To: Stephen Boyd
  Cc: Geert Uytterhoeven, Michael Turquette, Geert Uytterhoeven,
	Magnus Damm, linux-clk, linux-renesas-soc

On Thu, Feb 25, 2016 at 03:44:34PM -0800, Stephen Boyd wrote:
> On 02/23, Simon Horman wrote:
> > On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> > > CC The New Mike ;-)
> > > 
> > > On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> > > <horms+renesas@verge.net.au> wrote:
> > > > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > > > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > > > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> > > >
> > > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > > > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > > >
> > > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > > 
> > > Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> > > 
> 
> Applied to clk-next
> 
> > > >  drivers/clk/Makefile | 1 -
> > > >  1 file changed, 1 deletion(-)
> > > >
> > > >  Based on clk-next
> > > >
> > > > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > > > index bae4be6501df..b19af449d2f3 100644
> > > > --- a/drivers/clk/Makefile
> > > > +++ b/drivers/clk/Makefile
> > > > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> > > >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> > > >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> > > >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > > > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> > > 
> > > Should we rename clk/shmobile/ to clk/renesas/?
> > > Or is that too much of a hassle?
> > 
> > I think it is a good idea.  And I suspect it shouldn't be too difficult if
> > we coordinate things with Mike to handle any in-flight patches for that
> > directory.
> 
> Feel free to send the patch.

Done :)

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2016-03-03  5:02 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-02-23  0:57 [PATCH] clk: shmobile: Remove ARCH_SHMOBILE_MULTI Simon Horman
2016-02-23  8:17 ` Geert Uytterhoeven
2016-02-23  8:19 ` Geert Uytterhoeven
2016-02-23  9:10   ` Simon Horman
2016-02-25 23:44     ` Stephen Boyd
2016-03-03  5:02       ` Simon Horman

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.