All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c
@ 2016-04-08  2:24 Masahiro Yamada
  2016-04-08  2:24 ` [PATCH 2/2] kbuild: rename cmd_as_s_S to cmd_cpp_s_S Masahiro Yamada
  2016-04-08 15:00 ` [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Arnaldo Carvalho de Melo
  0 siblings, 2 replies; 4+ messages in thread
From: Masahiro Yamada @ 2016-04-08  2:24 UTC (permalink / raw)
  To: linux-kbuild
  Cc: Masahiro Yamada, Aaro Koskinen, Adrian Hunter, Michal Marek,
	linux-kernel, Lukas Wunner, Jiri Olsa, Arnaldo Carvalho de Melo

This command just preprocesses .c files into .i files, so cmd_cpp_i_c
seems more suitable.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
---

 scripts/Makefile.build     | 6 +++---
 tools/build/Makefile.build | 8 ++++----
 2 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/scripts/Makefile.build b/scripts/Makefile.build
index e1bc190..7e4df13 100644
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
@@ -152,11 +152,11 @@ cmd_cc_s_c       = $(CC) $(c_flags) $(DISABLE_LTO) -fverbose-asm -S -o $@ $<
 $(obj)/%.s: $(src)/%.c FORCE
 	$(call if_changed_dep,cc_s_c)
 
-quiet_cmd_cc_i_c = CPP $(quiet_modtag) $@
-cmd_cc_i_c       = $(CPP) $(c_flags)   -o $@ $<
+quiet_cmd_cpp_i_c = CPP $(quiet_modtag) $@
+cmd_cpp_i_c       = $(CPP) $(c_flags) -o $@ $<
 
 $(obj)/%.i: $(src)/%.c FORCE
-	$(call if_changed_dep,cc_i_c)
+	$(call if_changed_dep,cpp_i_c)
 
 cmd_gensymtypes =                                                           \
     $(CPP) -D__GENKSYMS__ $(c_flags) $< |                                   \
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
index ee566e8..27f3583 100644
--- a/tools/build/Makefile.build
+++ b/tools/build/Makefile.build
@@ -58,8 +58,8 @@ quiet_cmd_mkdir = MKDIR    $(dir $@)
 quiet_cmd_cc_o_c = CC       $@
       cmd_cc_o_c = $(CC) $(c_flags) -c -o $@ $<
 
-quiet_cmd_cc_i_c = CPP      $@
-      cmd_cc_i_c = $(CC) $(c_flags) -E -o $@ $<
+quiet_cmd_cpp_i_c = CPP      $@
+      cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
 
 quiet_cmd_cc_s_c = AS       $@
       cmd_cc_s_c = $(CC) $(c_flags) -S -o $@ $<
@@ -83,11 +83,11 @@ $(OUTPUT)%.o: %.S FORCE
 
 $(OUTPUT)%.i: %.c FORCE
 	$(call rule_mkdir)
-	$(call if_changed_dep,cc_i_c)
+	$(call if_changed_dep,cpp_i_c)
 
 $(OUTPUT)%.s: %.S FORCE
 	$(call rule_mkdir)
-	$(call if_changed_dep,cc_i_c)
+	$(call if_changed_dep,cpp_i_c)
 
 $(OUTPUT)%.s: %.c FORCE
 	$(call rule_mkdir)
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 2/2] kbuild: rename cmd_as_s_S to cmd_cpp_s_S
  2016-04-08  2:24 [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Masahiro Yamada
@ 2016-04-08  2:24 ` Masahiro Yamada
  2016-04-08 15:00 ` [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Arnaldo Carvalho de Melo
  1 sibling, 0 replies; 4+ messages in thread
From: Masahiro Yamada @ 2016-04-08  2:24 UTC (permalink / raw)
  To: linux-kbuild; +Cc: Masahiro Yamada, Michal Marek, linux-kernel

This command just preprocesses .S files into .s files, so cmd_cpp_s_S
seems more suitable.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
---

 scripts/Makefile.build | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/scripts/Makefile.build b/scripts/Makefile.build
index 7e4df13..e65a3e9 100644
--- a/scripts/Makefile.build
+++ b/scripts/Makefile.build
@@ -314,11 +314,11 @@ modkern_aflags := $(KBUILD_AFLAGS_KERNEL) $(AFLAGS_KERNEL)
 $(real-objs-m)      : modkern_aflags := $(KBUILD_AFLAGS_MODULE) $(AFLAGS_MODULE)
 $(real-objs-m:.o=.s): modkern_aflags := $(KBUILD_AFLAGS_MODULE) $(AFLAGS_MODULE)
 
-quiet_cmd_as_s_S = CPP $(quiet_modtag) $@
-cmd_as_s_S       = $(CPP) $(a_flags)   -o $@ $<
+quiet_cmd_cpp_s_S = CPP $(quiet_modtag) $@
+cmd_cpp_s_S       = $(CPP) $(a_flags) -o $@ $<
 
 $(obj)/%.s: $(src)/%.S FORCE
-	$(call if_changed_dep,as_s_S)
+	$(call if_changed_dep,cpp_s_S)
 
 quiet_cmd_as_o_S = AS $(quiet_modtag)  $@
 cmd_as_o_S       = $(CC) $(a_flags) -c -o $@ $<
-- 
1.9.1

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c
  2016-04-08  2:24 [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Masahiro Yamada
  2016-04-08  2:24 ` [PATCH 2/2] kbuild: rename cmd_as_s_S to cmd_cpp_s_S Masahiro Yamada
@ 2016-04-08 15:00 ` Arnaldo Carvalho de Melo
  2016-04-20  8:49   ` Michal Marek
  1 sibling, 1 reply; 4+ messages in thread
From: Arnaldo Carvalho de Melo @ 2016-04-08 15:00 UTC (permalink / raw)
  To: Masahiro Yamada
  Cc: linux-kbuild, Aaro Koskinen, Adrian Hunter, Michal Marek,
	linux-kernel, Arnaldo Carvalho de Melo, Lukas Wunner, Jiri Olsa

Em Fri, Apr 08, 2016 at 11:24:47AM +0900, Masahiro Yamada escreveu:
> This command just preprocesses .c files into .i files, so cmd_cpp_i_c
> seems more suitable.

Thanks for doing it to the tools/build/ copy, looks sensible, I guess
this can go via the kbuild tree?

Acked-by: Arnaldo Carvalho de Melo <acme@redhat.com>

- Arnaldo
 
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
> ---
> 
>  scripts/Makefile.build     | 6 +++---
>  tools/build/Makefile.build | 8 ++++----
>  2 files changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/scripts/Makefile.build b/scripts/Makefile.build
> index e1bc190..7e4df13 100644
> --- a/scripts/Makefile.build
> +++ b/scripts/Makefile.build
> @@ -152,11 +152,11 @@ cmd_cc_s_c       = $(CC) $(c_flags) $(DISABLE_LTO) -fverbose-asm -S -o $@ $<
>  $(obj)/%.s: $(src)/%.c FORCE
>  	$(call if_changed_dep,cc_s_c)
>  
> -quiet_cmd_cc_i_c = CPP $(quiet_modtag) $@
> -cmd_cc_i_c       = $(CPP) $(c_flags)   -o $@ $<
> +quiet_cmd_cpp_i_c = CPP $(quiet_modtag) $@
> +cmd_cpp_i_c       = $(CPP) $(c_flags) -o $@ $<
>  
>  $(obj)/%.i: $(src)/%.c FORCE
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  cmd_gensymtypes =                                                           \
>      $(CPP) -D__GENKSYMS__ $(c_flags) $< |                                   \
> diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
> index ee566e8..27f3583 100644
> --- a/tools/build/Makefile.build
> +++ b/tools/build/Makefile.build
> @@ -58,8 +58,8 @@ quiet_cmd_mkdir = MKDIR    $(dir $@)
>  quiet_cmd_cc_o_c = CC       $@
>        cmd_cc_o_c = $(CC) $(c_flags) -c -o $@ $<
>  
> -quiet_cmd_cc_i_c = CPP      $@
> -      cmd_cc_i_c = $(CC) $(c_flags) -E -o $@ $<
> +quiet_cmd_cpp_i_c = CPP      $@
> +      cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
>  
>  quiet_cmd_cc_s_c = AS       $@
>        cmd_cc_s_c = $(CC) $(c_flags) -S -o $@ $<
> @@ -83,11 +83,11 @@ $(OUTPUT)%.o: %.S FORCE
>  
>  $(OUTPUT)%.i: %.c FORCE
>  	$(call rule_mkdir)
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  $(OUTPUT)%.s: %.S FORCE
>  	$(call rule_mkdir)
> -	$(call if_changed_dep,cc_i_c)
> +	$(call if_changed_dep,cpp_i_c)
>  
>  $(OUTPUT)%.s: %.c FORCE
>  	$(call rule_mkdir)
> -- 
> 1.9.1

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c
  2016-04-08 15:00 ` [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Arnaldo Carvalho de Melo
@ 2016-04-20  8:49   ` Michal Marek
  0 siblings, 0 replies; 4+ messages in thread
From: Michal Marek @ 2016-04-20  8:49 UTC (permalink / raw)
  To: Arnaldo Carvalho de Melo
  Cc: Masahiro Yamada, linux-kbuild, Aaro Koskinen, Adrian Hunter,
	Michal Marek, linux-kernel, Arnaldo Carvalho de Melo,
	Lukas Wunner, Jiri Olsa

On Fri, Apr 08, 2016 at 12:00:57PM -0300, Arnaldo Carvalho de Melo wrote:
> Em Fri, Apr 08, 2016 at 11:24:47AM +0900, Masahiro Yamada escreveu:
> > This command just preprocesses .c files into .i files, so cmd_cpp_i_c
> > seems more suitable.
> 
> Thanks for doing it to the tools/build/ copy, looks sensible, I guess
> this can go via the kbuild tree?
> 
> Acked-by: Arnaldo Carvalho de Melo <acme@redhat.com>
> 
> - Arnaldo
>  
> > Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>

Applied both patches to kbuild.git#kbuild.

Michal

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2016-04-20  8:50 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-04-08  2:24 [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Masahiro Yamada
2016-04-08  2:24 ` [PATCH 2/2] kbuild: rename cmd_as_s_S to cmd_cpp_s_S Masahiro Yamada
2016-04-08 15:00 ` [PATCH 1/2] kbuild: rename cmd_cc_i_c to cmd_cpp_i_c Arnaldo Carvalho de Melo
2016-04-20  8:49   ` Michal Marek

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.