All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] main-loop: check return value before using
@ 2016-07-06  3:03 Cao jin
  2016-07-06  5:28 ` Cao jin
  2016-07-06  6:46 ` Fam Zheng
  0 siblings, 2 replies; 7+ messages in thread
From: Cao jin @ 2016-07-06  3:03 UTC (permalink / raw)
  To: qemu-devel; +Cc: pbonzini

pointer 'qemu_aio_context' should be checked first before it is used.
qemu_bh_new() will use it.

Also add extra newlines to make code well separated and easier to read.

Signed-off-by: Cao jin <caoj.fnst@cn.fujitsu.com>
---
 main-loop.c | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/main-loop.c b/main-loop.c
index 89a6994..0d943f1 100644
--- a/main-loop.c
+++ b/main-loop.c
@@ -154,18 +154,23 @@ int qemu_init_main_loop(Error **errp)
     }
 
     qemu_aio_context = aio_context_new(&local_error);
-    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
     if (!qemu_aio_context) {
         error_propagate(errp, local_error);
         return -EMFILE;
     }
+
+    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
+
     gpollfds = g_array_new(FALSE, FALSE, sizeof(GPollFD));
+
     src = aio_get_g_source(qemu_aio_context);
     g_source_attach(src, NULL);
     g_source_unref(src);
+
     src = iohandler_get_g_source();
     g_source_attach(src, NULL);
     g_source_unref(src);
+
     return 0;
 }
 
-- 
2.1.0

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-06  3:03 [Qemu-devel] [PATCH] main-loop: check return value before using Cao jin
@ 2016-07-06  5:28 ` Cao jin
  2016-07-06  6:46 ` Fam Zheng
  1 sibling, 0 replies; 7+ messages in thread
From: Cao jin @ 2016-07-06  5:28 UTC (permalink / raw)
  To: qemu-devel; +Cc: pbonzini

cc Paolo again, because failed to deliver in 'git send-email'

On 07/06/2016 11:03 AM, Cao jin wrote:
> pointer 'qemu_aio_context' should be checked first before it is used.
> qemu_bh_new() will use it.
>
> Also add extra newlines to make code well separated and easier to read.
>
> Signed-off-by: Cao jin <caoj.fnst@cn.fujitsu.com>
> ---
>   main-loop.c | 7 ++++++-
>   1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/main-loop.c b/main-loop.c
> index 89a6994..0d943f1 100644
> --- a/main-loop.c
> +++ b/main-loop.c
> @@ -154,18 +154,23 @@ int qemu_init_main_loop(Error **errp)
>       }
>
>       qemu_aio_context = aio_context_new(&local_error);
> -    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
>       if (!qemu_aio_context) {
>           error_propagate(errp, local_error);
>           return -EMFILE;
>       }
> +
> +    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
> +
>       gpollfds = g_array_new(FALSE, FALSE, sizeof(GPollFD));
> +
>       src = aio_get_g_source(qemu_aio_context);
>       g_source_attach(src, NULL);
>       g_source_unref(src);
> +
>       src = iohandler_get_g_source();
>       g_source_attach(src, NULL);
>       g_source_unref(src);
> +
>       return 0;
>   }
>
>

-- 
Yours Sincerely,

Cao jin

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-06  3:03 [Qemu-devel] [PATCH] main-loop: check return value before using Cao jin
  2016-07-06  5:28 ` Cao jin
@ 2016-07-06  6:46 ` Fam Zheng
  2016-07-06  7:46   ` Cao jin
  1 sibling, 1 reply; 7+ messages in thread
From: Fam Zheng @ 2016-07-06  6:46 UTC (permalink / raw)
  To: Cao jin; +Cc: qemu-devel, pbonzini

On Wed, 07/06 11:03, Cao jin wrote:
> pointer 'qemu_aio_context' should be checked first before it is used.
> qemu_bh_new() will use it.
> 
> Also add extra newlines to make code well separated and easier to read.

This "also" is not good, please only do one thing in a patch.

Fam

> 
> Signed-off-by: Cao jin <caoj.fnst@cn.fujitsu.com>
> ---
>  main-loop.c | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/main-loop.c b/main-loop.c
> index 89a6994..0d943f1 100644
> --- a/main-loop.c
> +++ b/main-loop.c
> @@ -154,18 +154,23 @@ int qemu_init_main_loop(Error **errp)
>      }
>  
>      qemu_aio_context = aio_context_new(&local_error);
> -    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
>      if (!qemu_aio_context) {
>          error_propagate(errp, local_error);
>          return -EMFILE;
>      }
> +
> +    qemu_notify_bh = qemu_bh_new(notify_event_cb, NULL);
> +
>      gpollfds = g_array_new(FALSE, FALSE, sizeof(GPollFD));
> +
>      src = aio_get_g_source(qemu_aio_context);
>      g_source_attach(src, NULL);
>      g_source_unref(src);
> +
>      src = iohandler_get_g_source();
>      g_source_attach(src, NULL);
>      g_source_unref(src);
> +
>      return 0;
>  }
>  
> -- 
> 2.1.0
> 
> 
> 
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-06  6:46 ` Fam Zheng
@ 2016-07-06  7:46   ` Cao jin
  2016-07-07  0:31     ` Fam Zheng
  0 siblings, 1 reply; 7+ messages in thread
From: Cao jin @ 2016-07-06  7:46 UTC (permalink / raw)
  To: Fam Zheng; +Cc: qemu-devel, pbonzini


On 07/06/2016 02:46 PM, Fam Zheng wrote:
> On Wed, 07/06 11:03, Cao jin wrote:
>> pointer 'qemu_aio_context' should be checked first before it is used.
>> qemu_bh_new() will use it.
>>
>> Also add extra newlines to make code well separated and easier to read.
>
> This "also" is not good, please only do one thing in a patch.
>
> Fam
>

Thanks Fam.

See what I was told before when come to here:
http://lists.nongnu.org/archive/html/qemu-trivial/2015-10/msg00116.html
http://lists.nongnu.org/archive/html/qemu-trivial/2015-10/msg00123.html

So since then, I always prefer to squeeze stylistics patch into a 
productive one.

Ok, I will split it.

Yours Sincerely,

Cao jin

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-06  7:46   ` Cao jin
@ 2016-07-07  0:31     ` Fam Zheng
  2016-07-07  3:18       ` Cao jin
  0 siblings, 1 reply; 7+ messages in thread
From: Fam Zheng @ 2016-07-07  0:31 UTC (permalink / raw)
  To: Cao jin; +Cc: pbonzini, qemu-devel

On Wed, 07/06 15:46, Cao jin wrote:
> 
> On 07/06/2016 02:46 PM, Fam Zheng wrote:
> > On Wed, 07/06 11:03, Cao jin wrote:
> > > pointer 'qemu_aio_context' should be checked first before it is used.
> > > qemu_bh_new() will use it.
> > > 
> > > Also add extra newlines to make code well separated and easier to read.
> > 
> > This "also" is not good, please only do one thing in a patch.
> > 
> > Fam
> > 
> 
> Thanks Fam.
> 
> See what I was told before when come to here:
> http://lists.nongnu.org/archive/html/qemu-trivial/2015-10/msg00116.html
> http://lists.nongnu.org/archive/html/qemu-trivial/2015-10/msg00123.html
> 
> So since then, I always prefer to squeeze stylistics patch into a productive
> one.

Yes, but in this patch I think the blank line changes are 1) more of personal
taste, 2) completely unrelated (neither lines nor semantics) to the functional
change.

Fam

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-07  0:31     ` Fam Zheng
@ 2016-07-07  3:18       ` Cao jin
  2016-07-07  5:00         ` Fam Zheng
  0 siblings, 1 reply; 7+ messages in thread
From: Cao jin @ 2016-07-07  3:18 UTC (permalink / raw)
  To: Fam Zheng; +Cc: pbonzini, qemu-devel



On 07/07/2016 08:31 AM, Fam Zheng wrote:
> On Wed, 07/06 15:46, Cao jin wrote:
>>
>
> Yes, but in this patch I think the blank line changes are 1) more of personal
> taste, 2) completely unrelated (neither lines nor semantics) to the functional
> change.
>
> Fam

Indeed, my personal taste. Generally speaking, well separated code block 
is easier for newbies to read. This is what I has been trained before, 
and I like it, so I just can't help to add these lines when the code in 
my hand:P  BTW, I am curious about maintainer`s opinion about this thing:)

-- 
Yours Sincerely,

Cao jin

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] main-loop: check return value before using
  2016-07-07  3:18       ` Cao jin
@ 2016-07-07  5:00         ` Fam Zheng
  0 siblings, 0 replies; 7+ messages in thread
From: Fam Zheng @ 2016-07-07  5:00 UTC (permalink / raw)
  To: Cao jin; +Cc: pbonzini, qemu-devel

On Thu, 07/07 11:18, Cao jin wrote:
> 
> 
> On 07/07/2016 08:31 AM, Fam Zheng wrote:
> > On Wed, 07/06 15:46, Cao jin wrote:
> > > 
> > 
> > Yes, but in this patch I think the blank line changes are 1) more of personal
> > taste, 2) completely unrelated (neither lines nor semantics) to the functional
> > change.
> > 
> > Fam
> 
> Indeed, my personal taste. Generally speaking, well separated code block is
> easier for newbies to read. This is what I has been trained before, and I
> like it, so I just can't help to add these lines when the code in my hand:P
> BTW, I am curious about maintainer`s opinion about this thing:)

It of course doesn't hurt git blame, as far as I can tell. Please Cc
qemu-trivial in the separate patch.

Fam

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2016-07-07  5:00 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-07-06  3:03 [Qemu-devel] [PATCH] main-loop: check return value before using Cao jin
2016-07-06  5:28 ` Cao jin
2016-07-06  6:46 ` Fam Zheng
2016-07-06  7:46   ` Cao jin
2016-07-07  0:31     ` Fam Zheng
2016-07-07  3:18       ` Cao jin
2016-07-07  5:00         ` Fam Zheng

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.