All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1080/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 12:14 Baole Ni
  2016-08-02 13:26 ` Steven Rostedt
  0 siblings, 1 reply; 2+ messages in thread
From: Baole Ni @ 2016-08-02 12:14 UTC (permalink / raw)
  To: jbaron, jiangshanlai, rostedt, mathieu.desnoyers, m.chehab,
	gregkh, m.szyprowski, kyungmin.park, k.kozlowski
  Cc: linux-kernel, chuansheng.liu, baolex.ni, mhocko, tglx, vkuznets,
	pmladek, tj, jpoimboe

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 lib/dynamic_debug.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
index fe42b6e..853158e 100644
--- a/lib/dynamic_debug.c
+++ b/lib/dynamic_debug.c
@@ -63,7 +63,7 @@ struct ddebug_iter {
 static DEFINE_MUTEX(ddebug_lock);
 static LIST_HEAD(ddebug_tables);
 static int verbose;
-module_param(verbose, int, 0644);
+module_param(verbose, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 
 /* Return the path relative to source root */
 static inline const char *trim_prefix(const char *path)
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1080/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 12:14 [PATCH 1080/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-02 13:26 ` Steven Rostedt
  0 siblings, 0 replies; 2+ messages in thread
From: Steven Rostedt @ 2016-08-02 13:26 UTC (permalink / raw)
  To: Baole Ni
  Cc: jbaron, jiangshanlai, mathieu.desnoyers, m.chehab, gregkh,
	m.szyprowski, kyungmin.park, k.kozlowski, linux-kernel,
	chuansheng.liu, mhocko, tglx, vkuznets, pmladek, tj, jpoimboe

On Tue,  2 Aug 2016 20:14:36 +0800
Baole Ni <baolex.ni@intel.com> wrote:

> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
> 

NACK!

I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.

-- Steve

> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  lib/dynamic_debug.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c
> index fe42b6e..853158e 100644
> --- a/lib/dynamic_debug.c
> +++ b/lib/dynamic_debug.c
> @@ -63,7 +63,7 @@ struct ddebug_iter {
>  static DEFINE_MUTEX(ddebug_lock);
>  static LIST_HEAD(ddebug_tables);
>  static int verbose;
> -module_param(verbose, int, 0644);
> +module_param(verbose, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>  
>  /* Return the path relative to source root */
>  static inline const char *trim_prefix(const char *path)

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-08-02 14:24 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 12:14 [PATCH 1080/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 13:26 ` Steven Rostedt

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.