All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1134/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 12:19 Baole Ni
  0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 12:19 UTC (permalink / raw)
  To: jhs, davem, kadlec, kaber, m.szyprowski, kyungmin.park, k.kozlowski
  Cc: netdev, linux-kernel, chuansheng.liu, baolex.ni, aryabinin

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 net/sched/sch_htb.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/net/sched/sch_htb.c b/net/sched/sch_htb.c
index d4b4218..8234fae 100644
--- a/net/sched/sch_htb.c
+++ b/net/sched/sch_htb.c
@@ -62,11 +62,11 @@ static int htb_hysteresis __read_mostly = 0; /* whether to use mode hysteresis f
 #endif
 
 /* Module parameter and sysfs export */
-module_param    (htb_hysteresis, int, 0640);
+module_param    (htb_hysteresis, int, S_IRUSR | S_IWUSR | S_IRGRP);
 MODULE_PARM_DESC(htb_hysteresis, "Hysteresis mode, less CPU load, less accurate");
 
 static int htb_rate_est = 0; /* htb classes have a default rate estimator */
-module_param(htb_rate_est, int, 0640);
+module_param(htb_rate_est, int, S_IRUSR | S_IWUSR | S_IRGRP);
 MODULE_PARM_DESC(htb_rate_est, "setup a default rate estimator (4sec 16sec) for htb classes");
 
 /* used internaly to keep status of single class */
-- 
2.9.2

^ permalink raw reply related	[flat|nested] only message in thread

only message in thread, other threads:[~2016-08-02 12:58 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 12:19 [PATCH 1134/1285] Replace numeric parameter like 0444 with macro Baole Ni

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.