All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0133/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:43 ` Baole Ni
  0 siblings, 0 replies; 4+ messages in thread
From: Baole Ni @ 2016-08-02 10:43 UTC (permalink / raw)
  To: ludovic.desroches, dan.j.williams, vinod.koul, davem, hpa, x86
  Cc: linux-arm-kernel, dmaengine, linux-kernel, chuansheng.liu,
	baolex.ni, peter, lee.jones

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/dma/at_xdmac.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c
index 75bd662..3c26e23 100644
--- a/drivers/dma/at_xdmac.c
+++ b/drivers/dma/at_xdmac.c
@@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg)
 };
 
 static unsigned int init_nr_desc_per_channel = 64;
-module_param(init_nr_desc_per_channel, uint, 0644);
+module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(init_nr_desc_per_channel,
 		 "initial descriptors per channel (default: 64)");
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH 0133/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:43 ` Baole Ni
  0 siblings, 0 replies; 4+ messages in thread
From: Baole Ni @ 2016-08-02 10:43 UTC (permalink / raw)
  To: linux-arm-kernel

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/dma/at_xdmac.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c
index 75bd662..3c26e23 100644
--- a/drivers/dma/at_xdmac.c
+++ b/drivers/dma/at_xdmac.c
@@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg)
 };
 
 static unsigned int init_nr_desc_per_channel = 64;
-module_param(init_nr_desc_per_channel, uint, 0644);
+module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(init_nr_desc_per_channel,
 		 "initial descriptors per channel (default: 64)");
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 0133/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 10:43 ` Baole Ni
@ 2016-08-03  2:38   ` Vinod Koul
  -1 siblings, 0 replies; 4+ messages in thread
From: Vinod Koul @ 2016-08-03  2:38 UTC (permalink / raw)
  To: Baole Ni
  Cc: ludovic.desroches, dan.j.williams, davem, hpa, x86,
	linux-arm-kernel, dmaengine, linux-kernel, chuansheng.liu, peter,
	lee.jones

On Tue, Aug 02, 2016 at 06:43:10PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

and all the patches I recived have same title.

Please, use subsystem specfic tags and driver names. Also patch title is
not telling me much. Perhpas mentioning that you are fixing module
params hardcoding would be better!

> 
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  drivers/dma/at_xdmac.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c
> index 75bd662..3c26e23 100644
> --- a/drivers/dma/at_xdmac.c
> +++ b/drivers/dma/at_xdmac.c
> @@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg)
>  };
>  
>  static unsigned int init_nr_desc_per_channel = 64;
> -module_param(init_nr_desc_per_channel, uint, 0644);
> +module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>  MODULE_PARM_DESC(init_nr_desc_per_channel,
>  		 "initial descriptors per channel (default: 64)");
>  
> -- 
> 2.9.2
> 

-- 
~Vinod

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 0133/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-03  2:38   ` Vinod Koul
  0 siblings, 0 replies; 4+ messages in thread
From: Vinod Koul @ 2016-08-03  2:38 UTC (permalink / raw)
  To: linux-arm-kernel

On Tue, Aug 02, 2016 at 06:43:10PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.

and all the patches I recived have same title.

Please, use subsystem specfic tags and driver names. Also patch title is
not telling me much. Perhpas mentioning that you are fixing module
params hardcoding would be better!

> 
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  drivers/dma/at_xdmac.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/dma/at_xdmac.c b/drivers/dma/at_xdmac.c
> index 75bd662..3c26e23 100644
> --- a/drivers/dma/at_xdmac.c
> +++ b/drivers/dma/at_xdmac.c
> @@ -314,7 +314,7 @@ static inline u8 at_xdmac_get_dwidth(u32 cfg)
>  };
>  
>  static unsigned int init_nr_desc_per_channel = 64;
> -module_param(init_nr_desc_per_channel, uint, 0644);
> +module_param(init_nr_desc_per_channel, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
>  MODULE_PARM_DESC(init_nr_desc_per_channel,
>  		 "initial descriptors per channel (default: 64)");
>  
> -- 
> 2.9.2
> 

-- 
~Vinod

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2016-08-03  2:38 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:43 [PATCH 0133/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 10:43 ` Baole Ni
2016-08-03  2:38 ` Vinod Koul
2016-08-03  2:38   ` Vinod Koul

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.