All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
To: Jason Gunthorpe <jgunthorpe@obsidianresearch.com>
Cc: Peter Huewe <peterhuewe@gmx.de>,
	linux-security-module@vger.kernel.org, stable@vger.kernel.org,
	Marcel Selhorst <tpmdd@selhorst.net>,
	"moderated list:TPM DEVICE DRIVER" 
	<tpmdd-devel@lists.sourceforge.net>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] tpm: fix a race condition in tpm2_unseal_trusted()
Date: Mon, 29 Aug 2016 18:25:21 +0300	[thread overview]
Message-ID: <20160829152520.GA9063@intel.com> (raw)
In-Reply-To: <20160828185149.GF12783@obsidianresearch.com>

On Sun, Aug 28, 2016 at 12:51:49PM -0600, Jason Gunthorpe wrote:
> On Sun, Aug 28, 2016 at 08:36:52AM +0200, Jarkko Sakkinen wrote:
> >  
> > @@ -576,7 +576,8 @@ static int tpm2_load(struct tpm_chip *chip,
> >  		goto out;
> >  	}
> >  
> > -	rc = tpm_transmit_cmd(chip, buf.data, PAGE_SIZE, "loading blob");
> > +	rc = tpm_transmit_cmd(chip, buf.data, PAGE_SIZE, TPM_TRANSMIT_UNLOCKED,
> > +			      "loading blob");
> 
> I still don't like this, required mutex's should not be split outside the
> function that needs them without more a more obvious indication:
> 
> > +	mutex_lock(&chip->tpm_mutex);
> >  	rc = tpm2_load(chip, payload, options, &blob_handle);
> >  	if (rc)
> > -		return rc;
> 
> I recommend you stick with the idiom and do this:
> 
>         mutex_lock(&chip->tpm_mutex);
>   	rc = tpm2_load(chip, payload, options, &blob_handle, TPM_TRANSMIT_UNLOCKED);
> 
> Which makes it easy to see we are doing it right everywhere.

Why consume stack for unnecessary stuff? This is a static function. For
me this sounds like cutting hairs really.

One thing that would improve readability would be to rename internal
functions tpm2_load and tpm2_unseal to tpm2_load_cmd and tpm2_unseal_cmd
in order to underline that they are command wrappers and not to mix with
tpm2_unseal_trusted().

I've been thinking to move that kind of convetion at least with TPM2
specific stuff when a function is clearly a wrapper. It kind of
documents the call path. I.e. if function satifies a constraint that
it prepares a command blob, calls tpm_transmit_cmd once and then
returns results to the caller this would be the naming convention.

> Jason

/Jarkko

  reply	other threads:[~2016-08-29 15:25 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-28  6:36 [PATCH] tpm: fix a race condition in tpm2_unseal_trusted() Jarkko Sakkinen
2016-08-28  6:36 ` Jarkko Sakkinen
2016-08-28 18:51 ` Jason Gunthorpe
2016-08-28 18:51   ` Jason Gunthorpe
2016-08-28 18:51   ` Jason Gunthorpe
2016-08-29 15:25   ` Jarkko Sakkinen [this message]
2016-08-29 15:25     ` Jarkko Sakkinen
2016-08-29 19:21     ` Jason Gunthorpe
2016-08-29 19:21       ` Jason Gunthorpe
2016-08-29 19:21       ` Jason Gunthorpe
2016-08-29 19:40       ` Jarkko Sakkinen
2016-08-29 19:40         ` Jarkko Sakkinen
2016-08-29 20:03         ` Jarkko Sakkinen
2016-08-29 20:03           ` Jarkko Sakkinen
2016-08-29 20:07           ` Jason Gunthorpe
2016-08-29 20:07             ` Jason Gunthorpe
2016-08-29 20:07             ` Jason Gunthorpe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160829152520.GA9063@intel.com \
    --to=jarkko.sakkinen@linux.intel.com \
    --cc=jgunthorpe@obsidianresearch.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=peterhuewe@gmx.de \
    --cc=stable@vger.kernel.org \
    --cc=tpmdd-devel@lists.sourceforge.net \
    --cc=tpmdd@selhorst.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.