All of lore.kernel.org
 help / color / mirror / Atom feed
* [U-Boot] check_config.sh produces false positive error?
@ 2016-12-04 19:52 Mirza Krak
  2016-12-05 16:34 ` Tom Rini
  0 siblings, 1 reply; 3+ messages in thread
From: Mirza Krak @ 2016-12-04 19:52 UTC (permalink / raw)
  To: u-boot

Hi.

Recently a check was added to if new ad-hoc CONFIG options where added
and produced an error. The exact commit is [1].

While building (2016.11) with some out of tree files in include folder
I get the following error:

Build error:
| Error: You must add new CONFIG options using Kconfig
| The following new ad-hoc CONFIG options were detected:
| CONFIG_MENDER_H
|
| Please add these via Kconfig instead. Find a suitable Kconfig
| file and add a 'config' or 'menuconfig' option.

As you can see above that this is not a new configuration option but a
header guard. Probably not the best naming convention here, but still
I wonder if the check_config.sh script should produce errors in cases
like the one above? The common practice in u-boot  is to use _H as
part of a header guard name (as far as I can see at least) so maybe
that should be added to the regexp in check_config.sh?

[1]. http://git.denx.de/?p=u-boot.git;a=commit;h=371244cb19f9804711dd66e4281ff7979915fd2e

Best Regards
Mirza

^ permalink raw reply	[flat|nested] 3+ messages in thread

* [U-Boot] check_config.sh produces false positive error?
  2016-12-04 19:52 [U-Boot] check_config.sh produces false positive error? Mirza Krak
@ 2016-12-05 16:34 ` Tom Rini
  2016-12-05 22:05   ` Mirza Krak
  0 siblings, 1 reply; 3+ messages in thread
From: Tom Rini @ 2016-12-05 16:34 UTC (permalink / raw)
  To: u-boot

On Sun, Dec 04, 2016 at 08:52:35PM +0100, Mirza Krak wrote:
> Hi.
> 
> Recently a check was added to if new ad-hoc CONFIG options where added
> and produced an error. The exact commit is [1].
> 
> While building (2016.11) with some out of tree files in include folder
> I get the following error:
> 
> Build error:
> | Error: You must add new CONFIG options using Kconfig
> | The following new ad-hoc CONFIG options were detected:
> | CONFIG_MENDER_H
> |
> | Please add these via Kconfig instead. Find a suitable Kconfig
> | file and add a 'config' or 'menuconfig' option.
> 
> As you can see above that this is not a new configuration option but a
> header guard. Probably not the best naming convention here, but still
> I wonder if the check_config.sh script should produce errors in cases
> like the one above? The common practice in u-boot  is to use _H as
> part of a header guard name (as far as I can see at least) so maybe
> that should be added to the regexp in check_config.sh?

I'm indifferent.  If you patch it and it looks clean, OK.  But on the
other hand, header guards should be _HEADER_PATH_AND_NAME_H_ (and I
mildly wonder if checkpatch.pl catches this).

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20161205/fa1b2fc3/attachment.sig>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* [U-Boot] check_config.sh produces false positive error?
  2016-12-05 16:34 ` Tom Rini
@ 2016-12-05 22:05   ` Mirza Krak
  0 siblings, 0 replies; 3+ messages in thread
From: Mirza Krak @ 2016-12-05 22:05 UTC (permalink / raw)
  To: u-boot

2016-12-05 17:34 GMT+01:00 Tom Rini <trini@konsulko.com>:
> On Sun, Dec 04, 2016 at 08:52:35PM +0100, Mirza Krak wrote:
>> Hi.
>>
>> Recently a check was added to if new ad-hoc CONFIG options where added
>> and produced an error. The exact commit is [1].
>>
>> While building (2016.11) with some out of tree files in include folder
>> I get the following error:
>>
>> Build error:
>> | Error: You must add new CONFIG options using Kconfig
>> | The following new ad-hoc CONFIG options were detected:
>> | CONFIG_MENDER_H
>> |
>> | Please add these via Kconfig instead. Find a suitable Kconfig
>> | file and add a 'config' or 'menuconfig' option.
>>
>> As you can see above that this is not a new configuration option but a
>> header guard. Probably not the best naming convention here, but still
>> I wonder if the check_config.sh script should produce errors in cases
>> like the one above? The common practice in u-boot  is to use _H as
>> part of a header guard name (as far as I can see at least) so maybe
>> that should be added to the regexp in check_config.sh?
>
> I'm indifferent.  If you patch it and it looks clean, OK.  But on the
> other hand, header guards should be _HEADER_PATH_AND_NAME_H_ (and I
> mildly wonder if checkpatch.pl catches this).

Understand. Will not produce a patch. We have now discussed this and
at least someone can google it I guess.

Best Regards
Mirza

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-12-05 22:05 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-12-04 19:52 [U-Boot] check_config.sh produces false positive error? Mirza Krak
2016-12-05 16:34 ` Tom Rini
2016-12-05 22:05   ` Mirza Krak

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.