All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] firmware: simplify defining and handling FW_OPT_FALLBACK
@ 2016-12-11 13:26 Rafał Miłecki
  2016-12-11 21:21 ` [PATCH V2] " Rafał Miłecki
  0 siblings, 1 reply; 3+ messages in thread
From: Rafał Miłecki @ 2016-12-11 13:26 UTC (permalink / raw)
  To: Ming Lei, Luis R . Rodriguez, Linux Kernel Mailing List
  Cc: Rafał Miłecki

From: Rafał Miłecki <rafal@milecki.pl>

I found handling of FW_OPT_FALLBACK a bit complex. It was defined using
another option and their values were dependent on kernel config.

It was also non-trivial to follow the code. Some callers were using
FW_OPT_FALLBACK which was confusing since the _request_firmware function
was always checking for FW_OPT_USERHELPER (the same bit in a relevan
configuration).

With this patch FW_OPT_USERHELPER gets its own bit and is explicitly
checked in the _request_firmware which hopefully makes code easier to
understand.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
 drivers/base/firmware_class.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index 22d1760..0524f8b 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -112,13 +112,9 @@ static inline long firmware_loading_timeout(void)
 #else
 #define FW_OPT_USERHELPER	0
 #endif
-#ifdef CONFIG_FW_LOADER_USER_HELPER_FALLBACK
-#define FW_OPT_FALLBACK		FW_OPT_USERHELPER
-#else
-#define FW_OPT_FALLBACK		0
-#endif
 #define FW_OPT_NO_WARN	(1U << 3)
 #define FW_OPT_NOCACHE	(1U << 4)
+#define FW_OPT_FALLBACK	(1U << 5)
 
 struct firmware_cache {
 	/* firmware_buf instance will be added into the below list */
@@ -1175,8 +1171,12 @@ _request_firmware(const struct firmware **firmware_p, const char *name,
 			dev_warn(device,
 				 "Direct firmware load for %s failed with error %d\n",
 				 name, ret);
-		if (opt_flags & FW_OPT_USERHELPER) {
+		if (config_enabled(CONFIG_FW_LOADER_USER_HELPER_FALLBACK) &&
+		    opt_flags & FW_OPT_FALLBACK) {
 			dev_warn(device, "Falling back to user helper\n");
+			opt_flags |= FW_OPT_USERHELPER;
+		}
+		if (opt_flags & FW_OPT_USERHELPER) {
 			ret = fw_load_from_user_helper(fw, name, device,
 						       opt_flags, timeout);
 		}
-- 
2.10.1

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* [PATCH V2] firmware: simplify defining and handling FW_OPT_FALLBACK
  2016-12-11 13:26 [PATCH] firmware: simplify defining and handling FW_OPT_FALLBACK Rafał Miłecki
@ 2016-12-11 21:21 ` Rafał Miłecki
       [not found]   ` <6ad5eb68-37c2-482c-395e-b6544a599046@broadcom.com>
  0 siblings, 1 reply; 3+ messages in thread
From: Rafał Miłecki @ 2016-12-11 21:21 UTC (permalink / raw)
  To: Ming Lei, Luis R . Rodriguez, Linux Kernel Mailing List
  Cc: Rafał Miłecki

From: Rafał Miłecki <rafal@milecki.pl>

I found handling of FW_OPT_FALLBACK a bit complex. It was defined using
another option and their values were dependent on kernel config.

It was also non-trivial to follow the code. Some callers were using
FW_OPT_FALLBACK which was confusing since the _request_firmware function
was always checking for FW_OPT_USERHELPER (the same bit in a relevant
configuration).

With this patch FW_OPT_USERHELPER gets its own bit and is explicitly
checked in the _request_firmware which hopefully makes code easier to
understand.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
V2: s/config_enabled/IS_ENABLED/ to compile since c0a0aba8e47 ("kconfig.h: remove config_enabled() macro")
---
 drivers/base/firmware_class.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index 22d1760..0e1d5b8 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -112,13 +112,9 @@ static inline long firmware_loading_timeout(void)
 #else
 #define FW_OPT_USERHELPER	0
 #endif
-#ifdef CONFIG_FW_LOADER_USER_HELPER_FALLBACK
-#define FW_OPT_FALLBACK		FW_OPT_USERHELPER
-#else
-#define FW_OPT_FALLBACK		0
-#endif
 #define FW_OPT_NO_WARN	(1U << 3)
 #define FW_OPT_NOCACHE	(1U << 4)
+#define FW_OPT_FALLBACK	(1U << 5)
 
 struct firmware_cache {
 	/* firmware_buf instance will be added into the below list */
@@ -1175,8 +1171,12 @@ _request_firmware(const struct firmware **firmware_p, const char *name,
 			dev_warn(device,
 				 "Direct firmware load for %s failed with error %d\n",
 				 name, ret);
-		if (opt_flags & FW_OPT_USERHELPER) {
+		if (IS_ENABLED(CONFIG_FW_LOADER_USER_HELPER_FALLBACK) &&
+		    opt_flags & FW_OPT_FALLBACK) {
 			dev_warn(device, "Falling back to user helper\n");
+			opt_flags |= FW_OPT_USERHELPER;
+		}
+		if (opt_flags & FW_OPT_USERHELPER) {
 			ret = fw_load_from_user_helper(fw, name, device,
 						       opt_flags, timeout);
 		}
-- 
2.10.1

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH V2] firmware: simplify defining and handling FW_OPT_FALLBACK
       [not found]   ` <6ad5eb68-37c2-482c-395e-b6544a599046@broadcom.com>
@ 2016-12-12 10:24     ` Rafał Miłecki
  0 siblings, 0 replies; 3+ messages in thread
From: Rafał Miłecki @ 2016-12-12 10:24 UTC (permalink / raw)
  To: Arend van Spriel
  Cc: Ming Lei, Luis R . Rodriguez, Linux Kernel Mailing List,
	Rafał Miłecki

On 11 December 2016 at 23:46, Arend van Spriel
<arend.vanspriel@broadcom.com> wrote:
> On 11-12-16 22:21, Rafał Miłecki wrote:
>> From: Rafał Miłecki <rafal@milecki.pl>
>>
>> I found handling of FW_OPT_FALLBACK a bit complex. It was defined using
>> another option and their values were dependent on kernel config.
>>
>> It was also non-trivial to follow the code. Some callers were using
>> FW_OPT_FALLBACK which was confusing since the _request_firmware function
>> was always checking for FW_OPT_USERHELPER (the same bit in a relevant
>> configuration).
>>
>> With this patch FW_OPT_USERHELPER gets its own bit and is explicitly
>> checked in the _request_firmware which hopefully makes code easier to
>> understand.
>>
>> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
>> ---
>> V2: s/config_enabled/IS_ENABLED/ to compile since c0a0aba8e47 ("kconfig.h: remove config_enabled() macro")
>> ---
>>  drivers/base/firmware_class.c | 12 ++++++------
>>  1 file changed, 6 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
>> index 22d1760..0e1d5b8 100644
>> --- a/drivers/base/firmware_class.c
>> +++ b/drivers/base/firmware_class.c
>> @@ -112,13 +112,9 @@ static inline long firmware_loading_timeout(void)
>>  #else
>>  #define FW_OPT_USERHELPER    0
>>  #endif
>> -#ifdef CONFIG_FW_LOADER_USER_HELPER_FALLBACK
>> -#define FW_OPT_FALLBACK              FW_OPT_USERHELPER
>> -#else
>> -#define FW_OPT_FALLBACK              0
>> -#endif
>>  #define FW_OPT_NO_WARN       (1U << 3)
>>  #define FW_OPT_NOCACHE       (1U << 4)
>> +#define FW_OPT_FALLBACK      (1U << 5)
>>
>>  struct firmware_cache {
>>       /* firmware_buf instance will be added into the below list */
>> @@ -1175,8 +1171,12 @@ _request_firmware(const struct firmware **firmware_p, const char *name,
>>                       dev_warn(device,
>>                                "Direct firmware load for %s failed with error %d\n",
>>                                name, ret);
>> -             if (opt_flags & FW_OPT_USERHELPER) {
>> +             if (IS_ENABLED(CONFIG_FW_LOADER_USER_HELPER_FALLBACK) &&
>> +                 opt_flags & FW_OPT_FALLBACK) {
>
> When mixing logical and binary expressions I would suggest putting the
> binary expression between brackets.

I checked my patch with checkpatch.pl before sending and it didn't
complain. I just re-read CodingStyle but I didn't find any info on
this.

It this some upstream-documented preference for coding style?

-- 
Rafał

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-12-12 10:24 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-12-11 13:26 [PATCH] firmware: simplify defining and handling FW_OPT_FALLBACK Rafał Miłecki
2016-12-11 21:21 ` [PATCH V2] " Rafał Miłecki
     [not found]   ` <6ad5eb68-37c2-482c-395e-b6544a599046@broadcom.com>
2016-12-12 10:24     ` Rafał Miłecki

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.