All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] Change name of live migration thread
@ 2017-01-22  7:17 Pankaj Gupta
  2017-01-23  5:40 ` Amit Shah
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Pankaj Gupta @ 2017-01-22  7:17 UTC (permalink / raw)
  To: qemu-devel; +Cc: quintela, amit.shah, dgilbert

Change the name of live migration thread from 'migration' 
to 'qemu_vm_migration' to identify it clearly. 'migration'
is a generic word and kernel also has  tasks for process
migration with the name 'migration/cpu#'.

Signed-off-by: Pankaj Gupta <pagupta@redhat.com>
---
 migration/migration.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/migration/migration.c b/migration/migration.c
index f498ab8..6ebd606 100644
--- a/migration/migration.c
+++ b/migration/migration.c
@@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s)
     }
 
     migrate_compress_threads_create();
-    qemu_thread_create(&s->thread, "migration", migration_thread, s,
+    qemu_thread_create(&s->thread, "qemu_vm_migration", migration_thread, s,
                        QEMU_THREAD_JOINABLE);
     s->migration_thread_running = true;
 }
-- 
2.7.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-22  7:17 [Qemu-devel] [PATCH] Change name of live migration thread Pankaj Gupta
@ 2017-01-23  5:40 ` Amit Shah
  2017-01-23  9:18   ` Paolo Bonzini
  2017-01-23  8:42 ` Juan Quintela
  2017-01-23  9:17 ` Dr. David Alan Gilbert
  2 siblings, 1 reply; 7+ messages in thread
From: Amit Shah @ 2017-01-23  5:40 UTC (permalink / raw)
  To: Pankaj Gupta; +Cc: qemu-devel, quintela, dgilbert

On (Sun) 22 Jan 2017 [12:47:51], Pankaj Gupta wrote:
> Change the name of live migration thread from 'migration' 
> to 'qemu_vm_migration' to identify it clearly. 'migration'
> is a generic word and kernel also has  tasks for process
> migration with the name 'migration/cpu#'.

Makes sense.

Reviewed-by: Amit Shah <amit.shah@redhat.com>

		Amit

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-22  7:17 [Qemu-devel] [PATCH] Change name of live migration thread Pankaj Gupta
  2017-01-23  5:40 ` Amit Shah
@ 2017-01-23  8:42 ` Juan Quintela
  2017-01-23  9:17 ` Dr. David Alan Gilbert
  2 siblings, 0 replies; 7+ messages in thread
From: Juan Quintela @ 2017-01-23  8:42 UTC (permalink / raw)
  To: Pankaj Gupta; +Cc: qemu-devel, amit.shah, dgilbert

Pankaj Gupta <pagupta@redhat.com> wrote:
> Change the name of live migration thread from 'migration' 
> to 'qemu_vm_migration' to identify it clearly. 'migration'
> is a generic word and kernel also has  tasks for process
> migration with the name 'migration/cpu#'.
>
> Signed-off-by: Pankaj Gupta <pagupta@redhat.com>

Reviewed-by: Juan Quintela <quintela@redhat.com>

Once here, I will change the name of the compression threads.

Thanks, Juan.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-22  7:17 [Qemu-devel] [PATCH] Change name of live migration thread Pankaj Gupta
  2017-01-23  5:40 ` Amit Shah
  2017-01-23  8:42 ` Juan Quintela
@ 2017-01-23  9:17 ` Dr. David Alan Gilbert
  2017-01-23 10:58   ` Pankaj Gupta
  2 siblings, 1 reply; 7+ messages in thread
From: Dr. David Alan Gilbert @ 2017-01-23  9:17 UTC (permalink / raw)
  To: Pankaj Gupta; +Cc: qemu-devel, quintela, amit.shah

* Pankaj Gupta (pagupta@redhat.com) wrote:
> Change the name of live migration thread from 'migration' 
> to 'qemu_vm_migration' to identify it clearly. 'migration'
> is a generic word and kernel also has  tasks for process
> migration with the name 'migration/cpu#'.
> 
> Signed-off-by: Pankaj Gupta <pagupta@redhat.com>
> ---
>  migration/migration.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/migration/migration.c b/migration/migration.c
> index f498ab8..6ebd606 100644
> --- a/migration/migration.c
> +++ b/migration/migration.c
> @@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s)
>      }
>  
>      migrate_compress_threads_create();
> -    qemu_thread_create(&s->thread, "migration", migration_thread, s,
> +    qemu_thread_create(&s->thread, "qemu_vm_migration", migration_thread, s,
>                         QEMU_THREAD_JOINABLE);

Are you sure that works?  For me it doesn't change the name.

There's a maximum length that I think is somewhere around 16 characters and that
name is too long.

Changing it to "qemu_migration" seems to work.

Dave

>      s->migration_thread_running = true;
>  }
> -- 
> 2.7.4
> 
--
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-23  5:40 ` Amit Shah
@ 2017-01-23  9:18   ` Paolo Bonzini
  2017-01-23 11:05     ` Pankaj Gupta
  0 siblings, 1 reply; 7+ messages in thread
From: Paolo Bonzini @ 2017-01-23  9:18 UTC (permalink / raw)
  To: Amit Shah, Pankaj Gupta; +Cc: qemu-devel, dgilbert, quintela



On 23/01/2017 06:40, Amit Shah wrote:
> On (Sun) 22 Jan 2017 [12:47:51], Pankaj Gupta wrote:
>> Change the name of live migration thread from 'migration' 
>> to 'qemu_vm_migration' to identify it clearly. 'migration'
>> is a generic word and kernel also has  tasks for process
>> migration with the name 'migration/cpu#'.
> 
> Makes sense.
> 
> Reviewed-by: Amit Shah <amit.shah@redhat.com>

It's a bit ugly that no other thread name has qemu in it, and the limit
is 15 characters---which is more than "qemu_vm_migration"'s length.  So
maybe "live_migration" or "migrate" would be better.

Spaces vs. underscores are also inconsistent.  A patch to fix that would
be helpful!

Paolo

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-23  9:17 ` Dr. David Alan Gilbert
@ 2017-01-23 10:58   ` Pankaj Gupta
  0 siblings, 0 replies; 7+ messages in thread
From: Pankaj Gupta @ 2017-01-23 10:58 UTC (permalink / raw)
  To: Dr. David Alan Gilbert; +Cc: qemu-devel, quintela, amit shah


Hi Dave,

> > Change the name of live migration thread from 'migration'
> > to 'qemu_vm_migration' to identify it clearly. 'migration'
> > is a generic word and kernel also has  tasks for process
> > migration with the name 'migration/cpu#'.
> > 
> > Signed-off-by: Pankaj Gupta <pagupta@redhat.com>
> > ---
> >  migration/migration.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/migration/migration.c b/migration/migration.c
> > index f498ab8..6ebd606 100644
> > --- a/migration/migration.c
> > +++ b/migration/migration.c
> > @@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s)
> >      }
> >  
> >      migrate_compress_threads_create();
> > -    qemu_thread_create(&s->thread, "migration", migration_thread, s,
> > +    qemu_thread_create(&s->thread, "qemu_vm_migration", migration_thread,
> > s,
> >                         QEMU_THREAD_JOINABLE);
> 
> Are you sure that works?  For me it doesn't change the name.
> 
> There's a maximum length that I think is somewhere around 16 characters and
> that
> name is too long.
> 
> Changing it to "qemu_migration" seems to work.

Thanks for pointing out.
I will send a v2.

> 
> Dave
> 
> >      s->migration_thread_running = true;
> >  }
> > --
> > 2.7.4
> > 
> --
> Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [Qemu-devel] [PATCH] Change name of live migration thread
  2017-01-23  9:18   ` Paolo Bonzini
@ 2017-01-23 11:05     ` Pankaj Gupta
  0 siblings, 0 replies; 7+ messages in thread
From: Pankaj Gupta @ 2017-01-23 11:05 UTC (permalink / raw)
  To: Paolo Bonzini; +Cc: Amit Shah, qemu-devel, dgilbert, quintela

Hi Paolo,

> > On (Sun) 22 Jan 2017 [12:47:51], Pankaj Gupta wrote:
> >> Change the name of live migration thread from 'migration'
> >> to 'qemu_vm_migration' to identify it clearly. 'migration'
> >> is a generic word and kernel also has  tasks for process
> >> migration with the name 'migration/cpu#'.
> > 
> > Makes sense.
> > 
> > Reviewed-by: Amit Shah <amit.shah@redhat.com>
> 
> It's a bit ugly that no other thread name has qemu in it, and the limit
> is 15 characters---which is more than "qemu_vm_migration"'s length.  So
> maybe "live_migration" or "migrate" would be better.

Thanks for the suggestion.
"live_migration" seems like good option.
> 
> Spaces vs. underscores are also inconsistent.  A patch to fix that would
> be helpful!

Sure, will do that.
> 
> Paolo
> 

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2017-01-23 11:06 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-01-22  7:17 [Qemu-devel] [PATCH] Change name of live migration thread Pankaj Gupta
2017-01-23  5:40 ` Amit Shah
2017-01-23  9:18   ` Paolo Bonzini
2017-01-23 11:05     ` Pankaj Gupta
2017-01-23  8:42 ` Juan Quintela
2017-01-23  9:17 ` Dr. David Alan Gilbert
2017-01-23 10:58   ` Pankaj Gupta

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.