All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/2 v4] staging: speakup: Clean up parentheses
@ 2017-02-28  6:40 Sreya Mittal
  2017-02-28  8:21 ` Greg Kroah-Hartman
  0 siblings, 1 reply; 2+ messages in thread
From: Sreya Mittal @ 2017-02-28  6:40 UTC (permalink / raw)
  To: outreachy-kernel
  Cc: Sreya Mittal, William Hubbs, Chris Brannon, Kirk Reiser,
	Samuel Thibault, Greg Kroah-Hartman

Align next line of print statements
to the right of open parentheses and
remove extra parentheses.

Signed-off-by: Sreya Mittal <sreyamittal5@gmail.com>
---

No changes from previous patch.

 drivers/staging/speakup/keyhelp.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/speakup/keyhelp.c b/drivers/staging/speakup/keyhelp.c
index ce94cb1..c373762 100644
--- a/drivers/staging/speakup/keyhelp.c
+++ b/drivers/staging/speakup/keyhelp.c
@@ -115,9 +115,9 @@ static void say_key(int key)
 		if (state & masks[i])
 			synth_printf(" %s", spk_msg_get(MSG_STATES_START + i));
 	}
-	if ((key > 0) && (key <= num_key_names))
+	if (key > 0 && key <= num_key_names)
 		synth_printf(" %s\n",
-				spk_msg_get(MSG_KEYNAMES_START + (key - 1)));
+			     spk_msg_get(MSG_KEYNAMES_START + (key - 1)));
 }
 
 static int help_init(void)
@@ -164,7 +164,7 @@ int spk_handle_help(struct vc_data *vc, u_char type, u_char ch, u_short key)
 		cur_item = letter_offsets[ch - 'a'];
 	} else if (type == KT_CUR) {
 		if (ch == 0
-		    && (MSG_FUNCNAMES_START + cur_item + 1) <=
+		    && MSG_FUNCNAMES_START + cur_item + 1 <=
 		    MSG_FUNCNAMES_END)
 			cur_item++;
 		else if (ch == 3 && cur_item > 0)
@@ -180,9 +180,9 @@ int spk_handle_help(struct vc_data *vc, u_char type, u_char ch, u_short key)
 		return 1;
 	} else {
 		name = NULL;
-		if ((type != KT_SPKUP) && (key > 0) && (key <= num_key_names)) {
+		if (type != KT_SPKUP && key > 0 && key <= num_key_names) {
 			synth_printf("%s\n",
-				spk_msg_get(MSG_KEYNAMES_START + key - 1));
+				     spk_msg_get(MSG_KEYNAMES_START + key - 1));
 			return 1;
 		}
 		for (i = 0; funcvals[i] != 0 && !name; i++) {
-- 
2.9.3



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1/2 v4] staging: speakup: Clean up parentheses
  2017-02-28  6:40 [PATCH 1/2 v4] staging: speakup: Clean up parentheses Sreya Mittal
@ 2017-02-28  8:21 ` Greg Kroah-Hartman
  0 siblings, 0 replies; 2+ messages in thread
From: Greg Kroah-Hartman @ 2017-02-28  8:21 UTC (permalink / raw)
  To: Sreya Mittal
  Cc: outreachy-kernel, William Hubbs, Chris Brannon, Kirk Reiser,
	Samuel Thibault

On Tue, Feb 28, 2017 at 12:10:42PM +0530, Sreya Mittal wrote:
> Align next line of print statements
> to the right of open parentheses and
> remove extra parentheses.
> 
> Signed-off-by: Sreya Mittal <sreyamittal5@gmail.com>
> ---
> 
> No changes from previous patch.
> 
>  drivers/staging/speakup/keyhelp.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/staging/speakup/keyhelp.c b/drivers/staging/speakup/keyhelp.c
> index ce94cb1..c373762 100644
> --- a/drivers/staging/speakup/keyhelp.c
> +++ b/drivers/staging/speakup/keyhelp.c
> @@ -115,9 +115,9 @@ static void say_key(int key)
>  		if (state & masks[i])
>  			synth_printf(" %s", spk_msg_get(MSG_STATES_START + i));
>  	}
> -	if ((key > 0) && (key <= num_key_names))
> +	if (key > 0 && key <= num_key_names)

Why are these "extra"?  They make sense to keep to me, they make it more
obvious to the reader what is going on here.

>  		synth_printf(" %s\n",
> -				spk_msg_get(MSG_KEYNAMES_START + (key - 1)));
> +			     spk_msg_get(MSG_KEYNAMES_START + (key - 1)));

This is a different type of change than the one above, so it should be
in a separate patch.  Rememeber, only do one "type" of thing per patch.

>  static int help_init(void)
> @@ -164,7 +164,7 @@ int spk_handle_help(struct vc_data *vc, u_char type, u_char ch, u_short key)
>  		cur_item = letter_offsets[ch - 'a'];
>  	} else if (type == KT_CUR) {
>  		if (ch == 0
> -		    && (MSG_FUNCNAMES_START + cur_item + 1) <=
> +		    && MSG_FUNCNAMES_START + cur_item + 1 <=
>  		    MSG_FUNCNAMES_END)

Again, ick, no.

Really, the statement should look like:
 		if (ch == 0 &&
		    (MSG_FUNCNAMES_START + cur_item + 1) <= MSG_FUNCNAMES_END)

which is much more readable by a person, don't you think?

thanks,

greg k-h


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2017-02-28  8:21 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-02-28  6:40 [PATCH 1/2 v4] staging: speakup: Clean up parentheses Sreya Mittal
2017-02-28  8:21 ` Greg Kroah-Hartman

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.