All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] cgroup: switch to BUG_ON()
@ 2017-03-26 16:24 Nicholas Mc Guire
  2017-03-27 17:59 ` Tejun Heo
  2017-04-05  5:50 ` Zefan Li
  0 siblings, 2 replies; 3+ messages in thread
From: Nicholas Mc Guire @ 2017-03-26 16:24 UTC (permalink / raw)
  To: Tejun Heo
  Cc: Zefan Li, Andrew Morton, Michal Hocko, Vlastimil Babka,
	Ingo Molnar, Joonwoo Park, Miao Xie, linux-kernel,
	Nicholas Mc Guire

Use BUG_ON() rather than an explicit if followed by BUG() for 
improved readability and also consistency.

Signed-off-by: Nicholas Mc Guire <der.herr@hofr.at>
---

Found by coccinelle: bugon.cocci
./kernel/cgroup/cpuset.c:2125:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
./kernel/cgroup/cpuset.c:2127:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
./kernel/cgroup/cpuset.c:2143:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.

BUG_ON() wraps the explicit if condition and is actually in use for
all conditional BUG() cases in cpuset.c except in this one function.

Patch was compile-tested with: x86_64_defconfig (implies CONFIG_CPUSETS=y)
(checkpatch warnings for this patch seem to be false-positives - the 
 BUG_ON should be fine)

Patch is against 4.11-rc3 (localversion-next is next-20170324)

 kernel/cgroup/cpuset.c | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

diff --git a/kernel/cgroup/cpuset.c b/kernel/cgroup/cpuset.c
index 0f41292..8b84db2 100644
--- a/kernel/cgroup/cpuset.c
+++ b/kernel/cgroup/cpuset.c
@@ -2121,10 +2121,8 @@ int __init cpuset_init(void)
 {
 	int err = 0;
 
-	if (!alloc_cpumask_var(&top_cpuset.cpus_allowed, GFP_KERNEL))
-		BUG();
-	if (!alloc_cpumask_var(&top_cpuset.effective_cpus, GFP_KERNEL))
-		BUG();
+	BUG_ON(!alloc_cpumask_var(&top_cpuset.cpus_allowed, GFP_KERNEL));
+	BUG_ON(!alloc_cpumask_var(&top_cpuset.effective_cpus, GFP_KERNEL));
 
 	cpumask_setall(top_cpuset.cpus_allowed);
 	nodes_setall(top_cpuset.mems_allowed);
@@ -2139,8 +2137,7 @@ int __init cpuset_init(void)
 	if (err < 0)
 		return err;
 
-	if (!alloc_cpumask_var(&cpus_attach, GFP_KERNEL))
-		BUG();
+	BUG_ON(!alloc_cpumask_var(&cpus_attach, GFP_KERNEL));
 
 	return 0;
 }
-- 
2.1.4

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] cgroup: switch to BUG_ON()
  2017-03-26 16:24 [PATCH] cgroup: switch to BUG_ON() Nicholas Mc Guire
@ 2017-03-27 17:59 ` Tejun Heo
  2017-04-05  5:50 ` Zefan Li
  1 sibling, 0 replies; 3+ messages in thread
From: Tejun Heo @ 2017-03-27 17:59 UTC (permalink / raw)
  To: Nicholas Mc Guire
  Cc: Zefan Li, Andrew Morton, Michal Hocko, Vlastimil Babka,
	Ingo Molnar, Joonwoo Park, Miao Xie, linux-kernel

On Sun, Mar 26, 2017 at 06:24:06PM +0200, Nicholas Mc Guire wrote:
> Use BUG_ON() rather than an explicit if followed by BUG() for 
> improved readability and also consistency.
> 
> Signed-off-by: Nicholas Mc Guire <der.herr@hofr.at>

Applied to cgroup/for-4.12.

Thanks.

-- 
tejun

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] cgroup: switch to BUG_ON()
  2017-03-26 16:24 [PATCH] cgroup: switch to BUG_ON() Nicholas Mc Guire
  2017-03-27 17:59 ` Tejun Heo
@ 2017-04-05  5:50 ` Zefan Li
  1 sibling, 0 replies; 3+ messages in thread
From: Zefan Li @ 2017-04-05  5:50 UTC (permalink / raw)
  To: Nicholas Mc Guire, Tejun Heo
  Cc: Andrew Morton, Michal Hocko, Vlastimil Babka, Ingo Molnar,
	Joonwoo Park, linux-kernel

On 2017/3/27 0:24, Nicholas Mc Guire wrote:
> Use BUG_ON() rather than an explicit if followed by BUG() for 
> improved readability and also consistency.
> 
> Signed-off-by: Nicholas Mc Guire <der.herr@hofr.at>
> ---
> 
> Found by coccinelle: bugon.cocci
> ./kernel/cgroup/cpuset.c:2125:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2127:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2143:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> 
> BUG_ON() wraps the explicit if condition and is actually in use for
> all conditional BUG() cases in cpuset.c except in this one function.
> 
> Patch was compile-tested with: x86_64_defconfig (implies CONFIG_CPUSETS=y)
> (checkpatch warnings for this patch seem to be false-positives - the 
>  BUG_ON should be fine)
> 
> Patch is against 4.11-rc3 (localversion-next is next-20170324)
> 

Acked-by: Zefan Li <lizefan@huawei.com>

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2017-04-05  5:52 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-03-26 16:24 [PATCH] cgroup: switch to BUG_ON() Nicholas Mc Guire
2017-03-27 17:59 ` Tejun Heo
2017-04-05  5:50 ` Zefan Li

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.