All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: Kishon Vijay Abraham I <kishon@ti.com>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
	Joao Pinto <Joao.Pinto@synopsys.com>,
	Niklas Cassel <niklas.cassel@axis.com>,
	linux-omap@vger.kernel.org, linux-pci@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, nsekhar@ti.com
Subject: Re: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups
Date: Thu, 30 Mar 2017 18:44:50 -0500	[thread overview]
Message-ID: <20170330234450.GC3912@bhelgaas-glaptop.roam.corp.google.com> (raw)
In-Reply-To: <20170313134328.1588-1-kishon@ti.com>

On Mon, Mar 13, 2017 at 07:13:21PM +0530, Kishon Vijay Abraham I wrote:
> This should be the final set of cleanups/fixes before endpoint
> support can be merged.
> 
> Keerthy's patch is a general fix in dra7xx driver and is not
> directly related to endpoint mode.
> 
> This v1 of this series was previously sent with a different
> cover letter $subject [1]
> 
> Changes from v3:
> *) instead of changing all the callers of dbi accessors (taking
>    dbi_base and size), manage it using static inline as suggested
>    by Niklas (used static inline instead of macros because of
>    checkpatch error).
> 
> Changes from v2:
> *) Kconfig changes that was spilled into a patch is removed.
> *) In addition to renaming _unroll() to _ob_unroll(), all the
>    _unroll configurations is also moved a separate function.
> 
> Changes from v1:
> *) included a patch to rename _unroll() to _ob_unroll() as
>    similar thing has to be done for inbound window in the case
>    of EP mode.
> *) used 'size_t' instead of 'int' for specifying the size
>    in read_dbi/write_dbi function arguments.
> *) Populate cpu_addr_fixup ops for artpec6 as suggested by
>    Niklas
> 
> This series is based on 4.11-rc1
> 
> [1] -> https://lkml.org/lkml/2017/2/16/270
> 
> Keerthy (1):
>   PCI: dwc: dra7xx: Push request_irq call to the bottom of probe
> 
> Kishon Vijay Abraham I (6):
>   PCI: dwc: designware: Add new *ops* for cpu addr fixup
>   PCI: dwc: dra7xx: Populate cpu_addr_fixup ops
>   PCI: dwc: artpec6: Populate cpu_addr_fixup ops
>   PCI: dwc: all: Modify dbi accessors to take dbi_base as argument
>   PCI: dwc: all: Modify dbi accessors to access data of  4/2/1 bytes
>   PCI: dwc: designware: Move _unroll configurations to a separate
>     function
> 
>  drivers/pci/dwc/pci-dra7xx.c      |  25 +++----
>  drivers/pci/dwc/pci-exynos.c      |  14 ++--
>  drivers/pci/dwc/pcie-artpec6.c    |  15 +++--
>  drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++--------------
>  drivers/pci/dwc/pcie-designware.h |  23 +++++--
>  5 files changed, 135 insertions(+), 75 deletions(-)

Applied to pci/host-designware for v4.12, with Niklas' ack on patches
4 & 5, thanks!

WARNING: multiple messages have this Message-ID (diff)
From: Bjorn Helgaas <helgaas@kernel.org>
To: Kishon Vijay Abraham I <kishon@ti.com>
Cc: Joao Pinto <Joao.Pinto@synopsys.com>,
	linux-pci@vger.kernel.org, nsekhar@ti.com,
	linux-kernel@vger.kernel.org,
	Niklas Cassel <niklas.cassel@axis.com>,
	Bjorn Helgaas <bhelgaas@google.com>,
	linux-omap@vger.kernel.org, linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups
Date: Thu, 30 Mar 2017 18:44:50 -0500	[thread overview]
Message-ID: <20170330234450.GC3912@bhelgaas-glaptop.roam.corp.google.com> (raw)
In-Reply-To: <20170313134328.1588-1-kishon@ti.com>

On Mon, Mar 13, 2017 at 07:13:21PM +0530, Kishon Vijay Abraham I wrote:
> This should be the final set of cleanups/fixes before endpoint
> support can be merged.
> 
> Keerthy's patch is a general fix in dra7xx driver and is not
> directly related to endpoint mode.
> 
> This v1 of this series was previously sent with a different
> cover letter $subject [1]
> 
> Changes from v3:
> *) instead of changing all the callers of dbi accessors (taking
>    dbi_base and size), manage it using static inline as suggested
>    by Niklas (used static inline instead of macros because of
>    checkpatch error).
> 
> Changes from v2:
> *) Kconfig changes that was spilled into a patch is removed.
> *) In addition to renaming _unroll() to _ob_unroll(), all the
>    _unroll configurations is also moved a separate function.
> 
> Changes from v1:
> *) included a patch to rename _unroll() to _ob_unroll() as
>    similar thing has to be done for inbound window in the case
>    of EP mode.
> *) used 'size_t' instead of 'int' for specifying the size
>    in read_dbi/write_dbi function arguments.
> *) Populate cpu_addr_fixup ops for artpec6 as suggested by
>    Niklas
> 
> This series is based on 4.11-rc1
> 
> [1] -> https://lkml.org/lkml/2017/2/16/270
> 
> Keerthy (1):
>   PCI: dwc: dra7xx: Push request_irq call to the bottom of probe
> 
> Kishon Vijay Abraham I (6):
>   PCI: dwc: designware: Add new *ops* for cpu addr fixup
>   PCI: dwc: dra7xx: Populate cpu_addr_fixup ops
>   PCI: dwc: artpec6: Populate cpu_addr_fixup ops
>   PCI: dwc: all: Modify dbi accessors to take dbi_base as argument
>   PCI: dwc: all: Modify dbi accessors to access data of  4/2/1 bytes
>   PCI: dwc: designware: Move _unroll configurations to a separate
>     function
> 
>  drivers/pci/dwc/pci-dra7xx.c      |  25 +++----
>  drivers/pci/dwc/pci-exynos.c      |  14 ++--
>  drivers/pci/dwc/pcie-artpec6.c    |  15 +++--
>  drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++--------------
>  drivers/pci/dwc/pcie-designware.h |  23 +++++--
>  5 files changed, 135 insertions(+), 75 deletions(-)

Applied to pci/host-designware for v4.12, with Niklas' ack on patches
4 & 5, thanks!

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: helgaas@kernel.org (Bjorn Helgaas)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups
Date: Thu, 30 Mar 2017 18:44:50 -0500	[thread overview]
Message-ID: <20170330234450.GC3912@bhelgaas-glaptop.roam.corp.google.com> (raw)
In-Reply-To: <20170313134328.1588-1-kishon@ti.com>

On Mon, Mar 13, 2017 at 07:13:21PM +0530, Kishon Vijay Abraham I wrote:
> This should be the final set of cleanups/fixes before endpoint
> support can be merged.
> 
> Keerthy's patch is a general fix in dra7xx driver and is not
> directly related to endpoint mode.
> 
> This v1 of this series was previously sent with a different
> cover letter $subject [1]
> 
> Changes from v3:
> *) instead of changing all the callers of dbi accessors (taking
>    dbi_base and size), manage it using static inline as suggested
>    by Niklas (used static inline instead of macros because of
>    checkpatch error).
> 
> Changes from v2:
> *) Kconfig changes that was spilled into a patch is removed.
> *) In addition to renaming _unroll() to _ob_unroll(), all the
>    _unroll configurations is also moved a separate function.
> 
> Changes from v1:
> *) included a patch to rename _unroll() to _ob_unroll() as
>    similar thing has to be done for inbound window in the case
>    of EP mode.
> *) used 'size_t' instead of 'int' for specifying the size
>    in read_dbi/write_dbi function arguments.
> *) Populate cpu_addr_fixup ops for artpec6 as suggested by
>    Niklas
> 
> This series is based on 4.11-rc1
> 
> [1] -> https://lkml.org/lkml/2017/2/16/270
> 
> Keerthy (1):
>   PCI: dwc: dra7xx: Push request_irq call to the bottom of probe
> 
> Kishon Vijay Abraham I (6):
>   PCI: dwc: designware: Add new *ops* for cpu addr fixup
>   PCI: dwc: dra7xx: Populate cpu_addr_fixup ops
>   PCI: dwc: artpec6: Populate cpu_addr_fixup ops
>   PCI: dwc: all: Modify dbi accessors to take dbi_base as argument
>   PCI: dwc: all: Modify dbi accessors to access data of  4/2/1 bytes
>   PCI: dwc: designware: Move _unroll configurations to a separate
>     function
> 
>  drivers/pci/dwc/pci-dra7xx.c      |  25 +++----
>  drivers/pci/dwc/pci-exynos.c      |  14 ++--
>  drivers/pci/dwc/pcie-artpec6.c    |  15 +++--
>  drivers/pci/dwc/pcie-designware.c | 133 ++++++++++++++++++++++++--------------
>  drivers/pci/dwc/pcie-designware.h |  23 +++++--
>  5 files changed, 135 insertions(+), 75 deletions(-)

Applied to pci/host-designware for v4.12, with Niklas' ack on patches
4 & 5, thanks!

  parent reply	other threads:[~2017-03-30 23:44 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-03-13 13:43 [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Kishon Vijay Abraham I
2017-03-13 13:43 ` Kishon Vijay Abraham I
2017-03-13 13:43 ` Kishon Vijay Abraham I
2017-03-13 13:43 ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 1/7] PCI: dwc: designware: Add new *ops* for cpu addr fixup Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 2/7] PCI: dwc: dra7xx: Populate cpu_addr_fixup ops Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 3/7] PCI: dwc: artpec6: " Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 4/7] PCI: dwc: all: Modify dbi accessors to take dbi_base as argument Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 14:30   ` Niklas Cassel
2017-03-13 14:30     ` Niklas Cassel
2017-03-13 14:30     ` Niklas Cassel
2017-03-22 15:10   ` [PATCH v5 " Kishon Vijay Abraham I
2017-03-22 15:10     ` Kishon Vijay Abraham I
2017-03-22 15:10     ` Kishon Vijay Abraham I
2017-03-22 15:10     ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 5/7] PCI: dwc: all: Modify dbi accessors to access data of 4/2/1 bytes Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 14:32   ` Niklas Cassel
2017-03-13 14:32     ` Niklas Cassel
2017-03-13 14:32     ` Niklas Cassel
2017-03-13 13:43 ` [PATCH v4 6/7] PCI: dwc: designware: Move _unroll configurations to a separate function Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43 ` [PATCH v4 7/7] PCI: dwc: dra7xx: Push request_irq call to the bottom of probe Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-13 13:43   ` Kishon Vijay Abraham I
2017-03-30 23:44 ` Bjorn Helgaas [this message]
2017-03-30 23:44   ` [PATCH v4 0/7] PCI: dwc: Miscellaneous fixes and cleanups Bjorn Helgaas
2017-03-30 23:44   ` Bjorn Helgaas
2017-03-31  4:44   ` Kishon Vijay Abraham I
2017-03-31  4:44     ` Kishon Vijay Abraham I
2017-03-31  4:44     ` Kishon Vijay Abraham I

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170330234450.GC3912@bhelgaas-glaptop.roam.corp.google.com \
    --to=helgaas@kernel.org \
    --cc=Joao.Pinto@synopsys.com \
    --cc=bhelgaas@google.com \
    --cc=kishon@ti.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-omap@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=niklas.cassel@axis.com \
    --cc=nsekhar@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.