All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Johannes Thumshirn <jthumshirn@suse.de>
Cc: Christoph Hellwig <hch@lst.de>, Sagi Grimberg <sagi@grimberg.me>,
	Keith Busch <keith.busch@intel.com>,
	Hannes Reinecke <hare@suse.de>,
	maxg@mellanox.com,
	Linux NVMe Mailinglist <linux-nvme@lists.infradead.org>,
	Linux Kernel Mailinglist <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 7/8] nvmet: allow overriding the NVMe VS via configfs
Date: Mon, 5 Jun 2017 07:45:11 +0200	[thread overview]
Message-ID: <20170605054511.GF19480@lst.de> (raw)
In-Reply-To: <20170604103649.22130-8-jthumshirn@suse.de>

On Sun, Jun 04, 2017 at 12:36:48PM +0200, Johannes Thumshirn wrote:
> Allow overriding the announced NVMe Version of a via configfs.
> 
> This is particularly helpful when debugging new features for the host
> or target side without bumping the hard coded version (as the target
> might not be fully compliant to the announced version yet).
> 
> Signed-off-by: Johannes Thumshirn <jthumshirn@suse.de>
> ---
>  drivers/nvme/target/configfs.c | 34 ++++++++++++++++++++++++++++++++++
>  include/linux/nvme.h           |  4 ++++
>  2 files changed, 38 insertions(+)
> 
> diff --git a/drivers/nvme/target/configfs.c b/drivers/nvme/target/configfs.c
> index 16f9f6e3a084..45421d4308a4 100644
> --- a/drivers/nvme/target/configfs.c
> +++ b/drivers/nvme/target/configfs.c
> @@ -650,8 +650,42 @@ static ssize_t nvmet_subsys_attr_allow_any_host_store(struct config_item *item,
>  
>  CONFIGFS_ATTR(nvmet_subsys_, attr_allow_any_host);
>  
> +static ssize_t nvmet_subsys_version_show(struct config_item *item,
> +					      char *page)
> +{
> +	struct nvmet_subsys *subsys = to_subsys(item);
> +	int major, minor, tertiary;
> +	u32 ver;
> +
> +	ver = subsys->ver;
> +	major = NVME_MAJOR(ver);
> +	minor = NVME_MINOR(ver);
> +	tertiary = NVME_TERRIARY(ver);
> +
> +	return snprintf(page, PAGE_SIZE, "%d %d %d\n", major, minor, tertiary);

Nit Dop we really need all these variables?  Why not:

	return snprintf(page, PAGE_SIZE, "%d %d %d\n", NVME_MAJOR(subsys->ver), 
			NVME_MINOR(subsys->ver),  NVME_TERRIARY(subsys->ver));

?

Also except for the 1.2.1 oddbackk NVMe versions usually have two
components, and should be printed as such if the tertiary version is
0.


> +static ssize_t nvmet_subsys_version_store(struct config_item *item,
> +					       const char *page, size_t count)
> +{
> +	struct nvmet_subsys *subsys = to_subsys(item);
> +	int major, minor, tertiary;
> +	int ret;
> +
> +
> +	ret = sscanf(page, "%d %d %d\n", &major, &minor, &tertiary);
> +	if (ret != 3)
> +		return -EINVAL;

Same issue here.  I also have to say I'm a bit sceptical about
just being able to set versions as there are various dependencies
on it.  E.g. for 1.0 the version field in identify namespace doesn't
even exists and should be cleared to 0.

> +
> +	subsys->ver = NVME_VS(major, minor, tertiary);

locking?

> diff --git a/include/linux/nvme.h b/include/linux/nvme.h
> index afa6ef484e50..0d6e307a7aa4 100644
> --- a/include/linux/nvme.h
> +++ b/include/linux/nvme.h
> @@ -1069,4 +1069,8 @@ struct nvme_completion {
>  #define NVME_VS(major, minor, tertiary) \
>  	(((major) << 16) | ((minor) << 8) | (tertiary))
>  
> +#define NVME_MAJOR(ver)		((ver) >> 16)
> +#define NVME_MINOR(ver)		(((ver) >> 8) & 0xff)
> +#define NVME_TERRIARY(ver)	((ver) & 0xff)

I think TERRIARY should be TERTIARY.

WARNING: multiple messages have this Message-ID (diff)
From: hch@lst.de (Christoph Hellwig)
Subject: [PATCH v4 7/8] nvmet: allow overriding the NVMe VS via configfs
Date: Mon, 5 Jun 2017 07:45:11 +0200	[thread overview]
Message-ID: <20170605054511.GF19480@lst.de> (raw)
In-Reply-To: <20170604103649.22130-8-jthumshirn@suse.de>

On Sun, Jun 04, 2017@12:36:48PM +0200, Johannes Thumshirn wrote:
> Allow overriding the announced NVMe Version of a via configfs.
> 
> This is particularly helpful when debugging new features for the host
> or target side without bumping the hard coded version (as the target
> might not be fully compliant to the announced version yet).
> 
> Signed-off-by: Johannes Thumshirn <jthumshirn at suse.de>
> ---
>  drivers/nvme/target/configfs.c | 34 ++++++++++++++++++++++++++++++++++
>  include/linux/nvme.h           |  4 ++++
>  2 files changed, 38 insertions(+)
> 
> diff --git a/drivers/nvme/target/configfs.c b/drivers/nvme/target/configfs.c
> index 16f9f6e3a084..45421d4308a4 100644
> --- a/drivers/nvme/target/configfs.c
> +++ b/drivers/nvme/target/configfs.c
> @@ -650,8 +650,42 @@ static ssize_t nvmet_subsys_attr_allow_any_host_store(struct config_item *item,
>  
>  CONFIGFS_ATTR(nvmet_subsys_, attr_allow_any_host);
>  
> +static ssize_t nvmet_subsys_version_show(struct config_item *item,
> +					      char *page)
> +{
> +	struct nvmet_subsys *subsys = to_subsys(item);
> +	int major, minor, tertiary;
> +	u32 ver;
> +
> +	ver = subsys->ver;
> +	major = NVME_MAJOR(ver);
> +	minor = NVME_MINOR(ver);
> +	tertiary = NVME_TERRIARY(ver);
> +
> +	return snprintf(page, PAGE_SIZE, "%d %d %d\n", major, minor, tertiary);

Nit Dop we really need all these variables?  Why not:

	return snprintf(page, PAGE_SIZE, "%d %d %d\n", NVME_MAJOR(subsys->ver), 
			NVME_MINOR(subsys->ver),  NVME_TERRIARY(subsys->ver));

?

Also except for the 1.2.1 oddbackk NVMe versions usually have two
components, and should be printed as such if the tertiary version is
0.


> +static ssize_t nvmet_subsys_version_store(struct config_item *item,
> +					       const char *page, size_t count)
> +{
> +	struct nvmet_subsys *subsys = to_subsys(item);
> +	int major, minor, tertiary;
> +	int ret;
> +
> +
> +	ret = sscanf(page, "%d %d %d\n", &major, &minor, &tertiary);
> +	if (ret != 3)
> +		return -EINVAL;

Same issue here.  I also have to say I'm a bit sceptical about
just being able to set versions as there are various dependencies
on it.  E.g. for 1.0 the version field in identify namespace doesn't
even exists and should be cleared to 0.

> +
> +	subsys->ver = NVME_VS(major, minor, tertiary);

locking?

> diff --git a/include/linux/nvme.h b/include/linux/nvme.h
> index afa6ef484e50..0d6e307a7aa4 100644
> --- a/include/linux/nvme.h
> +++ b/include/linux/nvme.h
> @@ -1069,4 +1069,8 @@ struct nvme_completion {
>  #define NVME_VS(major, minor, tertiary) \
>  	(((major) << 16) | ((minor) << 8) | (tertiary))
>  
> +#define NVME_MAJOR(ver)		((ver) >> 16)
> +#define NVME_MINOR(ver)		(((ver) >> 8) & 0xff)
> +#define NVME_TERRIARY(ver)	((ver) & 0xff)

I think TERRIARY should be TERTIARY.

  parent reply	other threads:[~2017-06-05  5:45 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-06-04 10:36 [PATCH v4 0/8] Implement NVMe Namespace Descriptor Identification Johannes Thumshirn
2017-06-04 10:36 ` Johannes Thumshirn
2017-06-04 10:36 ` [PATCH v4 1/8] nvme: introduce NVMe Namespace Identification Descriptor structures Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 14:43   ` Sagi Grimberg
2017-06-04 14:43     ` Sagi Grimberg
2017-06-04 14:59   ` Sagi Grimberg
2017-06-04 14:59     ` Sagi Grimberg
2017-06-05  5:33     ` Christoph Hellwig
2017-06-05  5:33       ` Christoph Hellwig
2017-06-06  6:23   ` Hannes Reinecke
2017-06-06  6:23     ` Hannes Reinecke
2017-06-04 10:36 ` [PATCH v4 2/8] nvme: rename uuid to nguid in nvme_ns Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 14:43   ` Sagi Grimberg
2017-06-04 14:43     ` Sagi Grimberg
2017-06-04 10:36 ` [PATCH v4 3/8] nvmet: implement namespace identify descriptor list Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 15:00   ` Sagi Grimberg
2017-06-04 15:00     ` Sagi Grimberg
2017-06-05  5:35   ` Christoph Hellwig
2017-06-05  5:35     ` Christoph Hellwig
2017-06-06 12:04     ` Johannes Thumshirn
2017-06-06 12:04       ` Johannes Thumshirn
2017-06-06  6:23   ` Hannes Reinecke
2017-06-06  6:23     ` Hannes Reinecke
2017-06-04 10:36 ` [PATCH v4 4/8] nvmet: add uuid field to nvme_ns and populate via configfs Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 11:46   ` Max Gurtovoy
2017-06-04 11:46     ` Max Gurtovoy
2017-06-04 15:01   ` Sagi Grimberg
2017-06-04 15:01     ` Sagi Grimberg
2017-06-06  6:24   ` Hannes Reinecke
2017-06-06  6:24     ` Hannes Reinecke
2017-06-04 10:36 ` [PATCH v4 5/8] nvme: get list of namespace descriptors Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 15:06   ` Sagi Grimberg
2017-06-04 15:06     ` Sagi Grimberg
2017-06-05  5:38   ` Christoph Hellwig
2017-06-05  5:38     ` Christoph Hellwig
2017-06-06  7:15     ` Sagi Grimberg
2017-06-06  7:15       ` Sagi Grimberg
2017-06-06  6:24   ` Hannes Reinecke
2017-06-06  6:24     ` Hannes Reinecke
2017-06-04 10:36 ` [PATCH v4 6/8] nvme: provide UUID value to userspace Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 15:06   ` Sagi Grimberg
2017-06-04 15:06     ` Sagi Grimberg
2017-06-04 10:36 ` [PATCH v4 7/8] nvmet: allow overriding the NVMe VS via configfs Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 15:08   ` Sagi Grimberg
2017-06-04 15:08     ` Sagi Grimberg
2017-06-05  5:45   ` Christoph Hellwig [this message]
2017-06-05  5:45     ` Christoph Hellwig
2017-06-06  6:25   ` Hannes Reinecke
2017-06-06  6:25     ` Hannes Reinecke
2017-06-04 10:36 ` [PATCH v4 8/8] nvmet: use NVME_IDENTIFY_DATA_SIZE Johannes Thumshirn
2017-06-04 10:36   ` Johannes Thumshirn
2017-06-04 14:06   ` Max Gurtovoy
2017-06-04 14:06     ` Max Gurtovoy
2017-06-04 15:09   ` Sagi Grimberg
2017-06-04 15:09     ` Sagi Grimberg
2017-06-05  8:37   ` Christoph Hellwig
2017-06-05  8:37     ` Christoph Hellwig
2017-06-06  6:26   ` Hannes Reinecke
2017-06-06  6:26     ` Hannes Reinecke
2017-06-05  5:32 ` [PATCH v4 0/8] Implement NVMe Namespace Descriptor Identification Christoph Hellwig
2017-06-05  5:32   ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170605054511.GF19480@lst.de \
    --to=hch@lst.de \
    --cc=hare@suse.de \
    --cc=jthumshirn@suse.de \
    --cc=keith.busch@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvme@lists.infradead.org \
    --cc=maxg@mellanox.com \
    --cc=sagi@grimberg.me \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.