All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH v2 0/5] Create setup/cleanup methods for migration incoming side
@ 2017-06-13  9:53 Juan Quintela
  2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 1/5] migration: Rename save_live_setup() to save_setup() Juan Quintela
                   ` (4 more replies)
  0 siblings, 5 replies; 12+ messages in thread
From: Juan Quintela @ 2017-06-13  9:53 UTC (permalink / raw)
  To: qemu-devel; +Cc: dgilbert, lvivier, peterx, kwolf, stefanha

Hi

Changes from v1:
- Kevin detected that I didn't  called load_cleanup(), fix it.
- Be consistent and change the naming of the functions so they are all:
  qemu_savevm_state_* or qemu_loadvm_state*
- the traces still used the all names of _begin, instead of _setup,
  fix that.

Please, review.

Later, Juan.

PD: Yes, now that the includes are internal, we coauld rename
    "qemu_savevm_state_" to something shorter, like `savevm_".  The
    same for the loadvm counterparts.  But I am not doing any such
    changes soon, too much churn for so little gain.

[v1]
This series make:
- use of cleanup/save methods generic, not only for save_live methods
- create the equivalent methods for the load side (load_setup/cleanup)
- Make ram use this methods to see how/when they are used.

Stefan, Kevin, this were the methods that you asked for the block.c
migration, right?  Please, comment if they are enough for you.

Juan Quintela (5):
  migration: Rename save_live_setup() to save_setup()
  migration: Rename cleanup() to save_cleanup()
  migration: Create load_setup()/cleanup() methods
  migration: Convert ram to use new load_setup()/load_cleanup()
  migration: Make compression_threads use save/load_setup/cleanup()

 hw/ppc/spapr.c               |  4 +--
 include/migration/register.h |  6 ++--
 migration/block.c            |  4 +--
 migration/colo.c             |  2 +-
 migration/migration.c        | 10 +------
 migration/ram.c              | 66 ++++++++++++++++++++++++++++++--------------
 migration/ram.h              |  6 ----
 migration/savevm.c           | 60 ++++++++++++++++++++++++++++++++++------
 migration/savevm.h           |  2 +-
 migration/trace-events       |  4 ++-
 10 files changed, 111 insertions(+), 53 deletions(-)

-- 
2.9.4

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2017-06-21 11:33 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-06-13  9:53 [Qemu-devel] [PATCH v2 0/5] Create setup/cleanup methods for migration incoming side Juan Quintela
2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 1/5] migration: Rename save_live_setup() to save_setup() Juan Quintela
2017-06-16 17:30   ` Dr. David Alan Gilbert
2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 2/5] migration: Rename cleanup() to save_cleanup() Juan Quintela
2017-06-16 17:33   ` Dr. David Alan Gilbert
2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 3/5] migration: Create load_setup()/cleanup() methods Juan Quintela
2017-06-16 17:54   ` Dr. David Alan Gilbert
2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 4/5] migration: Convert ram to use new load_setup()/load_cleanup() Juan Quintela
2017-06-16 18:00   ` Dr. David Alan Gilbert
2017-06-21 11:33     ` Juan Quintela
2017-06-13  9:53 ` [Qemu-devel] [PATCH v2 5/5] migration: Make compression_threads use save/load_setup/cleanup() Juan Quintela
2017-06-16 18:04   ` Dr. David Alan Gilbert

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.