All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2 0/2] Avoid rewriting "packed-refs" unnecessarily
@ 2017-10-28  9:16 Michael Haggerty
  2017-10-28  9:16 ` [PATCH v2 1/2] t1409: check that `packed-refs` is not rewritten unnecessarily Michael Haggerty
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Michael Haggerty @ 2017-10-28  9:16 UTC (permalink / raw)
  To: Junio C Hamano; +Cc: Jeff King, Eric Sunshine, git, Michael Haggerty

This reroll make some logically small changes to v1 [1] that are
textually very big:

* Invert the sense of `is_packed_transaction_noop()` and rename it to
  `is_packed_transaction_needed()`. This makes the logic easier to
  follow and document.

* Add a big comment to that function, describing the cases when it
  returns false positives and explaining why that isn't a problem.

* In the commit message for patch 02, gives a lot more information
  about the regression that it is fixing. Thanks to Eric for the
  suggestion.

These patches are also available as branch
`avoid-rewriting-packed-refs` on my GitHub fork [2]. They now use
`mh/packed-ref-transactions` as the base, since that is where Junio
chose to apply v1.

Michael

[1] https://public-inbox.org/git/cover.1508924577.git.mhagger@alum.mit.edu/
[2] https://github.com/mhagger/git

Michael Haggerty (2):
  t1409: check that `packed-refs` is not rewritten unnecessarily
  files-backend: don't rewrite the `packed-refs` file unnecessarily

 refs/files-backend.c          |  18 ++++++-
 refs/packed-backend.c         |  94 +++++++++++++++++++++++++++++++++
 refs/packed-backend.h         |   9 ++++
 t/t1409-avoid-packing-refs.sh | 118 ++++++++++++++++++++++++++++++++++++++++++
 4 files changed, 238 insertions(+), 1 deletion(-)
 create mode 100755 t/t1409-avoid-packing-refs.sh

-- 
2.14.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2017-11-01  7:38 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-10-28  9:16 [PATCH v2 0/2] Avoid rewriting "packed-refs" unnecessarily Michael Haggerty
2017-10-28  9:16 ` [PATCH v2 1/2] t1409: check that `packed-refs` is not rewritten unnecessarily Michael Haggerty
2017-10-28  9:16 ` [PATCH v2 2/2] files-backend: don't rewrite the `packed-refs` file unnecessarily Michael Haggerty
2017-10-30  4:52   ` Junio C Hamano
2017-11-01  7:34 ` [PATCH v2 0/2] Avoid rewriting "packed-refs" unnecessarily Jeff King

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.