All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH net-next 0/2] nfp: bpf: rename ALU_OP_NEG and support BPF_NEG
@ 2017-11-01 17:38 Jakub Kicinski
  2017-11-01 17:38 ` [PATCH net-next 1/2] nfp: bpf: rename ALU_OP_NEG to ALU_OP_NOT Jakub Kicinski
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Jakub Kicinski @ 2017-11-01 17:38 UTC (permalink / raw)
  To: netdev; +Cc: oss-drivers, Jakub Kicinski

Jiong says:

  Compilers are starting to use BPF_NEG, for example LLVM. However, NFP
does not support JITing it. This patch set adds this. Unit test is added
as well.

  Meanwhile, the current NFP_ALU_NEG is actually doing bitwise NOT (one's
complement) operation, so the name is misleading. This patch set corrects
this.


Jiong Wang (2):
  nfp: bpf: rename ALU_OP_NEG to ALU_OP_NOT
  nfp: bpf: support [BPF_ALU | BPF_ALU64] | BPF_NEG

 drivers/net/ethernet/netronome/nfp/bpf/jit.c | 26 +++++++++++++++++++++++++-
 drivers/net/ethernet/netronome/nfp/nfp_asm.h |  2 +-
 2 files changed, 26 insertions(+), 2 deletions(-)

-- 
2.14.1

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2017-11-02  7:47 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-01 17:38 [PATCH net-next 0/2] nfp: bpf: rename ALU_OP_NEG and support BPF_NEG Jakub Kicinski
2017-11-01 17:38 ` [PATCH net-next 1/2] nfp: bpf: rename ALU_OP_NEG to ALU_OP_NOT Jakub Kicinski
2017-11-01 17:38 ` [PATCH net-next 2/2] nfp: bpf: support [BPF_ALU | BPF_ALU64] | BPF_NEG Jakub Kicinski
2017-11-02  7:47 ` [PATCH net-next 0/2] nfp: bpf: rename ALU_OP_NEG and support BPF_NEG David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.