All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v1 0/3] PCI: Rename host functions for consistency
@ 2017-11-13 22:40 ` Bjorn Helgaas
  0 siblings, 0 replies; 14+ messages in thread
From: Bjorn Helgaas @ 2017-11-13 22:40 UTC (permalink / raw)
  To: linux-pci
  Cc: Lorenzo Pieralisi, Michal Simek, rfi, Sören Brinkmann,
	Ley Foon Tan, linux-arm-kernel, Tanmay Inamdar

All native host bridge driver probe functions are called *_pci_probe() or
*_pcie_probe() *except* X-Gene's.  All "is the link up?" functions are
called *_pcie_link_up() *except* Altera's and Xilinx's.  Rename them to be
consistent.

I plan to include these for v4.15 unless there are objections.

---

Bjorn Helgaas (3):
      PCI: xgene: Rename xgene_pcie_probe_bridge() to xgene_pcie_probe()
      PCI: altera: Rename altera_pcie_link_is_up() to altera_pcie_link_up()
      PCI: xilinx: Rename xilinx_pcie_link_is_up() to xilinx_pcie_link_up()


 drivers/pci/host/pci-xgene.c   |    4 ++--
 drivers/pci/host/pcie-altera.c |    8 ++++----
 drivers/pci/host/pcie-xilinx.c |    6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2017-11-14 17:21 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-13 22:40 [PATCH v1 0/3] PCI: Rename host functions for consistency Bjorn Helgaas
2017-11-13 22:40 ` Bjorn Helgaas
2017-11-13 22:40 ` [PATCH v1 1/3] PCI: xgene: Rename xgene_pcie_probe_bridge() to xgene_pcie_probe() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-13 22:40 ` [PATCH v1 2/3] PCI: altera: Rename altera_pcie_link_is_up() to altera_pcie_link_up() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-14 16:58   ` Ley Foon Tan
2017-11-14 16:58     ` Ley Foon Tan
2017-11-13 22:40 ` [PATCH v1 3/3] PCI: xilinx: Rename xilinx_pcie_link_is_up() to xilinx_pcie_link_up() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-14  7:17   ` Michal Simek
2017-11-14  7:17     ` Michal Simek
2017-11-14 17:21 ` [PATCH v1 0/3] PCI: Rename host functions for consistency Lorenzo Pieralisi
2017-11-14 17:21   ` Lorenzo Pieralisi

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.