All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH i-g-t 1/4] lib: avoid < in gtkdoc comments
@ 2017-11-26 19:42 Daniel Vetter
  2017-11-26 19:42 ` [PATCH i-g-t 2/4] docs: remove version information Daniel Vetter
                   ` (7 more replies)
  0 siblings, 8 replies; 12+ messages in thread
From: Daniel Vetter @ 2017-11-26 19:42 UTC (permalink / raw)
  To: Intel Graphics Development; +Cc: Daniel Vetter

For reasons entirely not clear to me meson gtkdoc runs in strict
xml parsing mode, whereas automake gtkdoc doesn't. And gtkdoc itself
is tooooooooo dense to correctly escape this stuff.

Paper around this.

Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
 lib/igt_aux.c     | 4 ++--
 lib/igt_core.c    | 4 ++--
 lib/igt_debugfs.c | 2 +-
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/lib/igt_aux.c b/lib/igt_aux.c
index 0bcf792c64e9..62b30ce0e01b 100644
--- a/lib/igt_aux.c
+++ b/lib/igt_aux.c
@@ -1000,7 +1000,7 @@ void igt_drop_root(void)
  * @var: var lookup to to enable this wait
  *
  * Waits for a key press when run interactively and when the corresponding debug
- * var is set in the --interactive-debug=<var> variable. Multiple keys
+ * var is set in the --interactive-debug=$var variable. Multiple keys
  * can be specified as a comma-separated list or alternatively "all" if a wait
  * should happen for all cases.
  *
@@ -1041,7 +1041,7 @@ void igt_debug_wait_for_keypress(const char *var)
  * @expected: message to be printed as expected behaviour before wait for keys Y/n
  *
  * Waits for a key press when run interactively and when the corresponding debug
- * var is set in the --interactive-debug=<var> variable. Multiple vars
+ * var is set in the --interactive-debug=$var variable. Multiple vars
  * can be specified as a comma-separated list or alternatively "all" if a wait
  * should happen for all cases.
  *
diff --git a/lib/igt_core.c b/lib/igt_core.c
index 4fe48c974ef3..b38498e9d13b 100644
--- a/lib/igt_core.c
+++ b/lib/igt_core.c
@@ -164,10 +164,10 @@
  *   test logic.
  *
  * - When adding a new feature test function which uses igt_skip() internally,
- *   use the <prefix>_require_<feature_name> naming scheme. When you
+ *   use the &lt;prefix>_require_&lt;feature_name> naming scheme. When you
  *   instead add a feature test function which returns a boolean, because your
  *   main test logic must take different actions depending upon the feature's
- *   availability, then instead use the <prefix>_has_<feature_name>.
+ *   availability, then instead use the &lt;prefix>_has_&lt;feature_name>.
  *
  * - As already mentioned eschew explicit error handling logic as much as
  *   possible. If your test absolutely has to handle the error of some function
diff --git a/lib/igt_debugfs.c b/lib/igt_debugfs.c
index 5670099f1480..156c1d45ef58 100644
--- a/lib/igt_debugfs.c
+++ b/lib/igt_debugfs.c
@@ -231,7 +231,7 @@ int igt_debugfs_dir(int device)
  * @mode: mode bits as used by open()
  *
  * This opens a debugfs file as a Unix file descriptor. The filename should be
- * relative to the drm device's root, i.e. without "drm/<minor>".
+ * relative to the drm device's root, i.e. without "drm/$minor".
  *
  * Returns:
  * The Unix file descriptor for the debugfs file or -1 if that didn't work out.
-- 
2.15.0

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2017-11-27  9:04 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-26 19:42 [PATCH i-g-t 1/4] lib: avoid < in gtkdoc comments Daniel Vetter
2017-11-26 19:42 ` [PATCH i-g-t 2/4] docs: remove version information Daniel Vetter
2017-11-26 19:42 ` [PATCH i-g-t 3/4] lib: move write_stderr out of the #ifdef Daniel Vetter
2017-11-27  8:33   ` Tvrtko Ursulin
2017-11-26 19:42 ` [PATCH i-g-t 4/4] meson: gtkdoc support Daniel Vetter
2017-11-26 19:57   ` [PATCH i-g-t] " Daniel Vetter
2017-11-27  7:59   ` Daniel Vetter
2017-11-26 20:01 ` ✓ Fi.CI.BAT: success for series starting with [1/4] lib: avoid < in gtkdoc comments Patchwork
2017-11-26 20:42 ` ✓ Fi.CI.BAT: success for series starting with [1/4] lib: avoid < in gtkdoc comments (rev2) Patchwork
2017-11-26 21:49 ` ✗ Fi.CI.IGT: warning " Patchwork
2017-11-27  8:17 ` ✓ Fi.CI.BAT: success for series starting with [1/4] lib: avoid < in gtkdoc comments (rev3) Patchwork
2017-11-27  9:04 ` ✗ Fi.CI.IGT: warning " Patchwork

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.