All of lore.kernel.org
 help / color / mirror / Atom feed
* [patch net-next 00/11] mlxsw qdisc refactoring
@ 2018-01-10 13:59 Jiri Pirko
  2018-01-10 13:59 ` [patch net-next 01/11] mlxsw: spectrum: qdiscs: Move qdisc's declarations to its designated file Jiri Pirko
                   ` (11 more replies)
  0 siblings, 12 replies; 13+ messages in thread
From: Jiri Pirko @ 2018-01-10 13:59 UTC (permalink / raw)
  To: netdev; +Cc: nogahf, davem, idosch, mlxsw, jhs, xiyou.wangcong

From: Jiri Pirko <jiri@mellanox.com>

This patchset refactors the qdisc handling in mlxsw driver in order to make
it more object oriented like.
It helps readability, laying the groundwork for the offloading of
additional qdiscs by the driver
This patchset also makes the qdiscs statistics more generic.

Patch 1 moves the qdiscs declaration to the spectrum_qdisc.c
Patches 2-3 clean the offloaded stats requests. Patch 2 changes the RED
generic stats struct to be sharable by other offloaded qdiscs. Patch 3
changes the xstats request to be like the stats. Note that these patches
are outside the driver scope.
Patches 4-5 clean the statistics related functions and structs within the
driver.
Patches 6-7 decrease the need for the same parameters to be sent to many
functions.
Patches 8-11 create a functions pointers struct, to make the qdiscs
handling more object oriented like.

Nogah Frankel (11):
  mlxsw: spectrum: qdiscs: Move qdisc's declarations to its designated
    file
  net: sch: red: Change the name of the stats struct to be generic
  net: sch: red: Change offloaded xstats to be incremental
  mlxsw: spectrum: qdiscs: Clean qdisc statistics structs
  mlxsw: spectrum: qdiscs: Make the clean stats function to be for RED
    only
  mlxsw: spectrum: qdiscs: Add tclass number to the mlxsw_sp_qdisc
  mlxsw: spectrum: qdiscs: Unite all handle checks
  mlxsw: spectrum: qdiscs: Add an ops struct
  mlxsw: spectrum: qdiscs: Create a generic destroy function
  mlxsw: spectrum: qdiscs: Create a generic replace function
  mlxsw: spectrum: qdiscs: Remove qdisc before setting a new one

 drivers/net/ethernet/mellanox/mlxsw/spectrum.c     |  10 +
 drivers/net/ethernet/mellanox/mlxsw/spectrum.h     |  27 +-
 .../net/ethernet/mellanox/mlxsw/spectrum_qdisc.c   | 362 ++++++++++++++-------
 include/net/pkt_cls.h                              |  11 +-
 net/sched/sch_red.c                                |  24 +-
 5 files changed, 280 insertions(+), 154 deletions(-)

-- 
2.14.3

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2018-01-10 21:08 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-01-10 13:59 [patch net-next 00/11] mlxsw qdisc refactoring Jiri Pirko
2018-01-10 13:59 ` [patch net-next 01/11] mlxsw: spectrum: qdiscs: Move qdisc's declarations to its designated file Jiri Pirko
2018-01-10 13:59 ` [patch net-next 02/11] net: sch: red: Change the name of the stats struct to be generic Jiri Pirko
2018-01-10 13:59 ` [patch net-next 03/11] net: sch: red: Change offloaded xstats to be incremental Jiri Pirko
2018-01-10 14:00 ` [patch net-next 04/11] mlxsw: spectrum: qdiscs: Clean qdisc statistics structs Jiri Pirko
2018-01-10 14:00 ` [patch net-next 05/11] mlxsw: spectrum: qdiscs: Make the clean stats function to be for RED only Jiri Pirko
2018-01-10 14:00 ` [patch net-next 06/11] mlxsw: spectrum: qdiscs: Add tclass number to the mlxsw_sp_qdisc Jiri Pirko
2018-01-10 14:00 ` [patch net-next 07/11] mlxsw: spectrum: qdiscs: Unite all handle checks Jiri Pirko
2018-01-10 14:00 ` [patch net-next 08/11] mlxsw: spectrum: qdiscs: Add an ops struct Jiri Pirko
2018-01-10 14:00 ` [patch net-next 09/11] mlxsw: spectrum: qdiscs: Create a generic destroy function Jiri Pirko
2018-01-10 14:00 ` [patch net-next 10/11] mlxsw: spectrum: qdiscs: Create a generic replace function Jiri Pirko
2018-01-10 14:00 ` [patch net-next 11/11] mlxsw: spectrum: qdiscs: Remove qdisc before setting a new one Jiri Pirko
2018-01-10 21:08 ` [patch net-next 00/11] mlxsw qdisc refactoring David Miller

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.