All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: "Luis R. Rodriguez" <mcgrof@kernel.org>
Cc: akpm@linux-foundation.org, cantabile.desu@gmail.com,
	kubakici@wp.pl, linux-wireless@vger.kernel.org,
	keescook@chromium.org, shuah@kernel.org, mfuzzey@parkeon.com,
	zohar@linux.vnet.ibm.com, dhowells@redhat.com,
	pali.rohar@gmail.com, tiwai@suse.de,
	arend.vanspriel@broadcom.com, zajec5@gmail.com, nbroeking@me.com,
	markivx@codeaurora.org, broonie@kernel.org,
	dmitry.torokhov@gmail.com, dwmw2@infradead.org,
	torvalds@linux-foundation.org, Abhay_Salunke@dell.com,
	bjorn.andersson@linaro.org, jewalt@lgsinnovations.com,
	oneukum@suse.com, ast@fb.com, andresx7@gmail.com,
	linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot
Date: Tue, 20 Mar 2018 09:30:55 +0100	[thread overview]
Message-ID: <20180320083055.GA21640@kroah.com> (raw)
In-Reply-To: <20180310141501.2214-20-mcgrof@kernel.org>

On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote:
> Some devices have an optimization in place to enable the firmware to
> be retaineed during a system reboot, so after reboot the device can skip
> requesting and loading the firmware. This can save up to 1s in load
> time. The mt7601u 802.11 device happens to be such a device.
> 
> When these devices retain the firmware on a reboot and then suspend
> they can miss looking for the firmware on resume. To help with this we
> need a way to cache the firmware when such an optimization has taken
> place.
> 
> Signed-off-by: Luis R. Rodriguez <mcgrof@kernel.org>
> ---
>  .../driver-api/firmware/request_firmware.rst       | 14 +++++++++++++
>  drivers/base/firmware_loader/main.c                | 24 ++++++++++++++++++++++
>  include/linux/firmware.h                           |  3 +++
>  3 files changed, 41 insertions(+)
> 
> diff --git a/Documentation/driver-api/firmware/request_firmware.rst b/Documentation/driver-api/firmware/request_firmware.rst
> index cc0aea880824..b554f4338859 100644
> --- a/Documentation/driver-api/firmware/request_firmware.rst
> +++ b/Documentation/driver-api/firmware/request_firmware.rst
> @@ -44,6 +44,20 @@ request_firmware_nowait
>  .. kernel-doc:: drivers/base/firmware_class.c
>     :functions: request_firmware_nowait
>  
> +Special optimizations on reboot
> +===============================
> +
> +Some devices have an optimization in place to enable the firmware to be
> +retained during system reboot. When such optimizations are used the driver
> +author must ensure the firmware is still available on resume from suspend,
> +this can be done with request_firmware_cache() insted of requesting for the
> +firmare to be loaded.
> +
> +request_firmware_cache()
> +-----------------------
> +.. kernel-doc:: drivers/base/firmware_class.c
> +   :functions: request_firmware_load
> +
>  request firmware API expected driver use
>  ========================================
>  
> diff --git a/drivers/base/firmware_loader/main.c b/drivers/base/firmware_loader/main.c
> index 2913bb0e5e7b..04bf853f60e9 100644
> --- a/drivers/base/firmware_loader/main.c
> +++ b/drivers/base/firmware_loader/main.c
> @@ -656,6 +656,30 @@ int request_firmware_direct(const struct firmware **firmware_p,
>  }
>  EXPORT_SYMBOL_GPL(request_firmware_direct);
>  
> +/**
> + * request_firmware_cache: - cache firmware for suspend so resume can use it
> + * @name: name of firmware file
> + * @device: device for which firmware should be cached for
> + *
> + * There are some devices with an optimization that enables the device to not
> + * require loading firmware on system reboot. This optimization may still
> + * require the firmware present on resume from suspend. This routine can be
> + * used to ensure the firmware is present on resume from suspend in these
> + * situations. This helper is not compatible with drivers which use
> + * request_firmware_into_buf() or request_firmware_nowait() with no uevent set.
> + **/
> +int request_firmware_cache(struct device *device, const char *name)
> +{
> +	int ret;
> +
> +	mutex_lock(&fw_lock);
> +	ret = fw_add_devm_name(device, name);
> +	mutex_unlock(&fw_lock);
> +
> +	return ret;
> +}
> +EXPORT_SYMBOL_GPL(request_firmware_cache);

I know you are just following the existing naming scheme, but please
let's not continue the problem here.  Can you prefix all of the firmware
exported symbols with "firmware_", and then the verb.  So this would be
"firmware_request_cache", and the older function would be
"firmware_request_direct".

I've stopped here in the patch series, applying the others now, so feel
free to rebase and resend what I've missed, and the minor fixups for the
prior patches.

thanks,

greg k-h

  reply	other threads:[~2018-03-20  8:30 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-10 14:14 [PATCH v3 00/20] firmware: development for v4.17 Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 01/20] test_firmware: add simple firmware firmware test library Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 02/20] test_firmware: enable custom fallback testing on limited kernel configs Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 03/20] test_firmware: replace syfs fallback check with kconfig_has helper Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 04/20] firmware: enable to split firmware_class into separate target files Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 05/20] firmware: simplify CONFIG_FW_LOADER_USER_HELPER_FALLBACK further Luis R. Rodriguez
2018-03-14 18:53   ` Greg KH
2018-03-14 22:36     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 06/20] firmware: use helpers for setting up a temporary cache timeout Luis R. Rodriguez
2018-03-14 18:55   ` Greg KH
2018-03-10 14:14 ` [PATCH v3 07/20] firmware: move loading timeout under struct firmware_fallback_config Luis R. Rodriguez
2018-03-14 18:56   ` Greg KH
2018-03-14 22:33     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 08/20] firmware: split firmware fallback functionality into its own file Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 09/20] firmware: move firmware loader into its own directory Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 10/20] firmware: enable run time change of forcing fallback loader Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 11/20] firmware: enable to force disable the fallback mechanism at run time Luis R. Rodriguez
2018-03-14 19:00   ` Greg KH
2018-03-18 20:20     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 12/20] test_firmware: expand on library with shared helpers Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 13/20] test_firmware: test three firmware kernel configs using a proc knob Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 14/20] rename: _request_firmware_load() fw_load_sysfs_fallback() Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 15/20] firmware: fix checking for return values for fw_add_devm_name() Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 16/20] firmware: add helper to check to see if fw cache is setup Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 17/20] test_firmware: modify custom fallback tests to use unique files Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 18/20] firmware: ensure the firmware cache is not used on incompatible calls Luis R. Rodriguez
2018-03-10 14:15 ` [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot Luis R. Rodriguez
2018-03-20  8:30   ` Greg KH [this message]
2018-03-20 17:34     ` Luis R. Rodriguez
2018-03-20 17:38       ` Greg KH
2018-03-20 18:24         ` Luis R. Rodriguez
2018-03-20 18:54           ` Konstantin Ryabitsev
2018-03-20 19:51             ` Luis R. Rodriguez
2018-03-21 10:04           ` Greg KH
2018-03-10 14:15 ` [PATCH v3 20/20] mt7601u: use request_firmware_cache() to address " Luis R. Rodriguez
2018-03-13  4:43   ` Jakub Kicinski
2018-03-10 17:16 ` [PATCH v3 00/20] firmware: development for v4.17 Kees Cook
2018-03-14 17:44   ` Luis R. Rodriguez
2018-03-14 17:58     ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180320083055.GA21640@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=Abhay_Salunke@dell.com \
    --cc=akpm@linux-foundation.org \
    --cc=andresx7@gmail.com \
    --cc=arend.vanspriel@broadcom.com \
    --cc=ast@fb.com \
    --cc=bjorn.andersson@linaro.org \
    --cc=broonie@kernel.org \
    --cc=cantabile.desu@gmail.com \
    --cc=dhowells@redhat.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=jewalt@lgsinnovations.com \
    --cc=keescook@chromium.org \
    --cc=kubakici@wp.pl \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=markivx@codeaurora.org \
    --cc=mcgrof@kernel.org \
    --cc=mfuzzey@parkeon.com \
    --cc=nbroeking@me.com \
    --cc=oneukum@suse.com \
    --cc=pali.rohar@gmail.com \
    --cc=shuah@kernel.org \
    --cc=tiwai@suse.de \
    --cc=torvalds@linux-foundation.org \
    --cc=zajec5@gmail.com \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.