All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Luis R. Rodriguez" <mcgrof@kernel.org>
To: Greg KH <gregkh@linuxfoundation.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Julia Lawall <julia.lawall@lip6.fr>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	Joe Perches <joe@perches.com>, Takashi Iwai <tiwai@suse.de>,
	Thomas Gleixner <tglx@linutronix.de>,
	Jiri Kosina <jikos@kernel.org>,
	Masahiro Yamada <yamada.masahiro@socionext.com>
Cc: "Luis R. Rodriguez" <mcgrof@kernel.org>,
	akpm@linux-foundation.org, cantabile.desu@gmail.com,
	kubakici@wp.pl, linux-wireless@vger.kernel.org,
	keescook@chromium.org, shuah@kernel.org, mfuzzey@parkeon.com,
	zohar@linux.vnet.ibm.com, dhowells@redhat.com,
	pali.rohar@gmail.com, tiwai@suse.de,
	arend.vanspriel@broadcom.com, zajec5@gmail.com, nbroeking@me.com,
	markivx@codeaurora.org, broonie@kernel.org,
	dmitry.torokhov@gmail.com, dwmw2@infradead.org,
	Abhay_Salunke@dell.com, bjorn.andersson@linaro.org,
	jewalt@lgsinnovations.com, oneukum@suse.com, ast@fb.com,
	andresx7@gmail.com, linux-kernel@vger.kernel.org,
	linux-fsdevel@vger.kernel.org,
	Konstantin Ryabitsev <konstantin@linuxfoundation.org>
Subject: Re: [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot
Date: Tue, 20 Mar 2018 18:24:09 +0000	[thread overview]
Message-ID: <20180320182409.GF4449@wotan.suse.de> (raw)
In-Reply-To: <20180320173801.GA25040@kroah.com>

On Tue, Mar 20, 2018 at 06:38:01PM +0100, Greg KH wrote:
> On Tue, Mar 20, 2018 at 05:34:09PM +0000, Luis R. Rodriguez wrote:
> > On Tue, Mar 20, 2018 at 09:30:55AM +0100, Greg KH wrote:
> > > On Sat, Mar 10, 2018 at 06:15:00AM -0800, Luis R. Rodriguez wrote:
> > > > +EXPORT_SYMBOL_GPL(request_firmware_cache);
> > > 
> > > I know you are just following the existing naming scheme, but please
> > > let's not continue the problem here.  Can you prefix all of the firmware
> > > exported symbols with "firmware_", and then the verb.  So this would be
> > > "firmware_request_cache",
> > 
> > Sure.
> > 
> > >  and the older function would be
> > > "firmware_request_direct".
> > 
> > Sure, so you want to also rename the old exported symbols, and add a macro
> > or static inline to enable use of the older names?
> 
> Renaming is best, let's not keep them around for no good reason :)

Sure thing, I'll rename the old firmware calls.

Since that would be a cross-tree collateral evolution, as we have discussed
before over these at kernel summits, I'd prefer to leave that large set of
renames toward the end of the series, as the last patch. This way the
Coccinelle SmPL / sed script could be run at the very end, and in case of merge
conflicts re-run.

Which BTW... *long term*, I believe a possible way to address these cross-tree
collateral evolutions, due to new merge updates and conflicts, could be for us
to embed the SmPL / sed scripts into git notes, and in turn have an *optional* git
configuration which could attempt a merge conflict resolution through
alternative means, one of which -- if enabled -- could be to try to run the SmPL or
sed script in the attached git note (if you downloaded them). One of the other
benefits of this is the commit log is no longer visually impaired by such long
semantic patches or scripts, and gives us a nice way to pull these up through a
generic tooling mechanism. This could all just be optional, no one would have
to push or fetch these -- only if they wanted the possible added benefits of
having them.

*Iff* this seems sensible, this would only mean kernel.org would have to start
accepting git notes long term, for those who optionally want to push them or
fetch them.

FWIW I've confirmed with github that they now accepts git notes, the UI for
github just needs time to develop how to interact with them, for now they just
hide them. One of the difficulties with a UI interface for them is that by
default git notes *do not* use a namespace reflective for a branch or anything.
We could stick to a actual namespace for branch / commit:

"iso" for isomorphism

git note --ref branch/iso-coccinelle/ add commit-id
vi refs/notes/branch/iso-coccinelle/commit-id
git note --ref branch/iso-coccinelle/ edit commit-id

This is rather crude though so simple interface such as the following could
be added as well:

git smpl add sp.cocci commit-id
git smpl edit commit-id
git smpl list v4.13..v4.14

Similar thing could be done for crash dumps, if we wanted...

Since this still would need to be discussed, and if agreed then implemented, in
the meantime I can just do it the old school way of embedding the SmPL and/or
sed script into the commit log, but left as the last patch in the series.

  Luis

  reply	other threads:[~2018-03-20 18:24 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-10 14:14 [PATCH v3 00/20] firmware: development for v4.17 Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 01/20] test_firmware: add simple firmware firmware test library Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 02/20] test_firmware: enable custom fallback testing on limited kernel configs Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 03/20] test_firmware: replace syfs fallback check with kconfig_has helper Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 04/20] firmware: enable to split firmware_class into separate target files Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 05/20] firmware: simplify CONFIG_FW_LOADER_USER_HELPER_FALLBACK further Luis R. Rodriguez
2018-03-14 18:53   ` Greg KH
2018-03-14 22:36     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 06/20] firmware: use helpers for setting up a temporary cache timeout Luis R. Rodriguez
2018-03-14 18:55   ` Greg KH
2018-03-10 14:14 ` [PATCH v3 07/20] firmware: move loading timeout under struct firmware_fallback_config Luis R. Rodriguez
2018-03-14 18:56   ` Greg KH
2018-03-14 22:33     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 08/20] firmware: split firmware fallback functionality into its own file Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 09/20] firmware: move firmware loader into its own directory Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 10/20] firmware: enable run time change of forcing fallback loader Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 11/20] firmware: enable to force disable the fallback mechanism at run time Luis R. Rodriguez
2018-03-14 19:00   ` Greg KH
2018-03-18 20:20     ` Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 12/20] test_firmware: expand on library with shared helpers Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 13/20] test_firmware: test three firmware kernel configs using a proc knob Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 14/20] rename: _request_firmware_load() fw_load_sysfs_fallback() Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 15/20] firmware: fix checking for return values for fw_add_devm_name() Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 16/20] firmware: add helper to check to see if fw cache is setup Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 17/20] test_firmware: modify custom fallback tests to use unique files Luis R. Rodriguez
2018-03-10 14:14 ` [PATCH v3 18/20] firmware: ensure the firmware cache is not used on incompatible calls Luis R. Rodriguez
2018-03-10 14:15 ` [PATCH v3 19/20] firmware: add request_firmware_cache() to help with cache on reboot Luis R. Rodriguez
2018-03-20  8:30   ` Greg KH
2018-03-20 17:34     ` Luis R. Rodriguez
2018-03-20 17:38       ` Greg KH
2018-03-20 18:24         ` Luis R. Rodriguez [this message]
2018-03-20 18:54           ` Konstantin Ryabitsev
2018-03-20 19:51             ` Luis R. Rodriguez
2018-03-21 10:04           ` Greg KH
2018-03-10 14:15 ` [PATCH v3 20/20] mt7601u: use request_firmware_cache() to address " Luis R. Rodriguez
2018-03-13  4:43   ` Jakub Kicinski
2018-03-10 17:16 ` [PATCH v3 00/20] firmware: development for v4.17 Kees Cook
2018-03-14 17:44   ` Luis R. Rodriguez
2018-03-14 17:58     ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180320182409.GF4449@wotan.suse.de \
    --to=mcgrof@kernel.org \
    --cc=Abhay_Salunke@dell.com \
    --cc=akpm@linux-foundation.org \
    --cc=andresx7@gmail.com \
    --cc=arend.vanspriel@broadcom.com \
    --cc=ast@fb.com \
    --cc=bjorn.andersson@linaro.org \
    --cc=broonie@kernel.org \
    --cc=cantabile.desu@gmail.com \
    --cc=dhowells@redhat.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jewalt@lgsinnovations.com \
    --cc=jikos@kernel.org \
    --cc=joe@perches.com \
    --cc=julia.lawall@lip6.fr \
    --cc=keescook@chromium.org \
    --cc=konstantin@linuxfoundation.org \
    --cc=kubakici@wp.pl \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=markivx@codeaurora.org \
    --cc=mfuzzey@parkeon.com \
    --cc=nbroeking@me.com \
    --cc=nicolas.palix@imag.fr \
    --cc=oneukum@suse.com \
    --cc=pali.rohar@gmail.com \
    --cc=shuah@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=tiwai@suse.de \
    --cc=torvalds@linux-foundation.org \
    --cc=yamada.masahiro@socionext.com \
    --cc=zajec5@gmail.com \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.