All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] KVM: fix spelling mistake: "cop_unsuable" -> "cop_unusable"
@ 2018-05-14 17:23 ` Colin King
  0 siblings, 0 replies; 4+ messages in thread
From: Colin King @ 2018-05-14 17:23 UTC (permalink / raw)
  To: James Hogan, Ralf Baechle, linux-mips; +Cc: kernel-janitors, linux-kernel

From: Colin Ian King <colin.king@canonical.com>

Trivial fix to spelling mistake in debugfs_entries text

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 arch/mips/kvm/mips.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/mips/kvm/mips.c b/arch/mips/kvm/mips.c
index 2549fdd27ee1..0f725e9cee8f 100644
--- a/arch/mips/kvm/mips.c
+++ b/arch/mips/kvm/mips.c
@@ -45,7 +45,7 @@ struct kvm_stats_debugfs_item debugfs_entries[] = {
 	{ "cache",	  VCPU_STAT(cache_exits),	 KVM_STAT_VCPU },
 	{ "signal",	  VCPU_STAT(signal_exits),	 KVM_STAT_VCPU },
 	{ "interrupt",	  VCPU_STAT(int_exits),		 KVM_STAT_VCPU },
-	{ "cop_unsuable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
+	{ "cop_unusable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
 	{ "tlbmod",	  VCPU_STAT(tlbmod_exits),	 KVM_STAT_VCPU },
 	{ "tlbmiss_ld",	  VCPU_STAT(tlbmiss_ld_exits),	 KVM_STAT_VCPU },
 	{ "tlbmiss_st",	  VCPU_STAT(tlbmiss_st_exits),	 KVM_STAT_VCPU },
-- 
2.17.0

^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH] KVM: fix spelling mistake: "cop_unsuable" -> "cop_unusable"
@ 2018-05-14 17:23 ` Colin King
  0 siblings, 0 replies; 4+ messages in thread
From: Colin King @ 2018-05-14 17:23 UTC (permalink / raw)
  To: James Hogan, Ralf Baechle, linux-mips; +Cc: kernel-janitors, linux-kernel

From: Colin Ian King <colin.king@canonical.com>

Trivial fix to spelling mistake in debugfs_entries text

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 arch/mips/kvm/mips.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/mips/kvm/mips.c b/arch/mips/kvm/mips.c
index 2549fdd27ee1..0f725e9cee8f 100644
--- a/arch/mips/kvm/mips.c
+++ b/arch/mips/kvm/mips.c
@@ -45,7 +45,7 @@ struct kvm_stats_debugfs_item debugfs_entries[] = {
 	{ "cache",	  VCPU_STAT(cache_exits),	 KVM_STAT_VCPU },
 	{ "signal",	  VCPU_STAT(signal_exits),	 KVM_STAT_VCPU },
 	{ "interrupt",	  VCPU_STAT(int_exits),		 KVM_STAT_VCPU },
-	{ "cop_unsuable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
+	{ "cop_unusable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
 	{ "tlbmod",	  VCPU_STAT(tlbmod_exits),	 KVM_STAT_VCPU },
 	{ "tlbmiss_ld",	  VCPU_STAT(tlbmiss_ld_exits),	 KVM_STAT_VCPU },
 	{ "tlbmiss_st",	  VCPU_STAT(tlbmiss_st_exits),	 KVM_STAT_VCPU },
-- 
2.17.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] KVM: fix spelling mistake: "cop_unsuable" -> "cop_unusable"
  2018-05-14 17:23 ` Colin King
@ 2018-05-14 22:13   ` James Hogan
  -1 siblings, 0 replies; 4+ messages in thread
From: James Hogan @ 2018-05-14 22:13 UTC (permalink / raw)
  To: Colin King
  Cc: Ralf Baechle, linux-mips, kernel-janitors, linux-kernel,
	Paolo Bonzini, Radim Krčmář,
	kvm

[-- Attachment #1: Type: text/plain, Size: 1518 bytes --]

On Mon, May 14, 2018 at 06:23:50PM +0100, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> Trivial fix to spelling mistake in debugfs_entries text
> 
> Signed-off-by: Colin Ian King <colin.king@canonical.com>

Adding KVM folk. Its a fairly trivial change so I'll just take it as a
fix via the MIPS tree unless anybody objects.

This does change the name of one of the stats counters debugfs files
though (which I have no doubt isn't relied upon by anything), so I've
added:

Fixes: 669e846e6c4e ("KVM/MIPS32: MIPS arch specific APIs for KVM")
Cc: <stable@vger.kernel.org> # 3.10+

Thanks
James

> ---
>  arch/mips/kvm/mips.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/arch/mips/kvm/mips.c b/arch/mips/kvm/mips.c
> index 2549fdd27ee1..0f725e9cee8f 100644
> --- a/arch/mips/kvm/mips.c
> +++ b/arch/mips/kvm/mips.c
> @@ -45,7 +45,7 @@ struct kvm_stats_debugfs_item debugfs_entries[] = {
>  	{ "cache",	  VCPU_STAT(cache_exits),	 KVM_STAT_VCPU },
>  	{ "signal",	  VCPU_STAT(signal_exits),	 KVM_STAT_VCPU },
>  	{ "interrupt",	  VCPU_STAT(int_exits),		 KVM_STAT_VCPU },
> -	{ "cop_unsuable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
> +	{ "cop_unusable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
>  	{ "tlbmod",	  VCPU_STAT(tlbmod_exits),	 KVM_STAT_VCPU },
>  	{ "tlbmiss_ld",	  VCPU_STAT(tlbmiss_ld_exits),	 KVM_STAT_VCPU },
>  	{ "tlbmiss_st",	  VCPU_STAT(tlbmiss_st_exits),	 KVM_STAT_VCPU },
> -- 
> 2.17.0
> 

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] KVM: fix spelling mistake: "cop_unsuable" -> "cop_unusable"
@ 2018-05-14 22:13   ` James Hogan
  0 siblings, 0 replies; 4+ messages in thread
From: James Hogan @ 2018-05-14 22:13 UTC (permalink / raw)
  To: Colin King
  Cc: Ralf Baechle, linux-mips, kernel-janitors, linux-kernel,
	Paolo Bonzini, Radim Krčmář,
	kvm

[-- Attachment #1: Type: text/plain, Size: 1518 bytes --]

On Mon, May 14, 2018 at 06:23:50PM +0100, Colin King wrote:
> From: Colin Ian King <colin.king@canonical.com>
> 
> Trivial fix to spelling mistake in debugfs_entries text
> 
> Signed-off-by: Colin Ian King <colin.king@canonical.com>

Adding KVM folk. Its a fairly trivial change so I'll just take it as a
fix via the MIPS tree unless anybody objects.

This does change the name of one of the stats counters debugfs files
though (which I have no doubt isn't relied upon by anything), so I've
added:

Fixes: 669e846e6c4e ("KVM/MIPS32: MIPS arch specific APIs for KVM")
Cc: <stable@vger.kernel.org> # 3.10+

Thanks
James

> ---
>  arch/mips/kvm/mips.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/arch/mips/kvm/mips.c b/arch/mips/kvm/mips.c
> index 2549fdd27ee1..0f725e9cee8f 100644
> --- a/arch/mips/kvm/mips.c
> +++ b/arch/mips/kvm/mips.c
> @@ -45,7 +45,7 @@ struct kvm_stats_debugfs_item debugfs_entries[] = {
>  	{ "cache",	  VCPU_STAT(cache_exits),	 KVM_STAT_VCPU },
>  	{ "signal",	  VCPU_STAT(signal_exits),	 KVM_STAT_VCPU },
>  	{ "interrupt",	  VCPU_STAT(int_exits),		 KVM_STAT_VCPU },
> -	{ "cop_unsuable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
> +	{ "cop_unusable", VCPU_STAT(cop_unusable_exits), KVM_STAT_VCPU },
>  	{ "tlbmod",	  VCPU_STAT(tlbmod_exits),	 KVM_STAT_VCPU },
>  	{ "tlbmiss_ld",	  VCPU_STAT(tlbmiss_ld_exits),	 KVM_STAT_VCPU },
>  	{ "tlbmiss_st",	  VCPU_STAT(tlbmiss_st_exits),	 KVM_STAT_VCPU },
> -- 
> 2.17.0
> 

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2018-05-14 22:13 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-05-14 17:23 [PATCH] KVM: fix spelling mistake: "cop_unsuable" -> "cop_unusable" Colin King
2018-05-14 17:23 ` Colin King
2018-05-14 22:13 ` James Hogan
2018-05-14 22:13   ` James Hogan

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.