All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: James Simmons <jsimmons@infradead.org>
Cc: devel@driverdev.osuosl.org,
	Andreas Dilger <andreas.dilger@intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	NeilBrown <neilb@suse.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Oleg Drokin <oleg.drokin@intel.com>,
	Jinshan Xiong <jinshan.xiong@intel.com>,
	Lai Siyao <lai.siyao@intel.com>,
	Lustre Development List <lustre-devel@lists.lustre.org>
Subject: Re: [PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode
Date: Wed, 16 May 2018 11:00:22 +0300	[thread overview]
Message-ID: <20180516080022.b4ihz7opiueobm7u@mwanda> (raw)
In-Reply-To: <alpine.LFD.2.21.1805150207500.576@casper.infradead.org>

On Tue, May 15, 2018 at 04:02:55PM +0100, James Simmons wrote:
> 
> > >  	/*
> > >  	 * Allocate new object. This may result in rather complicated
> > >  	 * operations, including fld queries, inode loading, etc.
> > >  	 */
> > >  	o = lu_object_alloc(env, dev, f, conf);
> > > -	if (IS_ERR(o))
> > > +	if (unlikely(IS_ERR(o)))
> > >  		return o;
> > >  
> > 
> > This is an unrelated and totally pointless.  likely/unlikely annotations
> > hurt readability, and they should only be added if it's something which
> > is going to show up in benchmarking.  lu_object_alloc() is already too
> > slow for the unlikely() to make a difference and anyway IS_ERR() has an
> > unlikely built in so it's duplicative...
> 
> Sounds like a good checkpatch case to test for :-)

The likely/unlikely annotations have their place in fast paths so a
checkpatch warning would get annoying...

regards,
dan carpenter

_______________________________________________
devel mailing list
devel@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

WARNING: multiple messages have this Message-ID (diff)
From: Dan Carpenter <dan.carpenter@oracle.com>
To: James Simmons <jsimmons@infradead.org>
Cc: devel@driverdev.osuosl.org,
	Andreas Dilger <andreas.dilger@intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	NeilBrown <neilb@suse.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Oleg Drokin <oleg.drokin@intel.com>,
	Jinshan Xiong <jinshan.xiong@intel.com>,
	Lai Siyao <lai.siyao@intel.com>,
	Lustre Development List <lustre-devel@lists.lustre.org>
Subject: [lustre-devel] [PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode
Date: Wed, 16 May 2018 11:00:22 +0300	[thread overview]
Message-ID: <20180516080022.b4ihz7opiueobm7u@mwanda> (raw)
In-Reply-To: <alpine.LFD.2.21.1805150207500.576@casper.infradead.org>

On Tue, May 15, 2018 at 04:02:55PM +0100, James Simmons wrote:
> 
> > >  	/*
> > >  	 * Allocate new object. This may result in rather complicated
> > >  	 * operations, including fld queries, inode loading, etc.
> > >  	 */
> > >  	o = lu_object_alloc(env, dev, f, conf);
> > > -	if (IS_ERR(o))
> > > +	if (unlikely(IS_ERR(o)))
> > >  		return o;
> > >  
> > 
> > This is an unrelated and totally pointless.  likely/unlikely annotations
> > hurt readability, and they should only be added if it's something which
> > is going to show up in benchmarking.  lu_object_alloc() is already too
> > slow for the unlikely() to make a difference and anyway IS_ERR() has an
> > unlikely built in so it's duplicative...
> 
> Sounds like a good checkpatch case to test for :-)

The likely/unlikely annotations have their place in fast paths so a
checkpatch warning would get annoying...

regards,
dan carpenter

  reply	other threads:[~2018-05-16  8:00 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-02 18:21 [PATCH 0/4] staging: lustre: obdclass: missing lu_object fixes James Simmons
2018-05-02 18:21 ` [lustre-devel] " James Simmons
2018-05-02 18:21 ` [PATCH 1/4] staging: lustre: obdclass: change spinlock of key to rwlock James Simmons
2018-05-02 18:21   ` [lustre-devel] " James Simmons
2018-05-03 13:50   ` David Laight
2018-05-03 13:50     ` [lustre-devel] " David Laight
2018-05-03 23:26     ` NeilBrown
2018-05-03 23:26       ` [lustre-devel] " NeilBrown
2018-05-04  0:11     ` Dilger, Andreas
2018-05-04  0:11       ` [lustre-devel] " Dilger, Andreas
2018-05-04  0:53       ` NeilBrown
2018-05-04  0:53         ` [lustre-devel] " NeilBrown
2018-05-02 18:21 ` [PATCH 2/4] staging: lustre: obdclass: hoist locking in lu_context_exit() James Simmons
2018-05-02 18:21   ` [lustre-devel] " James Simmons
2018-05-02 18:21 ` [PATCH 3/4] staging: lustre: obdclass: guarantee all keys filled James Simmons
2018-05-02 18:21   ` [lustre-devel] " James Simmons
2018-05-02 18:21 ` [PATCH 4/4] staging: lustre: obdclass: change object lookup to no wait mode James Simmons
2018-05-02 18:21   ` [lustre-devel] " James Simmons
2018-05-04  1:15   ` NeilBrown
2018-05-04  1:15     ` [lustre-devel] " NeilBrown
2018-05-15  0:37     ` James Simmons
2018-05-15  0:37       ` [lustre-devel] " James Simmons
2018-05-15  1:37       ` NeilBrown
2018-05-15  1:37         ` [lustre-devel] " NeilBrown
2018-05-15  2:11         ` James Simmons
2018-05-15  2:11           ` [lustre-devel] " James Simmons
2018-05-07  1:47   ` Greg Kroah-Hartman
2018-05-07  1:47     ` [lustre-devel] " Greg Kroah-Hartman
2018-05-08 11:45   ` Dan Carpenter
2018-05-08 11:45     ` [lustre-devel] " Dan Carpenter
2018-05-15 15:02     ` James Simmons
2018-05-15 15:02       ` [lustre-devel] " James Simmons
2018-05-16  8:00       ` Dan Carpenter [this message]
2018-05-16  8:00         ` Dan Carpenter
2018-05-16  9:12         ` Dilger, Andreas
2018-05-16  9:12           ` [lustre-devel] " Dilger, Andreas
2018-05-16 15:44           ` Joe Perches
2018-05-16 15:44             ` [lustre-devel] " Joe Perches
2018-05-16 16:57       ` Greg Kroah-Hartman
2018-05-16 16:57         ` [lustre-devel] " Greg Kroah-Hartman
2018-05-17  5:07         ` James Simmons
2018-05-17  5:07           ` [lustre-devel] " James Simmons

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180516080022.b4ihz7opiueobm7u@mwanda \
    --to=dan.carpenter@oracle.com \
    --cc=andreas.dilger@intel.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jinshan.xiong@intel.com \
    --cc=jsimmons@infradead.org \
    --cc=lai.siyao@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lustre-devel@lists.lustre.org \
    --cc=neilb@suse.com \
    --cc=oleg.drokin@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.