All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.
@ 2018-06-12 21:09 Chris Opperman
  2018-06-13  9:29 ` Dan Carpenter
  2018-06-13 12:01 ` Ian Abbott
  0 siblings, 2 replies; 8+ messages in thread
From: Chris Opperman @ 2018-06-12 21:09 UTC (permalink / raw)
  Cc: eklikeroomys, Ian Abbott, H Hartley Sweeten, Greg Kroah-Hartman,
	Simo Koskinen, Frank Mori Hess, devel, linux-kernel

Changes since v3:
a) Reverted u64 to unsigned long long and u32 to unsigned int.
b) Added patch versioning.
c) Changed type of scans_left to unsigned long long to avoid cast.
d) Clarified and updated changelog.

>8-----------------------------------------------------------------------8<

Improve readability of comedi_nsamples_left:
a) Reduce nesting by using more return statements.
b) Declare variables scans_left and samples_left at start of function.
c) Change type of scans_Left to unsigned long long to avoid cast.

Signed-off-by: Chris Opperman <eklikeroomys@gmail.com>
---
 drivers/staging/comedi/drivers.c | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c
index 9d73347..57dd63d 100644
--- a/drivers/staging/comedi/drivers.c
+++ b/drivers/staging/comedi/drivers.c
@@ -473,21 +473,21 @@ unsigned int comedi_nsamples_left(struct comedi_subdevice *s,
 {
 	struct comedi_async *async = s->async;
 	struct comedi_cmd *cmd = &async->cmd;
+	unsigned long long scans_left;
+	unsigned long long samples_left;

-	if (cmd->stop_src == TRIG_COUNT) {
-		unsigned int scans_left = __comedi_nscans_left(s, cmd->stop_arg);
-		unsigned int scan_pos =
-		    comedi_bytes_to_samples(s, async->scan_progress);
-		unsigned long long samples_left = 0;
-
-		if (scans_left) {
-			samples_left = ((unsigned long long)scans_left *
-					cmd->scan_end_arg) - scan_pos;
-		}
+	if (cmd->stop_src != TRIG_COUNT)
+		return nsamples;

-		if (samples_left < nsamples)
-			nsamples = samples_left;
-	}
+	scans_left = __comedi_nscans_left(s, cmd->stop_arg);
+	if (!scans_left)
+		return 0;
+
+	samples_left = scans_left * cmd->scan_end_arg -
+		comedi_bytes_to_samples(s, async->scan_progress);
+
+	if (samples_left < nsamples)
+		return samples_left;
 	return nsamples;
 }
 EXPORT_SYMBOL_GPL(comedi_nsamples_left);
--
2.1.4


^ permalink raw reply related	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2018-06-14 16:19 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-06-12 21:09 [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left Chris Opperman
2018-06-13  9:29 ` Dan Carpenter
2018-06-13 18:26   ` Chris Opperman
2018-06-13 17:33     ` Ian Abbott
2018-06-13 19:05     ` Dan Carpenter
2018-06-14 11:08       ` Ian Abbott
2018-06-14 16:18         ` Chris Opperman
2018-06-13 12:01 ` Ian Abbott

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.