All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] btrfs: rename btrfs_parse_early_options
@ 2018-07-16 14:18 Anand Jain
  2018-07-16 15:01 ` Anand Jain
  0 siblings, 1 reply; 3+ messages in thread
From: Anand Jain @ 2018-07-16 14:18 UTC (permalink / raw)
  To: linux-btrfs

Rename btrfs_parse_early_options() to btrfs_parse_device_options(). As
btrfs_parse_early_options() parses the -o device options and scan the
device provided. So this rename specifies its action. Also the function
name is inline with btrfs_parse_subvol_options().
No functional changes.

Signed-off-by: Anand Jain <anand.jain@oracle.com>
---
 fs/btrfs/super.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/fs/btrfs/super.c b/fs/btrfs/super.c
index 9d340f8d3457..9dc56d3eaa66 100644
--- a/fs/btrfs/super.c
+++ b/fs/btrfs/super.c
@@ -465,9 +465,9 @@ int btrfs_parse_options(struct btrfs_fs_info *info, char *options,
 		case Opt_subvolrootid:
 		case Opt_device:
 			/*
-			 * These are parsed by btrfs_parse_subvol_options
-			 * and btrfs_parse_early_options
-			 * and can be happily ignored here.
+			 * These are parsed by btrfs_parse_subvol_options and
+			 * btrfs_parse_device_options and can be happily
+			 * ignored here.
 			 */
 			break;
 		case Opt_nodatasum:
@@ -883,8 +883,8 @@ int btrfs_parse_options(struct btrfs_fs_info *info, char *options,
  * All other options will be parsed on much later in the mount process and
  * only when we need to allocate a new super block.
  */
-static int btrfs_parse_early_options(const char *options, fmode_t flags,
-				     void *holder)
+static int btrfs_parse_device_options(const char *options, fmode_t flags,
+				      void *holder)
 {
 	substring_t args[MAX_OPT_ARGS];
 	char *device_name, *opts, *orig, *p;
@@ -951,7 +951,7 @@ static int btrfs_parse_subvol_options(const char *options, char **subvol_name,
 
 	/*
 	 * strsep changes the string, duplicate it because
-	 * btrfs_parse_early_options gets called later
+	 * btrfs_parse_device_options gets called later
 	 */
 	opts = kstrdup(options, GFP_KERNEL);
 	if (!opts)
@@ -1558,7 +1558,7 @@ static struct dentry *btrfs_mount_root(struct file_system_type *fs_type,
 	}
 
 	mutex_lock(&uuid_mutex);
-	error = btrfs_parse_early_options(data, mode, fs_type);
+	error = btrfs_parse_device_options(data, mode, fs_type);
 	if (error) {
 		mutex_unlock(&uuid_mutex);
 		goto error_fs_info;
-- 
2.15.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] btrfs: rename btrfs_parse_early_options
  2018-07-16 14:18 [PATCH] btrfs: rename btrfs_parse_early_options Anand Jain
@ 2018-07-16 15:01 ` Anand Jain
  2018-07-17 15:24   ` David Sterba
  0 siblings, 1 reply; 3+ messages in thread
From: Anand Jain @ 2018-07-16 15:01 UTC (permalink / raw)
  To: linux-btrfs



On 07/16/2018 10:18 PM, Anand Jain wrote:
> Rename btrfs_parse_early_options() to btrfs_parse_device_options(). As
> btrfs_parse_early_options() parses the -o device options and scan the
> device provided. So this rename specifies its action. Also the function
> name is inline with btrfs_parse_subvol_options().
> No functional changes.
> 
> Signed-off-by: Anand Jain <anand.jain@oracle.com>
> ---

Forgot to mention: This should be applied on top of
   Gu Jinxiang (2):
   btrfs: make fs_devices to be a local variable
   btrfs: get device pointer from btrfs_scan_one_device

Thanks.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] btrfs: rename btrfs_parse_early_options
  2018-07-16 15:01 ` Anand Jain
@ 2018-07-17 15:24   ` David Sterba
  0 siblings, 0 replies; 3+ messages in thread
From: David Sterba @ 2018-07-17 15:24 UTC (permalink / raw)
  To: Anand Jain; +Cc: linux-btrfs

On Mon, Jul 16, 2018 at 11:01:37PM +0800, Anand Jain wrote:
> On 07/16/2018 10:18 PM, Anand Jain wrote:
> > Rename btrfs_parse_early_options() to btrfs_parse_device_options(). As
> > btrfs_parse_early_options() parses the -o device options and scan the
> > device provided. So this rename specifies its action. Also the function
> > name is inline with btrfs_parse_subvol_options().

Yeah, much more fitting name.

> > No functional changes.
> > 
> > Signed-off-by: Anand Jain <anand.jain@oracle.com>
> > ---
> 
> Forgot to mention: This should be applied on top of
>    Gu Jinxiang (2):
>    btrfs: make fs_devices to be a local variable
>    btrfs: get device pointer from btrfs_scan_one_device

Both are in misc-next now so your patch applied too, thanks.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-07-17 15:57 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-16 14:18 [PATCH] btrfs: rename btrfs_parse_early_options Anand Jain
2018-07-16 15:01 ` Anand Jain
2018-07-17 15:24   ` David Sterba

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.