All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH v3 00/23] tests: Compile-time format string checking for libqtest.h
@ 2018-07-30  8:32 Markus Armbruster
  2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 01/23] libqtest: Document calling conventions Markus Armbruster
                   ` (22 more replies)
  0 siblings, 23 replies; 24+ messages in thread
From: Markus Armbruster @ 2018-07-30  8:32 UTC (permalink / raw)
  To: qemu-devel; +Cc: thuth, f4bug, eblake

This is a reboot of "[PATCH 0/9] tests: Clean up around qmp() and
hmp()" I sent about a year ago.  Back then, Eric folded it into his
"Clean up around qmp() and hmp()" series, which stalled after v4.

My reboot tries to avoid that fate by reducing mission creep.  There
are plenty of good ideas in Eric's series we should mine some day, but
today is not that day.

v3:
* PATCH 13: Quoting bug fixed [Eric]
* PATCH 18: GCC_FMT_ATTR() for migrate() [Eric], function comment
* PATCH 19: Whitespace cleanup [Eric]
* PATCH 21: Messed up indentation fixed [Eric]
* PATCH 23: Commit message improved [Eric]
* PATCH 13+22: Commit message typos fixed [Eric]

v2:
* PATCH 01: Comments tweaked, ripple effect on PATCH 05+13
* PATCH 05: Commit message improved [Thomas]
* PATCH 06: Style fix [Philippe]
* PATCH 16+17: Silence a warning
* PATCH 21-23: New

Eric Blake (1):
  libqtest: Document calling conventions

Markus Armbruster (22):
  libqtest: Rename functions to send QMP messages
  libqtest: Clean up how we read device_del messages
  libqtest: Clean up how we read the QMP greeting
  qobject: Replace qobject_from_jsonf() by qobject_from_jsonf_nofail()
  qobject: New qobject_from_vjsonf_nofail(), qdict_from_vjsonf_nofail()
  libqtest: Simplify qmp_fd_vsend() a bit
  test-qobject-input-visitor: Avoid format string ambiguity
  qobject: qobject_from_jsonv() is dangerous, hide it away
  tests: Pass literal format strings directly to qmp_FOO()
  tests: Clean up string interpolation into QMP input (simple cases)
  cpu-plug-test: Don't pass integers as strings to device_add
  tests: Clean up string interpolation around qtest_qmp_device_add()
  migration-test: Make wait_command() return the "return" member
  tests: New helper qtest_qmp_receive_success()
  migration-test: Make wait_command() cope with '%'
  migration-test: Clean up string interpolation into QMP, part 1
  migration-test: Clean up string interpolation into QMP, part 2
  migration-test: Clean up string interpolation into QMP, part 3
  libqtest: Enable compile-time format string checking
  libqtest: Remove qtest_qmp_discard_response() & friends
  libqtest: Replace qtest_startf() by qtest_initf()
  libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency

 include/qapi/qmp/qjson.h           |  12 +-
 qobject/qjson.c                    |  89 ++++++++++----
 tests/ahci-test.c                  |  32 +++--
 tests/boot-order-test.c            |  12 +-
 tests/boot-serial-test.c           |  10 +-
 tests/cdrom-test.c                 |   6 +-
 tests/check-qjson.c                |  15 +--
 tests/cpu-plug-test.c              |   7 +-
 tests/drive_del-test.c             |   4 +-
 tests/e1000e-test.c                |   6 +-
 tests/endianness-test.c            |  24 ++--
 tests/fdc-test.c                   |  11 +-
 tests/ide-test.c                   |   6 +-
 tests/ipmi-bt-test.c               |   2 +-
 tests/ivshmem-test.c               |   8 +-
 tests/libqos/ahci.c                |   4 +-
 tests/libqos/pci-pc.c              |   9 +-
 tests/libqos/pci.c                 |   7 --
 tests/libqos/pci.h                 |   2 -
 tests/libqos/usb.c                 |  10 +-
 tests/libqos/usb.h                 |   2 +-
 tests/libqtest.c                   | 189 ++++++++++++++---------------
 tests/libqtest.h                   | 124 ++++++++++---------
 tests/m25p80-test.c                |   6 +-
 tests/m48t59-test.c                |   2 +-
 tests/machine-none-test.c          |   2 +-
 tests/migration-test.c             | 186 +++++++++++++---------------
 tests/numa-test.c                  |   4 +-
 tests/pnv-xscom-test.c             |   8 +-
 tests/prom-env-test.c              |  10 +-
 tests/qmp-test.c                   |  20 +--
 tests/sdhci-test.c                 |   6 +-
 tests/tco-test.c                   |   6 +-
 tests/test-filter-mirror.c         |   5 +-
 tests/test-filter-redirector.c     |   9 +-
 tests/test-qga.c                   | 150 ++++++++++-------------
 tests/test-qobject-input-visitor.c |  19 +--
 tests/tpm-util.c                   |  41 ++-----
 tests/usb-hcd-ehci-test.c          |   2 +-
 tests/usb-hcd-ohci-test.c          |   2 +-
 tests/usb-hcd-uhci-test.c          |   4 +-
 tests/usb-hcd-xhci-test.c          |  10 +-
 tests/vhost-user-test.c            |   6 +-
 tests/virtio-balloon-test.c        |   4 +-
 tests/virtio-blk-test.c            |  32 ++---
 tests/virtio-console-test.c        |  12 +-
 tests/virtio-net-test.c            |   3 +-
 tests/virtio-rng-test.c            |   3 +-
 tests/virtio-scsi-test.c           |   2 +-
 tests/virtio-serial-test.c         |   6 +-
 tests/vmgenid-test.c               |   6 +-
 51 files changed, 565 insertions(+), 592 deletions(-)

-- 
2.17.1

^ permalink raw reply	[flat|nested] 24+ messages in thread

end of thread, other threads:[~2018-07-30  8:33 UTC | newest]

Thread overview: 24+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-30  8:32 [Qemu-devel] [PATCH v3 00/23] tests: Compile-time format string checking for libqtest.h Markus Armbruster
2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 01/23] libqtest: Document calling conventions Markus Armbruster
2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 02/23] libqtest: Rename functions to send QMP messages Markus Armbruster
2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 03/23] libqtest: Clean up how we read device_del messages Markus Armbruster
2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 04/23] libqtest: Clean up how we read the QMP greeting Markus Armbruster
2018-07-30  8:32 ` [Qemu-devel] [PATCH v3 05/23] qobject: Replace qobject_from_jsonf() by qobject_from_jsonf_nofail() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 06/23] qobject: New qobject_from_vjsonf_nofail(), qdict_from_vjsonf_nofail() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 07/23] libqtest: Simplify qmp_fd_vsend() a bit Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 08/23] test-qobject-input-visitor: Avoid format string ambiguity Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 09/23] qobject: qobject_from_jsonv() is dangerous, hide it away Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 10/23] tests: Pass literal format strings directly to qmp_FOO() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 11/23] tests: Clean up string interpolation into QMP input (simple cases) Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 12/23] cpu-plug-test: Don't pass integers as strings to device_add Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 13/23] tests: Clean up string interpolation around qtest_qmp_device_add() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 14/23] migration-test: Make wait_command() return the "return" member Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 15/23] tests: New helper qtest_qmp_receive_success() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 16/23] migration-test: Make wait_command() cope with '%' Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 17/23] migration-test: Clean up string interpolation into QMP, part 1 Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 18/23] migration-test: Clean up string interpolation into QMP, part 2 Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 19/23] migration-test: Clean up string interpolation into QMP, part 3 Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 20/23] libqtest: Enable compile-time format string checking Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 21/23] libqtest: Remove qtest_qmp_discard_response() & friends Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 22/23] libqtest: Replace qtest_startf() by qtest_initf() Markus Armbruster
2018-07-30  8:33 ` [Qemu-devel] [PATCH v3 23/23] libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency Markus Armbruster

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.