All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/1] staging:rtl8192u: Fix naming clash of exported symbol
@ 2018-09-04 10:56 John Whitmore
  2018-09-04 10:56 ` [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash John Whitmore
  0 siblings, 1 reply; 4+ messages in thread
From: John Whitmore @ 2018-09-04 10:56 UTC (permalink / raw)
  To: linux-kernel; +Cc: devel, gregkh, sfr, John Whitmore

Not sure of the procedure having made a mess of the build, (by reusing the name
of an exported symbol). I hope that given the obscurity of rtl1892u this doesn't
cause people issues. Obviously given the fact that I renamed an exported symbol
I should have checked the name. Newbie mistake, I can only apologise for the
oversight, sorry.

John Whitmore (1):
  staging:rtl8192u: Rename dot11d_init to fix name clash

 drivers/staging/rtl8192u/ieee80211/dot11d.c | 6 +++---
 drivers/staging/rtl8192u/ieee80211/dot11d.h | 2 +-
 drivers/staging/rtl8192u/r8192U_core.c      | 2 +-
 3 files changed, 5 insertions(+), 5 deletions(-)

-- 
2.18.0


^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash
  2018-09-04 10:56 [PATCH 0/1] staging:rtl8192u: Fix naming clash of exported symbol John Whitmore
@ 2018-09-04 10:56 ` John Whitmore
  2018-09-10  8:19   ` Greg KH
  0 siblings, 1 reply; 4+ messages in thread
From: John Whitmore @ 2018-09-04 10:56 UTC (permalink / raw)
  To: linux-kernel; +Cc: devel, gregkh, sfr, John Whitmore

The function dot11d_init() was previously renamed to clear a style
issue. Unfortunately the new name used, dot11d_init(), clashes with
a sybmol which is exported with the same name. To correct this
problem the function has been renamed to rtl8192u_dot11d_init().

Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>
---
 drivers/staging/rtl8192u/ieee80211/dot11d.c | 6 +++---
 drivers/staging/rtl8192u/ieee80211/dot11d.h | 2 +-
 drivers/staging/rtl8192u/r8192U_core.c      | 2 +-
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/rtl8192u/ieee80211/dot11d.c b/drivers/staging/rtl8192u/ieee80211/dot11d.c
index d3b13f0cfc09..3c8e8ba999cf 100644
--- a/drivers/staging/rtl8192u/ieee80211/dot11d.c
+++ b/drivers/staging/rtl8192u/ieee80211/dot11d.c
@@ -3,7 +3,7 @@
 
 #include "dot11d.h"
 
-void dot11d_init(struct ieee80211_device *ieee)
+void rtl8192u_dot11d_init(struct ieee80211_device *ieee)
 {
 	struct rt_dot11d_info *pDot11dInfo = GET_DOT11D_INFO(ieee);
 
@@ -15,9 +15,9 @@ void dot11d_init(struct ieee80211_device *ieee)
 	memset(pDot11dInfo->max_tx_pwr_dbm_list, 0xFF, MAX_CHANNEL_NUMBER+1);
 	RESET_CIE_WATCHDOG(ieee);
 
-	netdev_info(ieee->dev, "dot11d_init()\n");
+	netdev_info(ieee->dev, "rtl8192u_dot11d_init()\n");
 }
-EXPORT_SYMBOL(dot11d_init);
+EXPORT_SYMBOL(rtl8192u_dot11d_init);
 
 /* Reset to the state as we are just entering a regulatory domain. */
 void dot11d_reset(struct ieee80211_device *ieee)
diff --git a/drivers/staging/rtl8192u/ieee80211/dot11d.h b/drivers/staging/rtl8192u/ieee80211/dot11d.h
index be59f720ae20..d217eb8063c4 100644
--- a/drivers/staging/rtl8192u/ieee80211/dot11d.h
+++ b/drivers/staging/rtl8192u/ieee80211/dot11d.h
@@ -43,7 +43,7 @@ struct rt_dot11d_info {
 #define RESET_CIE_WATCHDOG(ieee_dev) (GET_CIE_WATCHDOG(ieee_dev) = 0)
 #define UPDATE_CIE_WATCHDOG(ieee_dev) (++GET_CIE_WATCHDOG(ieee_dev))
 
-void dot11d_init(struct ieee80211_device *dev);
+void rtl8192u_dot11d_init(struct ieee80211_device *dev);
 void dot11d_reset(struct ieee80211_device *dev);
 void dot11d_update_country_ie(struct ieee80211_device *dev,
 			      u8 *addr,
diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c
index 6b22aaa40ff9..0a21a76dcbc3 100644
--- a/drivers/staging/rtl8192u/r8192U_core.c
+++ b/drivers/staging/rtl8192u/r8192U_core.c
@@ -183,7 +183,7 @@ static void rtl819x_set_channel_map(u8 channel_plan, struct r8192_priv *priv)
 	case COUNTRY_CODE_ISRAEL:
 	case COUNTRY_CODE_TELEC:
 	case COUNTRY_CODE_MIC:
-		dot11d_init(ieee);
+		rtl8192u_dot11d_init(ieee);
 		ieee->bGlobalDomain = false;
 		/* actually 8225 & 8256 rf chips only support B,G,24N mode */
 		if ((priv->rf_chip == RF_8225) || (priv->rf_chip == RF_8256)) {
-- 
2.18.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash
  2018-09-04 10:56 ` [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash John Whitmore
@ 2018-09-10  8:19   ` Greg KH
  2018-09-11 21:07     ` John Whitmore
  0 siblings, 1 reply; 4+ messages in thread
From: Greg KH @ 2018-09-10  8:19 UTC (permalink / raw)
  To: John Whitmore; +Cc: linux-kernel, devel, sfr

On Tue, Sep 04, 2018 at 11:56:23AM +0100, John Whitmore wrote:
> The function dot11d_init() was previously renamed to clear a style
> issue. Unfortunately the new name used, dot11d_init(), clashes with
> a sybmol which is exported with the same name. To correct this
> problem the function has been renamed to rtl8192u_dot11d_init().
> 
> Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>

You forgot a "Reported-by:" tag here.  I'll go add it...

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash
  2018-09-10  8:19   ` Greg KH
@ 2018-09-11 21:07     ` John Whitmore
  0 siblings, 0 replies; 4+ messages in thread
From: John Whitmore @ 2018-09-11 21:07 UTC (permalink / raw)
  To: Greg KH; +Cc: linux-kernel, devel, sfr

On Mon, Sep 10, 2018 at 10:19:29AM +0200, Greg KH wrote:
> On Tue, Sep 04, 2018 at 11:56:23AM +0100, John Whitmore wrote:
> > The function dot11d_init() was previously renamed to clear a style
> > issue. Unfortunately the new name used, dot11d_init(), clashes with
> > a sybmol which is exported with the same name. To correct this
> > problem the function has been renamed to rtl8192u_dot11d_init().
> > 
> > Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>
> 
> You forgot a "Reported-by:" tag here.  I'll go add it...
> 
> thanks,
> 
> greg k-h

Sorry and thank you.

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2018-09-11 21:07 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-09-04 10:56 [PATCH 0/1] staging:rtl8192u: Fix naming clash of exported symbol John Whitmore
2018-09-04 10:56 ` [PATCH 1/1] staging:rtl8192u: Rename dot11d_init to fix name clash John Whitmore
2018-09-10  8:19   ` Greg KH
2018-09-11 21:07     ` John Whitmore

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.