All of lore.kernel.org
 help / color / mirror / Atom feed
From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
To: Robin Murphy <robin.murphy@arm.com>
Cc: Christoph Hellwig <hch@lst.de>, Will Deacon <will.deacon@arm.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	linux-arm-kernel@lists.infradead.org,
	iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 07/10] swiotlb: refactor swiotlb_map_page
Date: Thu, 18 Oct 2018 20:37:15 -0400	[thread overview]
Message-ID: <20181019003715.GI1251@char.us.oracle.com> (raw)
In-Reply-To: <35016142-f06d-e424-5afe-6026b6d57eda@arm.com>

> > +	if (!dma_capable(dev, dma_addr, size) ||
> > +	    swiotlb_force == SWIOTLB_FORCE) {
> > +		trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > +		dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > +	}
> 
> FWIW I prefer the inverse condition and early return of the original code
> here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> a couple of lines), but it's no biggie.
> 
> Reviewed-by: Robin Murphy <robin.murphy@arm.com>

I agree with Robin - it certainly makes it easier to read.

With that small change:
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

Thank you!

> 
> > -	return DIRECT_MAPPING_ERROR;
> > +	return dma_addr;
> >   }
> >   /*
> > 

WARNING: multiple messages have this Message-ID (diff)
From: Konrad Rzeszutek Wilk <konrad.wilk-QHcLZuEGTsvQT0dZR+AlfA@public.gmane.org>
To: Robin Murphy <robin.murphy-5wv7dgnIgG8@public.gmane.org>
Cc: Catalin Marinas <catalin.marinas-5wv7dgnIgG8@public.gmane.org>,
	Will Deacon <will.deacon-5wv7dgnIgG8@public.gmane.org>,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	iommu-cunTk1MwBs9QetFLy7KEm3xJsTq8ys+cHZ5vskTnxNA@public.gmane.org,
	Christoph Hellwig <hch-jcswGhMUV9g@public.gmane.org>,
	linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org
Subject: Re: [PATCH 07/10] swiotlb: refactor swiotlb_map_page
Date: Thu, 18 Oct 2018 20:37:15 -0400	[thread overview]
Message-ID: <20181019003715.GI1251@char.us.oracle.com> (raw)
In-Reply-To: <35016142-f06d-e424-5afe-6026b6d57eda-5wv7dgnIgG8@public.gmane.org>

> > +	if (!dma_capable(dev, dma_addr, size) ||
> > +	    swiotlb_force == SWIOTLB_FORCE) {
> > +		trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > +		dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > +	}
> 
> FWIW I prefer the inverse condition and early return of the original code
> here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> a couple of lines), but it's no biggie.
> 
> Reviewed-by: Robin Murphy <robin.murphy-5wv7dgnIgG8@public.gmane.org>

I agree with Robin - it certainly makes it easier to read.

With that small change:
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk-QHcLZuEGTsvQT0dZR+AlfA@public.gmane.org>

Thank you!

> 
> > -	return DIRECT_MAPPING_ERROR;
> > +	return dma_addr;
> >   }
> >   /*
> > 

WARNING: multiple messages have this Message-ID (diff)
From: konrad.wilk@oracle.com (Konrad Rzeszutek Wilk)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 07/10] swiotlb: refactor swiotlb_map_page
Date: Thu, 18 Oct 2018 20:37:15 -0400	[thread overview]
Message-ID: <20181019003715.GI1251@char.us.oracle.com> (raw)
In-Reply-To: <35016142-f06d-e424-5afe-6026b6d57eda@arm.com>

> > +	if (!dma_capable(dev, dma_addr, size) ||
> > +	    swiotlb_force == SWIOTLB_FORCE) {
> > +		trace_swiotlb_bounced(dev, dma_addr, size, swiotlb_force);
> > +		dma_addr = swiotlb_bounce_page(dev, &phys, size, dir, attrs);
> > +	}
> 
> FWIW I prefer the inverse condition and early return of the original code
> here, which also then allows a tail-call to swiotlb_bounce_page() (and saves
> a couple of lines), but it's no biggie.
> 
> Reviewed-by: Robin Murphy <robin.murphy@arm.com>

I agree with Robin - it certainly makes it easier to read.

With that small change:
Reviewed-by: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>

Thank you!

> 
> > -	return DIRECT_MAPPING_ERROR;
> > +	return dma_addr;
> >   }
> >   /*
> > 

  reply	other threads:[~2018-10-19  0:37 UTC|newest]

Thread overview: 131+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-08  8:02 move swiotlb noncoherent dma support from arm64 to generic code V2 Christoph Hellwig
2018-10-08  8:02 ` Christoph Hellwig
2018-10-08  8:02 ` [PATCH 01/10] swiotlb: remove a pointless comment Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-11 17:49   ` Robin Murphy
2018-10-11 17:49     ` Robin Murphy
2018-10-19  0:09   ` Konrad Rzeszutek Wilk
2018-10-19  0:09     ` Konrad Rzeszutek Wilk
2018-10-19  0:09     ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 02/10] swiotlb: mark is_swiotlb_buffer static Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-11 17:54   ` Robin Murphy
2018-10-11 17:54     ` Robin Murphy
2018-10-19  0:12   ` Konrad Rzeszutek Wilk
2018-10-19  0:12     ` Konrad Rzeszutek Wilk
2018-10-19  0:12     ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 03/10] swiotlb: do not panic on mapping failures Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-11 18:06   ` Robin Murphy
2018-10-11 18:06     ` Robin Murphy
2018-10-19  0:18     ` Konrad Rzeszutek Wilk
2018-10-19  0:18       ` Konrad Rzeszutek Wilk
2018-10-19  0:18       ` Konrad Rzeszutek Wilk
2018-10-19  0:17   ` Konrad Rzeszutek Wilk
2018-10-19  0:17     ` Konrad Rzeszutek Wilk
2018-10-19  0:17     ` Konrad Rzeszutek Wilk
2018-10-19  6:04     ` Christoph Hellwig
2018-10-19  6:04       ` Christoph Hellwig
2018-10-19 13:45       ` Konrad Rzeszutek Wilk
2018-10-19 13:45         ` Konrad Rzeszutek Wilk
2018-10-19 13:45         ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 04/10] swiotlb: remove the overflow buffer Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-11 18:19   ` Robin Murphy
2018-10-11 18:19     ` Robin Murphy
2018-10-12 17:04   ` Catalin Marinas
2018-10-12 17:04     ` Catalin Marinas
2018-10-19  0:23   ` Konrad Rzeszutek Wilk
2018-10-19  0:23     ` Konrad Rzeszutek Wilk
2018-10-19  0:23     ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 05/10] swiotlb: merge swiotlb_unmap_page and unmap_single Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-18 17:44   ` Robin Murphy
2018-10-18 17:44     ` Robin Murphy
2018-10-19  0:25   ` Konrad Rzeszutek Wilk
2018-10-19  0:25     ` Konrad Rzeszutek Wilk
2018-10-19  0:25     ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 06/10] swiotlb: use swiotlb_map_page in swiotlb_map_sg_attrs Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-18 17:53   ` Robin Murphy
2018-10-18 17:53     ` Robin Murphy
2018-10-18 17:53     ` Robin Murphy
2018-10-19  0:33   ` Konrad Rzeszutek Wilk
2018-10-19  0:33     ` Konrad Rzeszutek Wilk
2018-10-19  0:33     ` Konrad Rzeszutek Wilk
2018-11-07  1:27   ` John Stultz
2018-11-07  1:27     ` John Stultz
2018-11-09  7:49     ` Christoph Hellwig
2018-11-09  7:49       ` Christoph Hellwig
2018-11-09 16:37       ` Robin Murphy
2018-11-09 16:37         ` Robin Murphy
2018-11-19 19:36         ` Robin Murphy
2018-11-19 19:36           ` Robin Murphy
2018-11-19 19:36           ` Robin Murphy
2018-11-20  9:22           ` Christoph Hellwig
2018-11-20  9:22             ` Christoph Hellwig
2018-11-13  0:07       ` John Stultz
2018-11-13  0:07         ` John Stultz
2018-11-13  0:26         ` John Stultz
2018-11-13  0:26           ` John Stultz
2018-11-14 14:13         ` Christoph Hellwig
2018-11-14 14:13           ` Christoph Hellwig
2018-11-14 16:12           ` Christoph Hellwig
2018-11-14 16:12             ` Christoph Hellwig
2018-11-19 23:22             ` John Stultz
2018-11-19 23:22               ` John Stultz
2018-11-20  9:25               ` Christoph Hellwig
2018-11-20  9:25                 ` Christoph Hellwig
2018-11-23 18:27                 ` Will Deacon
2018-11-23 18:27                   ` Will Deacon
2018-11-23 19:34                   ` Robin Murphy
2018-11-23 19:34                     ` Robin Murphy
2018-11-26 19:31                     ` Will Deacon
2018-11-26 19:31                       ` Will Deacon
2018-10-08  8:02 ` [PATCH 07/10] swiotlb: refactor swiotlb_map_page Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-18 18:09   ` Robin Murphy
2018-10-18 18:09     ` Robin Murphy
2018-10-19  0:37     ` Konrad Rzeszutek Wilk [this message]
2018-10-19  0:37       ` Konrad Rzeszutek Wilk
2018-10-19  0:37       ` Konrad Rzeszutek Wilk
2018-10-19  6:52       ` Christoph Hellwig
2018-10-19  6:52         ` Christoph Hellwig
2018-10-19  6:52         ` Christoph Hellwig
2018-10-19 13:46         ` Konrad Rzeszutek Wilk
2018-10-19 13:46           ` Konrad Rzeszutek Wilk
2018-10-19 13:46           ` Konrad Rzeszutek Wilk
2018-10-08  8:02 ` [PATCH 08/10] swiotlb: don't dip into swiotlb pool for coherent allocations Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-12 17:04   ` Catalin Marinas
2018-10-12 17:04     ` Catalin Marinas
2018-10-19  0:40   ` Konrad Rzeszutek Wilk
2018-10-19  0:40     ` Konrad Rzeszutek Wilk
2018-10-19  0:40     ` Konrad Rzeszutek Wilk
2018-10-19 16:45   ` Robin Murphy
2018-10-19 16:45     ` Robin Murphy
2018-10-08  8:02 ` [PATCH 09/10] swiotlb: add support for non-coherent DMA Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-19  0:49   ` Konrad Rzeszutek Wilk
2018-10-19  0:49     ` Konrad Rzeszutek Wilk
2018-10-22 17:11   ` Robin Murphy
2018-10-22 17:11     ` Robin Murphy
2018-10-26  8:04     ` Christoph Hellwig
2018-10-26  8:04       ` Christoph Hellwig
2018-10-26  9:59       ` Robin Murphy
2018-10-26  9:59         ` Robin Murphy
2018-10-26  9:59         ` Robin Murphy
2018-10-08  8:02 ` [PATCH 10/10] arm64: use the generic swiotlb_dma_ops Christoph Hellwig
2018-10-08  8:02   ` Christoph Hellwig
2018-10-12 13:01   ` Robin Murphy
2018-10-12 13:01     ` Robin Murphy
2018-10-12 14:40     ` Christoph Hellwig
2018-10-12 14:40       ` Christoph Hellwig
2018-10-12 17:05       ` Catalin Marinas
2018-10-12 17:05         ` Catalin Marinas
2018-10-12 17:05         ` Catalin Marinas
2018-10-22 17:52   ` Robin Murphy
2018-10-22 17:52     ` Robin Murphy
2018-10-22 17:52     ` Robin Murphy
2018-10-26 12:44     ` Christoph Hellwig
2018-10-26 12:44       ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181019003715.GI1251@char.us.oracle.com \
    --to=konrad.wilk@oracle.com \
    --cc=catalin.marinas@arm.com \
    --cc=hch@lst.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.