All of lore.kernel.org
 help / color / mirror / Atom feed
* [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name
@ 2018-11-15 13:16 Andy Shevchenko
  0 siblings, 0 replies; 5+ messages in thread
From: Andy Shevchenko @ 2018-11-15 13:16 UTC (permalink / raw)
  To: Felipe Balbi, Greg Kroah-Hartman, linux-usb, Guenter Roeck,
	Heikki Krogerus, Roger Quadros, Hans de Goede
  Cc: Andy Shevchenko

Since we are going to use the same in Designware USB 3 driver,
rename the property to be consistent across the drivers.

No functional change intended.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: Hans de Goede <hdegoede@redhat.com>
Cc: Guenter Roeck <linux@roeck-us.net>
Acked-by: Hans de Goede <hdegoede@redhat.com>
Acked-by: Guenter Roeck <linux@roeck-us.net>
---
 drivers/platform/x86/intel_cht_int33fe.c | 2 +-
 drivers/usb/typec/tcpm/fusb302.c         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/platform/x86/intel_cht_int33fe.c b/drivers/platform/x86/intel_cht_int33fe.c
index 464fe93657b5..87cbf18d0305 100644
--- a/drivers/platform/x86/intel_cht_int33fe.c
+++ b/drivers/platform/x86/intel_cht_int33fe.c
@@ -79,7 +79,7 @@ static const struct property_entry max17047_props[] = {
 };
 
 static const struct property_entry fusb302_props[] = {
-	PROPERTY_ENTRY_STRING("fcs,extcon-name", "cht_wcove_pwrsrc"),
+	PROPERTY_ENTRY_STRING("linux,extcon-name", "cht_wcove_pwrsrc"),
 	PROPERTY_ENTRY_U32("fcs,max-sink-microvolt", 12000000),
 	PROPERTY_ENTRY_U32("fcs,max-sink-microamp",   3000000),
 	PROPERTY_ENTRY_U32("fcs,max-sink-microwatt", 36000000),
diff --git a/drivers/usb/typec/tcpm/fusb302.c b/drivers/usb/typec/tcpm/fusb302.c
index 43b64d9309d0..e9344997329c 100644
--- a/drivers/usb/typec/tcpm/fusb302.c
+++ b/drivers/usb/typec/tcpm/fusb302.c
@@ -1765,7 +1765,7 @@ static int fusb302_probe(struct i2c_client *client,
 	 * to be set by the platform code which also registers the i2c client
 	 * for the fusb302.
 	 */
-	if (device_property_read_string(dev, "fcs,extcon-name", &name) == 0) {
+	if (device_property_read_string(dev, "linux,extcon-name", &name) == 0) {
 		chip->extcon = extcon_get_extcon_dev(name);
 		if (!chip->extcon)
 			return -EPROBE_DEFER;

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name
@ 2018-12-05  9:41 Andy Shevchenko
  0 siblings, 0 replies; 5+ messages in thread
From: Andy Shevchenko @ 2018-12-05  9:41 UTC (permalink / raw)
  To: Greg Kroah-Hartman
  Cc: Heikki Krogerus, Felipe Balbi, linux-usb, Guenter Roeck,
	Roger Quadros, Hans de Goede

On Wed, Dec 05, 2018 at 10:25:36AM +0100, Greg Kroah-Hartman wrote:
> On Mon, Dec 03, 2018 at 09:23:44PM +0200, Andy Shevchenko wrote:
> > On Thu, Nov 15, 2018 at 04:53:03PM +0200, Heikki Krogerus wrote:

> > > FWIW, the series:
> > > Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>
> > 
> > Greg, can you pick up this patch (first in the series, since dwc3 went through Felipe's tree)?
> 
> Sorry for the delay, now queued up.

NP, thanks!

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name
@ 2018-12-05  9:25 Greg Kroah-Hartman
  0 siblings, 0 replies; 5+ messages in thread
From: Greg Kroah-Hartman @ 2018-12-05  9:25 UTC (permalink / raw)
  To: Andy Shevchenko
  Cc: Heikki Krogerus, Felipe Balbi, linux-usb, Guenter Roeck,
	Roger Quadros, Hans de Goede

On Mon, Dec 03, 2018 at 09:23:44PM +0200, Andy Shevchenko wrote:
> On Thu, Nov 15, 2018 at 04:53:03PM +0200, Heikki Krogerus wrote:
> > On Thu, Nov 15, 2018 at 03:16:19PM +0200, Andy Shevchenko wrote:
> > > Since we are going to use the same in Designware USB 3 driver,
> > > rename the property to be consistent across the drivers.
> > > 
> > > No functional change intended.
> > > 
> > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> > > Cc: Hans de Goede <hdegoede@redhat.com>
> > > Cc: Guenter Roeck <linux@roeck-us.net>
> > > Acked-by: Hans de Goede <hdegoede@redhat.com>
> > > Acked-by: Guenter Roeck <linux@roeck-us.net>
> > 
> > FWIW, the series:
> > Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>
> 
> Greg, can you pick up this patch (first in the series, since dwc3 went through Felipe's tree)?

Sorry for the delay, now queued up.

greg k-h

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name
@ 2018-12-03 19:23 Andy Shevchenko
  0 siblings, 0 replies; 5+ messages in thread
From: Andy Shevchenko @ 2018-12-03 19:23 UTC (permalink / raw)
  To: Heikki Krogerus
  Cc: Felipe Balbi, Greg Kroah-Hartman, linux-usb, Guenter Roeck,
	Roger Quadros, Hans de Goede

On Thu, Nov 15, 2018 at 04:53:03PM +0200, Heikki Krogerus wrote:
> On Thu, Nov 15, 2018 at 03:16:19PM +0200, Andy Shevchenko wrote:
> > Since we are going to use the same in Designware USB 3 driver,
> > rename the property to be consistent across the drivers.
> > 
> > No functional change intended.
> > 
> > Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> > Cc: Hans de Goede <hdegoede@redhat.com>
> > Cc: Guenter Roeck <linux@roeck-us.net>
> > Acked-by: Hans de Goede <hdegoede@redhat.com>
> > Acked-by: Guenter Roeck <linux@roeck-us.net>
> 
> FWIW, the series:
> Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>

Greg, can you pick up this patch (first in the series, since dwc3 went through Felipe's tree)?

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name
@ 2018-11-15 14:53 Heikki Krogerus
  0 siblings, 0 replies; 5+ messages in thread
From: Heikki Krogerus @ 2018-11-15 14:53 UTC (permalink / raw)
  To: Andy Shevchenko
  Cc: Felipe Balbi, Greg Kroah-Hartman, linux-usb, Guenter Roeck,
	Roger Quadros, Hans de Goede

On Thu, Nov 15, 2018 at 03:16:19PM +0200, Andy Shevchenko wrote:
> Since we are going to use the same in Designware USB 3 driver,
> rename the property to be consistent across the drivers.
> 
> No functional change intended.
> 
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Cc: Hans de Goede <hdegoede@redhat.com>
> Cc: Guenter Roeck <linux@roeck-us.net>
> Acked-by: Hans de Goede <hdegoede@redhat.com>
> Acked-by: Guenter Roeck <linux@roeck-us.net>

FWIW, the series:
Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com>

> ---
>  drivers/platform/x86/intel_cht_int33fe.c | 2 +-
>  drivers/usb/typec/tcpm/fusb302.c         | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/platform/x86/intel_cht_int33fe.c b/drivers/platform/x86/intel_cht_int33fe.c
> index 464fe93657b5..87cbf18d0305 100644
> --- a/drivers/platform/x86/intel_cht_int33fe.c
> +++ b/drivers/platform/x86/intel_cht_int33fe.c
> @@ -79,7 +79,7 @@ static const struct property_entry max17047_props[] = {
>  };
>  
>  static const struct property_entry fusb302_props[] = {
> -	PROPERTY_ENTRY_STRING("fcs,extcon-name", "cht_wcove_pwrsrc"),
> +	PROPERTY_ENTRY_STRING("linux,extcon-name", "cht_wcove_pwrsrc"),
>  	PROPERTY_ENTRY_U32("fcs,max-sink-microvolt", 12000000),
>  	PROPERTY_ENTRY_U32("fcs,max-sink-microamp",   3000000),
>  	PROPERTY_ENTRY_U32("fcs,max-sink-microwatt", 36000000),
> diff --git a/drivers/usb/typec/tcpm/fusb302.c b/drivers/usb/typec/tcpm/fusb302.c
> index 43b64d9309d0..e9344997329c 100644
> --- a/drivers/usb/typec/tcpm/fusb302.c
> +++ b/drivers/usb/typec/tcpm/fusb302.c
> @@ -1765,7 +1765,7 @@ static int fusb302_probe(struct i2c_client *client,
>  	 * to be set by the platform code which also registers the i2c client
>  	 * for the fusb302.
>  	 */
> -	if (device_property_read_string(dev, "fcs,extcon-name", &name) == 0) {
> +	if (device_property_read_string(dev, "linux,extcon-name", &name) == 0) {
>  		chip->extcon = extcon_get_extcon_dev(name);
>  		if (!chip->extcon)
>  			return -EPROBE_DEFER;
> -- 
> 2.19.1

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-12-05  9:41 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-15 13:16 [v2,1/3] staging: typec: fusb302: Rename fcs,extcon-name to linux,extcon-name Andy Shevchenko
2018-11-15 14:53 Heikki Krogerus
2018-12-03 19:23 Andy Shevchenko
2018-12-05  9:25 Greg Kroah-Hartman
2018-12-05  9:41 Andy Shevchenko

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.