All of lore.kernel.org
 help / color / mirror / Atom feed
* [RFC] drm/i915: rename alpha_support to preliminary_support.
@ 2018-11-27  1:51 Rodrigo Vivi
  2018-11-27  2:04 ` ✗ Fi.CI.CHECKPATCH: warning for " Patchwork
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Rodrigo Vivi @ 2018-11-27  1:51 UTC (permalink / raw)
  To: intel-gfx; +Cc: Jani Nikula, Rodrigo Vivi

The preliminary support protection flag exists mainly to protect
users with brand new Hardware from having bad experience when
using Linux distribution images containing old kernel versions from
preliminary development times. Distro's ISO images don't get frequent
updates.

This tag was previously created as "preliminary_hw_support",
but later renamed to "alpha_support" since "hw" was causing
some sort of confusion.

Unfortunately the rename brought us a bigger internal problem
since this created yet another ambiguity with project milestones
for a new platform.

By removing the "_hw_", and properly documenting it, both ambiguities
should now be solved.

Many other options were considered:
- under_development
- unsafe_driver
- force_modeset_on_unstable_driver
- and many other variations...

But returning it to something close to the original version we might
minimize the confusion with yet another different name for this flag.

Referrence: https://patchwork.kernel.org/patch/9405229
Cc: Jani Nikula <jani.nikula@intel.com>
Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
Signed-off-by: Rodrigo Vivi <rodrigo.vivi@intel.com>
---
 drivers/gpu/drm/i915/Kconfig             | 17 +++++++++--------
 drivers/gpu/drm/i915/i915_drv.h          |  2 +-
 drivers/gpu/drm/i915/i915_params.c       |  8 +++++---
 drivers/gpu/drm/i915/i915_params.h       |  3 ++-
 drivers/gpu/drm/i915/i915_pci.c          | 12 +++++++-----
 drivers/gpu/drm/i915/intel_csr.c         |  2 +-
 drivers/gpu/drm/i915/intel_device_info.h |  2 +-
 7 files changed, 26 insertions(+), 20 deletions(-)

diff --git a/drivers/gpu/drm/i915/Kconfig b/drivers/gpu/drm/i915/Kconfig
index 33a458b7f1fc..c1d1ed7f42bf 100644
--- a/drivers/gpu/drm/i915/Kconfig
+++ b/drivers/gpu/drm/i915/Kconfig
@@ -42,20 +42,21 @@ config DRM_I915
 
 	  If "M" is selected, the module will be called i915.
 
-config DRM_I915_ALPHA_SUPPORT
-	bool "Enable alpha quality support for new Intel hardware by default"
+config DRM_I915_PRELIMINARY_SUPPORT
+	bool "Enable under development driver for new Intel hardware by default"
 	depends on DRM_I915
 	default n
 	help
 	  Choose this option if you have new Intel hardware and want to enable
-	  the alpha quality i915 driver support for the hardware in this kernel
-	  version. You can also enable the support at runtime using the module
-	  parameter i915.alpha_support=1; this option changes the default for
-	  that module parameter.
+	  unstable driver from preliminary stages of development.
+	  You can also enable the support at runtime using the module
+	  parameter i915.preliminary_support=1; this option changes the default
+	  for that module parameter.
 
 	  It is recommended to upgrade to a kernel version with proper support
-	  as soon as it is available. Generally fixes for platforms with alpha
-	  support are not backported to older kernels.
+	  as soon as it is available. Generally, fixes for platforms under
+	  preliminary support protection flag are not backported to older
+	  kernels versions.
 
 	  If in doubt, say "N".
 
diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
index f763b30f98d9..bc79bc5b1691 100644
--- a/drivers/gpu/drm/i915/i915_drv.h
+++ b/drivers/gpu/drm/i915/i915_drv.h
@@ -2325,7 +2325,7 @@ intel_info(const struct drm_i915_private *dev_priv)
 #define IS_CNL_WITH_PORT_F(dev_priv)   (IS_CANNONLAKE(dev_priv) && \
 					(INTEL_DEVID(dev_priv) & 0x0004) == 0x0004)
 
-#define IS_ALPHA_SUPPORT(intel_info) ((intel_info)->is_alpha_support)
+#define PRELIMINARY_SUPPORT(intel_info) ((intel_info)->preliminary_support)
 
 #define SKL_REVID_A0		0x0
 #define SKL_REVID_B0		0x1
diff --git a/drivers/gpu/drm/i915/i915_params.c b/drivers/gpu/drm/i915/i915_params.c
index 2e0356561839..1c6904a37096 100644
--- a/drivers/gpu/drm/i915/i915_params.c
+++ b/drivers/gpu/drm/i915/i915_params.c
@@ -87,9 +87,11 @@ i915_param_named_unsafe(enable_psr, int, 0600,
 	"(0=disabled, 1=enabled) "
 	"Default: -1 (use per-chip default)");
 
-i915_param_named_unsafe(alpha_support, bool, 0400,
-	"Enable alpha quality driver support for latest hardware. "
-	"See also CONFIG_DRM_I915_ALPHA_SUPPORT.");
+i915_param_named_unsafe(preliminary_support, bool, 0400,
+	"Force the probe and the use of an unstable and preliminary driver."
+	"This flag protects brand new hardware from old preliminary software."
+	"Don't use this flag on production. Please upgrade your kernel instead."
+	"See also CONFIG_DRM_I915_PRELIMINARY_SUPPORT.");
 
 i915_param_named_unsafe(disable_power_well, int, 0400,
 	"Disable display power wells when possible "
diff --git a/drivers/gpu/drm/i915/i915_params.h b/drivers/gpu/drm/i915/i915_params.h
index 7e56c516c815..0e2ae6456980 100644
--- a/drivers/gpu/drm/i915/i915_params.h
+++ b/drivers/gpu/drm/i915/i915_params.h
@@ -55,7 +55,8 @@ struct drm_printer;
 	param(int, reset, 2) \
 	param(unsigned int, inject_load_failure, 0) \
 	/* leave bools at the end to not create holes */ \
-	param(bool, alpha_support, IS_ENABLED(CONFIG_DRM_I915_ALPHA_SUPPORT)) \
+	param(bool, preliminary_support, \
+		    IS_ENABLED(CONFIG_DRM_I915_PRELIMINARY_SUPPORT)) \
 	param(bool, enable_hangcheck, true) \
 	param(bool, fastboot, false) \
 	param(bool, prefault_disable, false) \
diff --git a/drivers/gpu/drm/i915/i915_pci.c b/drivers/gpu/drm/i915/i915_pci.c
index 1b81d7cb209e..b739df6c8de9 100644
--- a/drivers/gpu/drm/i915/i915_pci.c
+++ b/drivers/gpu/drm/i915/i915_pci.c
@@ -629,7 +629,7 @@ static const struct intel_device_info intel_cannonlake_info = {
 static const struct intel_device_info intel_icelake_11_info = {
 	GEN11_FEATURES,
 	PLATFORM(INTEL_ICELAKE),
-	.is_alpha_support = 1,
+	.preliminary_support = 1,
 	.ring_mask = RENDER_RING | BLT_RING | VEBOX_RING | BSD_RING | BSD3_RING,
 };
 
@@ -723,10 +723,12 @@ static int i915_pci_probe(struct pci_dev *pdev, const struct pci_device_id *ent)
 		(struct intel_device_info *) ent->driver_data;
 	int err;
 
-	if (IS_ALPHA_SUPPORT(intel_info) && !i915_modparams.alpha_support) {
-		DRM_INFO("The driver support for your hardware in this kernel version is alpha quality\n"
-			 "See CONFIG_DRM_I915_ALPHA_SUPPORT or i915.alpha_support module parameter\n"
-			 "to enable support in this kernel version, or check for kernel updates.\n");
+	if (PRELIMINARY_SUPPORT(intel_info) &&
+	    !i915_modparams.preliminary_support) {
+		DRM_INFO("The driver support for your hardware in this kernel version was under\n"
+			 "preliminary stages of development. See CONFIG_DRM_I915_PRELIMINARY_SUPPORT\n"
+			 "or i915.preliminary_support module parameter to enable support in this kernel\n"
+			 " version, or check for kernel updates.\n");
 		return -ENODEV;
 	}
 
diff --git a/drivers/gpu/drm/i915/intel_csr.c b/drivers/gpu/drm/i915/intel_csr.c
index a516697bf57d..9c9a0fd598e8 100644
--- a/drivers/gpu/drm/i915/intel_csr.c
+++ b/drivers/gpu/drm/i915/intel_csr.c
@@ -512,7 +512,7 @@ void intel_csr_ucode_init(struct drm_i915_private *dev_priv)
 
 	if (csr->fw_path == NULL) {
 		DRM_DEBUG_KMS("No known CSR firmware for platform, disabling runtime PM\n");
-		WARN_ON(!IS_ALPHA_SUPPORT(INTEL_INFO(dev_priv)));
+		WARN_ON(!PRELIMINARY_SUPPORT(INTEL_INFO(dev_priv)));
 
 		return;
 	}
diff --git a/drivers/gpu/drm/i915/intel_device_info.h b/drivers/gpu/drm/i915/intel_device_info.h
index 88f97210dc49..711b21fbaab8 100644
--- a/drivers/gpu/drm/i915/intel_device_info.h
+++ b/drivers/gpu/drm/i915/intel_device_info.h
@@ -86,7 +86,7 @@ enum intel_ppgtt {
 #define DEV_INFO_FOR_EACH_FLAG(func) \
 	func(is_mobile); \
 	func(is_lp); \
-	func(is_alpha_support); \
+	func(preliminary_support); \
 	/* Keep has_* in alphabetical order */ \
 	func(has_64bit_reloc); \
 	func(has_csr); \
-- 
2.19.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* ✗ Fi.CI.CHECKPATCH: warning for drm/i915: rename alpha_support to preliminary_support.
  2018-11-27  1:51 [RFC] drm/i915: rename alpha_support to preliminary_support Rodrigo Vivi
@ 2018-11-27  2:04 ` Patchwork
  2018-11-27  2:05 ` ✗ Fi.CI.SPARSE: " Patchwork
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 5+ messages in thread
From: Patchwork @ 2018-11-27  2:04 UTC (permalink / raw)
  To: Rodrigo Vivi; +Cc: intel-gfx

== Series Details ==

Series: drm/i915: rename alpha_support to preliminary_support.
URL   : https://patchwork.freedesktop.org/series/53046/
State : warning

== Summary ==

$ dim checkpatch origin/drm-tip
587ae1ba13b1 drm/i915: rename alpha_support to preliminary_support.
-:96: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis
#96: FILE: drivers/gpu/drm/i915/i915_params.c:91:
+i915_param_named_unsafe(preliminary_support, bool, 0400,
+	"Force the probe and the use of an unstable and preliminary driver."

total: 0 errors, 0 warnings, 1 checks, 100 lines checked

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 5+ messages in thread

* ✗ Fi.CI.SPARSE: warning for drm/i915: rename alpha_support to preliminary_support.
  2018-11-27  1:51 [RFC] drm/i915: rename alpha_support to preliminary_support Rodrigo Vivi
  2018-11-27  2:04 ` ✗ Fi.CI.CHECKPATCH: warning for " Patchwork
@ 2018-11-27  2:05 ` Patchwork
  2018-11-27  2:22 ` ✗ Fi.CI.BAT: failure " Patchwork
  2018-11-27  8:26 ` [RFC] " Jani Nikula
  3 siblings, 0 replies; 5+ messages in thread
From: Patchwork @ 2018-11-27  2:05 UTC (permalink / raw)
  To: Rodrigo Vivi; +Cc: intel-gfx

== Series Details ==

Series: drm/i915: rename alpha_support to preliminary_support.
URL   : https://patchwork.freedesktop.org/series/53046/
State : warning

== Summary ==

$ dim sparse origin/drm-tip
Sparse version: v0.5.2
Commit: drm/i915: rename alpha_support to preliminary_support.
+
+Error in reading or end of file.

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 5+ messages in thread

* ✗ Fi.CI.BAT: failure for drm/i915: rename alpha_support to preliminary_support.
  2018-11-27  1:51 [RFC] drm/i915: rename alpha_support to preliminary_support Rodrigo Vivi
  2018-11-27  2:04 ` ✗ Fi.CI.CHECKPATCH: warning for " Patchwork
  2018-11-27  2:05 ` ✗ Fi.CI.SPARSE: " Patchwork
@ 2018-11-27  2:22 ` Patchwork
  2018-11-27  8:26 ` [RFC] " Jani Nikula
  3 siblings, 0 replies; 5+ messages in thread
From: Patchwork @ 2018-11-27  2:22 UTC (permalink / raw)
  To: Rodrigo Vivi; +Cc: intel-gfx

== Series Details ==

Series: drm/i915: rename alpha_support to preliminary_support.
URL   : https://patchwork.freedesktop.org/series/53046/
State : failure

== Summary ==

= CI Bug Log - changes from CI_DRM_5207 -> Patchwork_10908 =

== Summary - FAILURE ==

  Serious unknown changes coming with Patchwork_10908 absolutely need to be
  verified manually.
  
  If you think the reported changes have nothing to do with the changes
  introduced in Patchwork_10908, please notify your bug team to allow them
  to document this new failure mode, which will reduce false positives in CI.

  External URL: https://patchwork.freedesktop.org/api/1.0/series/53046/revisions/1/mbox/

== Possible new issues ==

  Here are the unknown changes that may have been introduced in Patchwork_10908:

  === IGT changes ===

    ==== Possible regressions ====

    igt@gem_exec_suspend@basic-s4-devices:
      fi-ivb-3520m:       PASS -> FAIL

    igt@i915_selftest@live_coherency:
      {fi-icl-u3}:        PASS -> FAIL +12

    igt@i915_selftest@live_execlists:
      {fi-icl-u3}:        NOTRUN -> FAIL +2

    igt@i915_selftest@live_gem:
      {fi-icl-y}:         NOTRUN -> FAIL +16

    igt@i915_selftest@live_hugepages:
      fi-icl-u2:          NOTRUN -> FAIL +16

    
    ==== Warnings ====

    igt@i915_selftest@live_contexts:
      {fi-icl-u3}:        INCOMPLETE (fdo#108315) -> FAIL

    igt@kms_chamelium@hdmi-hpd-fast:
      fi-icl-u2:          PASS -> SKIP +170

    igt@kms_frontbuffer_tracking@basic:
      {fi-icl-u3}:        PASS -> SKIP +229

    igt@kms_pipe_crc_basic@nonblocking-crc-pipe-c:
      {fi-kbl-7567u}:     PASS -> SKIP +33

    
== Known issues ==

  Here are the changes found in Patchwork_10908 that come from known issues:

  === IGT changes ===

    ==== Issues hit ====

    igt@i915_selftest@live_coherency:
      fi-gdg-551:         PASS -> DMESG-FAIL (fdo#107164)

    igt@i915_selftest@live_execlists:
      fi-apl-guc:         PASS -> DMESG-WARN (fdo#108622)

    igt@kms_pipe_crc_basic@suspend-read-crc-pipe-b:
      fi-byt-clapper:     PASS -> FAIL (fdo#103191, fdo#107362)

    {igt@runner@aborted}:
      fi-apl-guc:         NOTRUN -> FAIL (fdo#108622)

    
    ==== Possible fixes ====

    igt@gem_ctx_create@basic-files:
      {fi-icl-u3}:        DMESG-WARN (fdo#107724) -> SKIP

    igt@gem_ctx_switch@basic-default:
      fi-icl-u2:          DMESG-WARN (fdo#107724) -> SKIP

    igt@kms_chamelium@common-hpd-after-suspend:
      fi-icl-u2:          DMESG-FAIL (fdo#107732, fdo#103375, fdo#108070) -> SKIP

    igt@kms_frontbuffer_tracking@basic:
      fi-byt-clapper:     FAIL (fdo#103167) -> PASS

    igt@kms_pipe_crc_basic@hang-read-crc-pipe-a:
      fi-byt-clapper:     FAIL (fdo#103191, fdo#107362) -> PASS

    
  {name}: This element is suppressed. This means it is ignored when computing
          the status of the difference (SUCCESS, WARNING, or FAILURE).

  fdo#103167 https://bugs.freedesktop.org/show_bug.cgi?id=103167
  fdo#103191 https://bugs.freedesktop.org/show_bug.cgi?id=103191
  fdo#103375 https://bugs.freedesktop.org/show_bug.cgi?id=103375
  fdo#107164 https://bugs.freedesktop.org/show_bug.cgi?id=107164
  fdo#107362 https://bugs.freedesktop.org/show_bug.cgi?id=107362
  fdo#107724 https://bugs.freedesktop.org/show_bug.cgi?id=107724
  fdo#107732 https://bugs.freedesktop.org/show_bug.cgi?id=107732
  fdo#108070 https://bugs.freedesktop.org/show_bug.cgi?id=108070
  fdo#108315 https://bugs.freedesktop.org/show_bug.cgi?id=108315
  fdo#108622 https://bugs.freedesktop.org/show_bug.cgi?id=108622


== Participating hosts (52 -> 45) ==

  Additional (1): fi-icl-y 
  Missing    (8): fi-kbl-soraka fi-ilk-m540 fi-hsw-4200u fi-byt-j1900 fi-byt-squawks fi-bsw-cyan fi-ctg-p8600 fi-pnv-d510 


== Build changes ==

    * Linux: CI_DRM_5207 -> Patchwork_10908

  CI_DRM_5207: 5931122c0786671d3f6a46bd672d4e7a3960345e @ git://anongit.freedesktop.org/gfx-ci/linux
  IGT_4729: 2388bbd062c17b5912039101efd4603e8d876c88 @ git://anongit.freedesktop.org/xorg/app/intel-gpu-tools
  Patchwork_10908: 587ae1ba13b1fa0629ea54dfacf161b8d6eec371 @ git://anongit.freedesktop.org/gfx-ci/linux


== Linux commits ==

587ae1ba13b1 drm/i915: rename alpha_support to preliminary_support.

== Logs ==

For more details see: https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_10908/
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [RFC] drm/i915: rename alpha_support to preliminary_support.
  2018-11-27  1:51 [RFC] drm/i915: rename alpha_support to preliminary_support Rodrigo Vivi
                   ` (2 preceding siblings ...)
  2018-11-27  2:22 ` ✗ Fi.CI.BAT: failure " Patchwork
@ 2018-11-27  8:26 ` Jani Nikula
  3 siblings, 0 replies; 5+ messages in thread
From: Jani Nikula @ 2018-11-27  8:26 UTC (permalink / raw)
  To: intel-gfx; +Cc: Rodrigo Vivi

On Mon, 26 Nov 2018, Rodrigo Vivi <rodrigo.vivi@intel.com> wrote:
> The preliminary support protection flag exists mainly to protect
> users with brand new Hardware from having bad experience when
> using Linux distribution images containing old kernel versions from
> preliminary development times. Distro's ISO images don't get frequent
> updates.

I'd prefer it if we aligned first on what we want to achieve with the
flag, whether we want to and/or have to keep it going forward, and how
we define a platform is good enough to drop the flag. After that, we can
discuss whether a rename is in order or not.

BR,
Jani.

-- 
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-11-27  8:26 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-11-27  1:51 [RFC] drm/i915: rename alpha_support to preliminary_support Rodrigo Vivi
2018-11-27  2:04 ` ✗ Fi.CI.CHECKPATCH: warning for " Patchwork
2018-11-27  2:05 ` ✗ Fi.CI.SPARSE: " Patchwork
2018-11-27  2:22 ` ✗ Fi.CI.BAT: failure " Patchwork
2018-11-27  8:26 ` [RFC] " Jani Nikula

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.