All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] Introduce size_to_sectors helper in blkdev.h
@ 2019-04-30  1:32 Marcos Paulo de Souza
  2019-04-30  1:32 ` [PATCH 1/2] blkdev.h: Introduce size_to_sectors hlper function Marcos Paulo de Souza
  2019-04-30  1:32 ` [PATCH 2/2] null_blk: Make use of size_to_sectors helper Marcos Paulo de Souza
  0 siblings, 2 replies; 6+ messages in thread
From: Marcos Paulo de Souza @ 2019-04-30  1:32 UTC (permalink / raw)
  To: linux-block; +Cc: Marcos Paulo de Souza

My previous submission was an RFC, but I got a reviewed-by from Chaitanya, so
I removed the RFc tag.

Changes from v1:
Reworked the documentation of size_to_sectors by removing a sentence that was
explaining the size -> sectors math, which wasn't necessary given the
description prior to the example.

Let me know if you have more suggestions to this code.

Here is the cover letter of the RFC sent prior to this patchset:

While reading code of drivers/block, I was curious about the set_capacity
argument, always shifting the value by 9, and so I took me a while to realize
this is done on purpose: the capacity is the number of sectors of 512 bytes
related to the storage space.

Rather the shifting by 9, there are other places where the value if shifted by
SECTOR_SHIFT, which is more readable.
This patch aims to reduce these differences by adding a new function called
size_to_sectors, adding a proper comment explaining why this is needed.

null_blk was changed to use this new function.

Thanks,
Marco

Marcos Paulo de Souza (2):
  blkdev.h: Introduce size_to_sectors hlper function
  null_blk: Make use of size_to_sectors helper

 drivers/block/null_blk_main.c | 18 +++++++++---------
 include/linux/blkdev.h        | 17 +++++++++++++++++
 2 files changed, 26 insertions(+), 9 deletions(-)

-- 
2.16.4


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2019-05-02 21:51 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-04-30  1:32 [PATCH 0/2] Introduce size_to_sectors helper in blkdev.h Marcos Paulo de Souza
2019-04-30  1:32 ` [PATCH 1/2] blkdev.h: Introduce size_to_sectors hlper function Marcos Paulo de Souza
2019-04-30  2:50   ` Martin K. Petersen
2019-04-30 10:52     ` Marcos Paulo de Souza
2019-05-02 21:51   ` Elliott, Robert (Servers)
2019-04-30  1:32 ` [PATCH 2/2] null_blk: Make use of size_to_sectors helper Marcos Paulo de Souza

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.