All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] kernel: module: Use struct_size() helper
@ 2019-06-04 23:23 Gustavo A. R. Silva
  2019-06-06 18:05 ` Jessica Yu
  0 siblings, 1 reply; 3+ messages in thread
From: Gustavo A. R. Silva @ 2019-06-04 23:23 UTC (permalink / raw)
  To: Jessica Yu; +Cc: linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes, in particular in the
context in which this code is being used.

So, replace the following form:

sizeof(*sect_attrs) + nloaded * sizeof(sect_attrs->attrs[0]

with:

struct_size(sect_attrs, attrs, nloaded)

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 kernel/module.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/kernel/module.c b/kernel/module.c
index 80c7c09584cf..3f3bb090fbf4 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -1492,8 +1492,7 @@ static void add_sect_attrs(struct module *mod, const struct load_info *info)
 	for (i = 0; i < info->hdr->e_shnum; i++)
 		if (!sect_empty(&info->sechdrs[i]))
 			nloaded++;
-	size[0] = ALIGN(sizeof(*sect_attrs)
-			+ nloaded * sizeof(sect_attrs->attrs[0]),
+	size[0] = ALIGN(struct_size(sect_attrs, attrs, nloaded),
 			sizeof(sect_attrs->grp.attrs[0]));
 	size[1] = (nloaded + 1) * sizeof(sect_attrs->grp.attrs[0]);
 	sect_attrs = kzalloc(size[0] + size[1], GFP_KERNEL);
-- 
2.21.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] kernel: module: Use struct_size() helper
  2019-06-04 23:23 [PATCH] kernel: module: Use struct_size() helper Gustavo A. R. Silva
@ 2019-06-06 18:05 ` Jessica Yu
  2019-06-06 18:50   ` Gustavo A. R. Silva
  0 siblings, 1 reply; 3+ messages in thread
From: Jessica Yu @ 2019-06-06 18:05 UTC (permalink / raw)
  To: Gustavo A. R. Silva; +Cc: linux-kernel

+++ Gustavo A. R. Silva [04/06/19 18:23 -0500]:
>Make use of the struct_size() helper instead of an open-coded version
>in order to avoid any potential type mistakes, in particular in the
>context in which this code is being used.
>
>So, replace the following form:
>
>sizeof(*sect_attrs) + nloaded * sizeof(sect_attrs->attrs[0]
>
>with:
>
>struct_size(sect_attrs, attrs, nloaded)
>
>This code was detected with the help of Coccinelle.
>
>Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>

Hi Gustavo!

I see you've sent similar cleanup patches elsewhere, do you think you
could reword your commit message to be more similar to your patch here
for instance:

	https://lkml.org/lkml/2019/6/5/856

It does a *much* better job of explaining the motivation and usage of
struct_size().

Thank you!

Jessica

>---
> kernel/module.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
>diff --git a/kernel/module.c b/kernel/module.c
>index 80c7c09584cf..3f3bb090fbf4 100644
>--- a/kernel/module.c
>+++ b/kernel/module.c
>@@ -1492,8 +1492,7 @@ static void add_sect_attrs(struct module *mod, const struct load_info *info)
> 	for (i = 0; i < info->hdr->e_shnum; i++)
> 		if (!sect_empty(&info->sechdrs[i]))
> 			nloaded++;
>-	size[0] = ALIGN(sizeof(*sect_attrs)
>-			+ nloaded * sizeof(sect_attrs->attrs[0]),
>+	size[0] = ALIGN(struct_size(sect_attrs, attrs, nloaded),
> 			sizeof(sect_attrs->grp.attrs[0]));
> 	size[1] = (nloaded + 1) * sizeof(sect_attrs->grp.attrs[0]);
> 	sect_attrs = kzalloc(size[0] + size[1], GFP_KERNEL);
>-- 
>2.21.0
>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] kernel: module: Use struct_size() helper
  2019-06-06 18:05 ` Jessica Yu
@ 2019-06-06 18:50   ` Gustavo A. R. Silva
  0 siblings, 0 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2019-06-06 18:50 UTC (permalink / raw)
  To: Jessica Yu; +Cc: linux-kernel

Hi Jessica,

On 6/6/19 1:05 PM, Jessica Yu wrote:

> Hi Gustavo!
> 
> I see you've sent similar cleanup patches elsewhere, do you think you
> could reword your commit message to be more similar to your patch here
> for instance:
> 
>     https://lkml.org/lkml/2019/6/5/856
> 
> It does a *much* better job of explaining the motivation and usage of
> struct_size().
> 

Sure thing. :)

I'll send v2 with that change, shortly.

Thanks
--
Gustavo

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-06-06 19:38 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-06-04 23:23 [PATCH] kernel: module: Use struct_size() helper Gustavo A. R. Silva
2019-06-06 18:05 ` Jessica Yu
2019-06-06 18:50   ` Gustavo A. R. Silva

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.