All of lore.kernel.org
 help / color / mirror / Atom feed
* [tip:ras/core] RAS/CEC: Rename count_threshold to action_threshold
@ 2019-06-08 21:28 tip-bot for Borislav Petkov
  2019-06-09  9:06 ` Ingo Molnar
  0 siblings, 1 reply; 3+ messages in thread
From: tip-bot for Borislav Petkov @ 2019-06-08 21:28 UTC (permalink / raw)
  To: linux-tip-commits; +Cc: tony.luck, linux-edac, bp, mingo, hpa, tglx

Commit-ID:  b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
Gitweb:     https://git.kernel.org/tip/b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
Author:     Borislav Petkov <bp@suse.de>
AuthorDate: Sat, 20 Apr 2019 21:30:11 +0200
Committer:  Borislav Petkov <bp@suse.de>
CommitDate: Sat, 8 Jun 2019 17:38:17 +0200

RAS/CEC: Rename count_threshold to action_threshold

... which is the better, more-fitting name anyway.

Tony:
 - make action_threshold u64 due to debugfs accessors expecting u64.
 - rename the remaining: s/count_threshold/action_threshold/g

Co-developed-by: Tony Luck <tony.luck@intel.com>
Signed-off-by: Tony Luck <tony.luck@intel.com>
Signed-off-by: Borislav Petkov <bp@suse.de>
Cc: linux-edac <linux-edac@vger.kernel.org>
---
 drivers/ras/cec.c | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

diff --git a/drivers/ras/cec.c b/drivers/ras/cec.c
index da5797c38051..364f7e1a6bad 100644
--- a/drivers/ras/cec.c
+++ b/drivers/ras/cec.c
@@ -37,9 +37,9 @@
  * thus emulate an an LRU-like behavior when deleting elements to free up space
  * in the page.
  *
- * When an element reaches it's max count of count_threshold, we try to poison
- * it by assuming that errors triggered count_threshold times in a single page
- * are excessive and that page shouldn't be used anymore. count_threshold is
+ * When an element reaches it's max count of action_threshold, we try to poison
+ * it by assuming that errors triggered action_threshold times in a single page
+ * are excessive and that page shouldn't be used anymore. action_threshold is
  * initialized to COUNT_MASK which is the maximum.
  *
  * That error event entry causes cec_add_elem() to return !0 value and thus
@@ -122,7 +122,7 @@ static DEFINE_MUTEX(ce_mutex);
 static u64 dfs_pfn;
 
 /* Amount of errors after which we offline */
-static unsigned int count_threshold = COUNT_MASK;
+static u64 action_threshold = COUNT_MASK;
 
 /* Each element "decays" each decay_interval which is 24hrs by default. */
 #define CEC_DECAY_DEFAULT_INTERVAL	24 * 60 * 60	/* 24 hrs */
@@ -345,7 +345,7 @@ int cec_add_elem(u64 pfn)
 
 	/* Check action threshold and soft-offline, if reached. */
 	count = COUNT(ca->array[to]);
-	if (count >= count_threshold) {
+	if (count >= action_threshold) {
 		u64 pfn = ca->array[to] >> PAGE_SHIFT;
 
 		if (!pfn_valid(pfn)) {
@@ -416,18 +416,18 @@ static int decay_interval_set(void *data, u64 val)
 }
 DEFINE_DEBUGFS_ATTRIBUTE(decay_interval_ops, u64_get, decay_interval_set, "%lld\n");
 
-static int count_threshold_set(void *data, u64 val)
+static int action_threshold_set(void *data, u64 val)
 {
 	*(u64 *)data = val;
 
 	if (val > COUNT_MASK)
 		val = COUNT_MASK;
 
-	count_threshold = val;
+	action_threshold = val;
 
 	return 0;
 }
-DEFINE_DEBUGFS_ATTRIBUTE(count_threshold_ops, u64_get, count_threshold_set, "%lld\n");
+DEFINE_DEBUGFS_ATTRIBUTE(action_threshold_ops, u64_get, action_threshold_set, "%lld\n");
 
 static int array_dump(struct seq_file *m, void *v)
 {
@@ -453,7 +453,7 @@ static int array_dump(struct seq_file *m, void *v)
 	seq_printf(m, "Decay interval: %lld seconds\n", decay_interval);
 	seq_printf(m, "Decays: %lld\n", ca->decays_done);
 
-	seq_printf(m, "Action threshold: %d\n", count_threshold);
+	seq_printf(m, "Action threshold: %lld\n", action_threshold);
 
 	mutex_unlock(&ce_mutex);
 
@@ -502,10 +502,10 @@ static int __init create_debugfs_nodes(void)
 		goto err;
 	}
 
-	count = debugfs_create_file("count_threshold", S_IRUSR | S_IWUSR, d,
-				    &count_threshold, &count_threshold_ops);
+	count = debugfs_create_file("action_threshold", S_IRUSR | S_IWUSR, d,
+				    &action_threshold, &action_threshold_ops);
 	if (!count) {
-		pr_warn("Error creating count_threshold debugfs node!\n");
+		pr_warn("Error creating action_threshold debugfs node!\n");
 		goto err;
 	}
 

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [tip:ras/core] RAS/CEC: Rename count_threshold to action_threshold
  2019-06-08 21:28 [tip:ras/core] RAS/CEC: Rename count_threshold to action_threshold tip-bot for Borislav Petkov
@ 2019-06-09  9:06 ` Ingo Molnar
  2019-06-09 11:57   ` Borislav Petkov
  0 siblings, 1 reply; 3+ messages in thread
From: Ingo Molnar @ 2019-06-09  9:06 UTC (permalink / raw)
  To: linux-edac, hpa, linux-kernel, bp, tony.luck, tglx; +Cc: linux-tip-commits


* tip-bot for Borislav Petkov <tipbot@zytor.com> wrote:

> Commit-ID:  b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
> Gitweb:     https://git.kernel.org/tip/b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
> Author:     Borislav Petkov <bp@suse.de>
> AuthorDate: Sat, 20 Apr 2019 21:30:11 +0200
> Committer:  Borislav Petkov <bp@suse.de>
> CommitDate: Sat, 8 Jun 2019 17:38:17 +0200
> 
> RAS/CEC: Rename count_threshold to action_threshold
> 
> ... which is the better, more-fitting name anyway.
> 
> Tony:
>  - make action_threshold u64 due to debugfs accessors expecting u64.
>  - rename the remaining: s/count_threshold/action_threshold/g
> 
> Co-developed-by: Tony Luck <tony.luck@intel.com>
> Signed-off-by: Tony Luck <tony.luck@intel.com>
> Signed-off-by: Borislav Petkov <bp@suse.de>
> Cc: linux-edac <linux-edac@vger.kernel.org>

JFYI, the SOB chain is a bit messed up here, the proper chain would be:

 Signed-off-by: Borislav Petkov <bp@suse.de>
 Signed-off-by: Tony Luck <tony.luck@intel.com>
 Signed-off-by: Borislav Petkov <bp@suse.de>

This shows that the patch started out as your effort as a developer, then 
Tony enhanced it and passed it to you as maintainer.

See for example this commit for an example:

  7675104990ed ("sched: Implement lockless wake-queues")

Note that this pattern also signals the co-developed portion, so that tag 
can be dropped - but it can be kept too for extra clarity.

Thanks,

	Ingo

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [tip:ras/core] RAS/CEC: Rename count_threshold to action_threshold
  2019-06-09  9:06 ` Ingo Molnar
@ 2019-06-09 11:57   ` Borislav Petkov
  0 siblings, 0 replies; 3+ messages in thread
From: Borislav Petkov @ 2019-06-09 11:57 UTC (permalink / raw)
  To: Ingo Molnar
  Cc: linux-edac, hpa, linux-kernel, tony.luck, tglx, linux-tip-commits

On Sun, Jun 09, 2019 at 11:06:37AM +0200, Ingo Molnar wrote:
> 
> * tip-bot for Borislav Petkov <tipbot@zytor.com> wrote:
> 
> > Commit-ID:  b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
> > Gitweb:     https://git.kernel.org/tip/b8b5ca6600dec2a4f1e50ca9d3cf9e1d032870cd
> > Author:     Borislav Petkov <bp@suse.de>
> > AuthorDate: Sat, 20 Apr 2019 21:30:11 +0200
> > Committer:  Borislav Petkov <bp@suse.de>
> > CommitDate: Sat, 8 Jun 2019 17:38:17 +0200
> > 
> > RAS/CEC: Rename count_threshold to action_threshold
> > 
> > ... which is the better, more-fitting name anyway.
> > 
> > Tony:
> >  - make action_threshold u64 due to debugfs accessors expecting u64.
> >  - rename the remaining: s/count_threshold/action_threshold/g
> > 
> > Co-developed-by: Tony Luck <tony.luck@intel.com>
> > Signed-off-by: Tony Luck <tony.luck@intel.com>
> > Signed-off-by: Borislav Petkov <bp@suse.de>
> > Cc: linux-edac <linux-edac@vger.kernel.org>
> 
> JFYI, the SOB chain is a bit messed up here, the proper chain would be:
> 
>  Signed-off-by: Borislav Petkov <bp@suse.de>
>  Signed-off-by: Tony Luck <tony.luck@intel.com>
>  Signed-off-by: Borislav Petkov <bp@suse.de>
> 
> This shows that the patch started out as your effort as a developer, then 
> Tony enhanced it and passed it to you as maintainer.

Actually, I was trying to point out with the tags that I simply included
changes from Tony because they belonged topically together. There was no
passing. I don't think you can express that with our tags properly thus
the free text above it.

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-06-09 11:57 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-06-08 21:28 [tip:ras/core] RAS/CEC: Rename count_threshold to action_threshold tip-bot for Borislav Petkov
2019-06-09  9:06 ` Ingo Molnar
2019-06-09 11:57   ` Borislav Petkov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.