All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
@ 2019-10-23  8:37 Nicholas Johnson
  2019-10-23  9:47 ` mika.westerberg
  0 siblings, 1 reply; 6+ messages in thread
From: Nicholas Johnson @ 2019-10-23  8:37 UTC (permalink / raw)
  To: linux-kernel; +Cc: linux-pci, bhelgaas, mika.westerberg, corbet, benh, logang

Add kernel parameter pci=hpmmiosize=nn[KMG] to set MMIO bridge window
size for hotplug bridges.

Add kernel parameter pci=hpmmioprefsize=nn[KMG] to set MMIO_PREF bridge
window size for hotplug bridges.

Leave pci=hpmemsize=nn[KMG] unchanged, to prevent disruptions to
existing users. This sets both MMIO and MMIO_PREF to the same size.

The two new parameters conform to the style of pci=hpiosize=nn[KMG].

Signed-off-by: Nicholas Johnson <nicholas.johnson-opensource@outlook.com.au>
---
 .../admin-guide/kernel-parameters.txt         |  9 ++++++-
 drivers/pci/pci.c                             | 17 ++++++++++---
 drivers/pci/pci.h                             |  3 ++-
 drivers/pci/setup-bus.c                       | 25 +++++++++++--------
 4 files changed, 38 insertions(+), 16 deletions(-)

diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
index a84a83f88..cfe8c2b67 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3492,8 +3492,15 @@
 		hpiosize=nn[KMG]	The fixed amount of bus space which is
 				reserved for hotplug bridge's IO window.
 				Default size is 256 bytes.
+		hpmmiosize=nn[KMG]	The fixed amount of bus space which is
+				reserved for hotplug bridge's MMIO window.
+				Default size is 2 megabytes.
+		hpmmioprefsize=nn[KMG]	The fixed amount of bus space which is
+				reserved for hotplug bridge's MMIO_PREF window.
+				Default size is 2 megabytes.
 		hpmemsize=nn[KMG]	The fixed amount of bus space which is
-				reserved for hotplug bridge's memory window.
+				reserved for hotplug bridge's MMIO and
+				MMIO_PREF window.
 				Default size is 2 megabytes.
 		hpbussize=nn	The minimum amount of additional bus numbers
 				reserved for buses below a hotplug bridge.
diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
index a97e2571a..f3adab84b 100644
--- a/drivers/pci/pci.c
+++ b/drivers/pci/pci.c
@@ -85,10 +85,12 @@ unsigned long pci_cardbus_io_size = DEFAULT_CARDBUS_IO_SIZE;
 unsigned long pci_cardbus_mem_size = DEFAULT_CARDBUS_MEM_SIZE;
 
 #define DEFAULT_HOTPLUG_IO_SIZE		(256)
-#define DEFAULT_HOTPLUG_MEM_SIZE	(2*1024*1024)
+#define DEFAULT_HOTPLUG_MMIO_SIZE	(2*1024*1024)
+#define DEFAULT_HOTPLUG_MMIO_PREF_SIZE	(2*1024*1024)
 /* pci=hpmemsize=nnM,hpiosize=nn can override this */
 unsigned long pci_hotplug_io_size  = DEFAULT_HOTPLUG_IO_SIZE;
-unsigned long pci_hotplug_mem_size = DEFAULT_HOTPLUG_MEM_SIZE;
+unsigned long pci_hotplug_mmio_size = DEFAULT_HOTPLUG_MMIO_SIZE;
+unsigned long pci_hotplug_mmio_pref_size = DEFAULT_HOTPLUG_MMIO_PREF_SIZE;
 
 #define DEFAULT_HOTPLUG_BUS_SIZE	1
 unsigned long pci_hotplug_bus_size = DEFAULT_HOTPLUG_BUS_SIZE;
@@ -6286,8 +6288,17 @@ static int __init pci_setup(char *str)
 				pcie_ecrc_get_policy(str + 5);
 			} else if (!strncmp(str, "hpiosize=", 9)) {
 				pci_hotplug_io_size = memparse(str + 9, &str);
+			} else if (!strncmp(str, "hpmmiosize=", 11)) {
+				pci_hotplug_mmio_size =
+					memparse(str + 11, &str);
+			} else if (!strncmp(str, "hpmmioprefsize=", 15)) {
+				pci_hotplug_mmio_pref_size =
+					memparse(str + 15, &str);
 			} else if (!strncmp(str, "hpmemsize=", 10)) {
-				pci_hotplug_mem_size = memparse(str + 10, &str);
+				pci_hotplug_mmio_size =
+					memparse(str + 10, &str);
+				pci_hotplug_mmio_pref_size =
+					memparse(str + 10, &str);
 			} else if (!strncmp(str, "hpbussize=", 10)) {
 				pci_hotplug_bus_size =
 					simple_strtoul(str + 10, &str, 0);
diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h
index 3f6947ee3..9faa55a15 100644
--- a/drivers/pci/pci.h
+++ b/drivers/pci/pci.h
@@ -218,7 +218,8 @@ extern const struct device_type pci_dev_type;
 extern const struct attribute_group *pci_bus_groups[];
 
 extern unsigned long pci_hotplug_io_size;
-extern unsigned long pci_hotplug_mem_size;
+extern unsigned long pci_hotplug_mmio_size;
+extern unsigned long pci_hotplug_mmio_pref_size;
 extern unsigned long pci_hotplug_bus_size;
 
 /**
diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
index e7dbe2170..24fc4c715 100644
--- a/drivers/pci/setup-bus.c
+++ b/drivers/pci/setup-bus.c
@@ -1178,7 +1178,8 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 {
 	struct pci_dev *dev;
 	unsigned long mask, prefmask, type2 = 0, type3 = 0;
-	resource_size_t additional_mem_size = 0, additional_io_size = 0;
+	resource_size_t additional_io_size = 0, additional_mmio_size = 0,
+		additional_mmio_pref_size = 0;
 	struct resource *b_res;
 	int ret;
 
@@ -1212,7 +1213,8 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 		pci_bridge_check_ranges(bus);
 		if (bus->self->is_hotplug_bridge) {
 			additional_io_size  = pci_hotplug_io_size;
-			additional_mem_size = pci_hotplug_mem_size;
+			additional_mmio_size = pci_hotplug_mmio_size;
+			additional_mmio_pref_size = pci_hotplug_mmio_pref_size;
 		}
 		/* Fall through */
 	default:
@@ -1230,9 +1232,9 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 		if (b_res[2].flags & IORESOURCE_MEM_64) {
 			prefmask |= IORESOURCE_MEM_64;
 			ret = pbus_size_mem(bus, prefmask, prefmask,
-				  prefmask, prefmask,
-				  realloc_head ? 0 : additional_mem_size,
-				  additional_mem_size, realloc_head);
+				prefmask, prefmask,
+				realloc_head ? 0 : additional_mmio_pref_size,
+				additional_mmio_pref_size, realloc_head);
 
 			/*
 			 * If successful, all non-prefetchable resources
@@ -1254,9 +1256,9 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 		if (!type2) {
 			prefmask &= ~IORESOURCE_MEM_64;
 			ret = pbus_size_mem(bus, prefmask, prefmask,
-					 prefmask, prefmask,
-					 realloc_head ? 0 : additional_mem_size,
-					 additional_mem_size, realloc_head);
+				prefmask, prefmask,
+				realloc_head ? 0 : additional_mmio_pref_size,
+				additional_mmio_pref_size, realloc_head);
 
 			/*
 			 * If successful, only non-prefetchable resources
@@ -1265,7 +1267,8 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 			if (ret == 0)
 				mask = prefmask;
 			else
-				additional_mem_size += additional_mem_size;
+				additional_mmio_size +=
+					additional_mmio_pref_size;
 
 			type2 = type3 = IORESOURCE_MEM;
 		}
@@ -1285,8 +1288,8 @@ void __pci_bus_size_bridges(struct pci_bus *bus, struct list_head *realloc_head)
 		 * prefetchable resource in a 64-bit prefetchable window.
 		 */
 		pbus_size_mem(bus, mask, IORESOURCE_MEM, type2, type3,
-				realloc_head ? 0 : additional_mem_size,
-				additional_mem_size, realloc_head);
+			realloc_head ? 0 : additional_mmio_size,
+			additional_mmio_size, realloc_head);
 		break;
 	}
 }
-- 
2.23.0


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
  2019-10-23  8:37 [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters Nicholas Johnson
@ 2019-10-23  9:47 ` mika.westerberg
  2019-10-23  9:57   ` Nicholas Johnson
  0 siblings, 1 reply; 6+ messages in thread
From: mika.westerberg @ 2019-10-23  9:47 UTC (permalink / raw)
  To: Nicholas Johnson; +Cc: linux-kernel, linux-pci, bhelgaas, corbet, benh, logang

On Wed, Oct 23, 2019 at 08:37:48AM +0000, Nicholas Johnson wrote:
>  			} else if (!strncmp(str, "hpmemsize=", 10)) {
> -				pci_hotplug_mem_size = memparse(str + 10, &str);
> +				pci_hotplug_mmio_size =
> +					memparse(str + 10, &str);
> +				pci_hotplug_mmio_pref_size =
> +					memparse(str + 10, &str);

Does this actually work correctly? The first memparse(str + 10, &str)
modifies str so the next call will not start from the correct position
anymore.

Otherwise the patch looks good to me.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
  2019-10-23  9:47 ` mika.westerberg
@ 2019-10-23  9:57   ` Nicholas Johnson
  2019-10-23 10:03     ` mika.westerberg
  0 siblings, 1 reply; 6+ messages in thread
From: Nicholas Johnson @ 2019-10-23  9:57 UTC (permalink / raw)
  To: mika.westerberg; +Cc: linux-kernel, linux-pci, bhelgaas, corbet, benh, logang

On Wed, Oct 23, 2019 at 12:47:43PM +0300, mika.westerberg@linux.intel.com wrote:
> On Wed, Oct 23, 2019 at 08:37:48AM +0000, Nicholas Johnson wrote:
> >  			} else if (!strncmp(str, "hpmemsize=", 10)) {
> > -				pci_hotplug_mem_size = memparse(str + 10, &str);
> > +				pci_hotplug_mmio_size =
> > +					memparse(str + 10, &str);
> > +				pci_hotplug_mmio_pref_size =
> > +					memparse(str + 10, &str);
> 
> Does this actually work correctly? The first memparse(str + 10, &str)
> modifies str so the next call will not start from the correct position
> anymore.
I have been using this for a long time now and have not had any issues.
Does it modify str? I thought that was done by the loop.

Can somebody else please weigh in here? I am worried now, and I want to 
be sure. If it is a problem, then I will have to read it into 
pci_hotplug_mmio_size and then set:

pci_hotplug_mmio_pref_size = pci_hotplug_mmio_size

> 
> Otherwise the patch looks good to me.
Thanks, I will re-post with your last suggestions of going over 80 
characters shortly.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
  2019-10-23  9:57   ` Nicholas Johnson
@ 2019-10-23 10:03     ` mika.westerberg
  2019-10-23 10:33       ` Nicholas Johnson
  0 siblings, 1 reply; 6+ messages in thread
From: mika.westerberg @ 2019-10-23 10:03 UTC (permalink / raw)
  To: Nicholas Johnson; +Cc: linux-kernel, linux-pci, bhelgaas, corbet, benh, logang

On Wed, Oct 23, 2019 at 09:57:17AM +0000, Nicholas Johnson wrote:
> On Wed, Oct 23, 2019 at 12:47:43PM +0300, mika.westerberg@linux.intel.com wrote:
> > On Wed, Oct 23, 2019 at 08:37:48AM +0000, Nicholas Johnson wrote:
> > >  			} else if (!strncmp(str, "hpmemsize=", 10)) {
> > > -				pci_hotplug_mem_size = memparse(str + 10, &str);
> > > +				pci_hotplug_mmio_size =
> > > +					memparse(str + 10, &str);
> > > +				pci_hotplug_mmio_pref_size =
> > > +					memparse(str + 10, &str);
> > 
> > Does this actually work correctly? The first memparse(str + 10, &str)
> > modifies str so the next call will not start from the correct position
> > anymore.
> I have been using this for a long time now and have not had any issues.
> Does it modify str? I thought that was done by the loop.

If you add "hpmemsize=xxx" in the command line and print both
pci_hotplug_mmio_size and pci_hotplug_mmio_pref_size after the
assignment, do they have the same value? If yes, then there is no
problem.

> Can somebody else please weigh in here? I am worried now, and I want to 
> be sure. If it is a problem, then I will have to read it into 
> pci_hotplug_mmio_size and then set:
> 
> pci_hotplug_mmio_pref_size = pci_hotplug_mmio_size

Yup.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
  2019-10-23 10:03     ` mika.westerberg
@ 2019-10-23 10:33       ` Nicholas Johnson
  2019-10-23 10:43         ` mika.westerberg
  0 siblings, 1 reply; 6+ messages in thread
From: Nicholas Johnson @ 2019-10-23 10:33 UTC (permalink / raw)
  To: mika.westerberg; +Cc: linux-kernel, linux-pci, bhelgaas, corbet, benh, logang

On Wed, Oct 23, 2019 at 01:03:59PM +0300, mika.westerberg@linux.intel.com wrote:
> On Wed, Oct 23, 2019 at 09:57:17AM +0000, Nicholas Johnson wrote:
> > On Wed, Oct 23, 2019 at 12:47:43PM +0300, mika.westerberg@linux.intel.com wrote:
> > > On Wed, Oct 23, 2019 at 08:37:48AM +0000, Nicholas Johnson wrote:
> > > >  			} else if (!strncmp(str, "hpmemsize=", 10)) {
> > > > -				pci_hotplug_mem_size = memparse(str + 10, &str);
> > > > +				pci_hotplug_mmio_size =
> > > > +					memparse(str + 10, &str);
> > > > +				pci_hotplug_mmio_pref_size =
> > > > +					memparse(str + 10, &str);
> > > 
> > > Does this actually work correctly? The first memparse(str + 10, &str)
> > > modifies str so the next call will not start from the correct position
> > > anymore.
> > I have been using this for a long time now and have not had any issues.
> > Does it modify str? I thought that was done by the loop.
> 
> If you add "hpmemsize=xxx" in the command line and print both
> pci_hotplug_mmio_size and pci_hotplug_mmio_pref_size after the
> assignment, do they have the same value? If yes, then there is no
> problem.
Looking at lib/cmdline.c line 125, it looks like there is no point in me 
testing it. It looks like you are right.

What is the better fix?

pci_hotplug_mmio_size = pci_hotplug_mmio_pref_size = memparse(str + 10, &str);

^ Could be too long, even if we are ignoring the 80-character limit.

> 
> > Can somebody else please weigh in here? I am worried now, and I want to 
> > be sure. If it is a problem, then I will have to read it into 
> > pci_hotplug_mmio_size and then set:
> > 
> > pci_hotplug_mmio_pref_size = pci_hotplug_mmio_size
> 
> Yup.
Or do you prefer the above?

Thanks

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters
  2019-10-23 10:33       ` Nicholas Johnson
@ 2019-10-23 10:43         ` mika.westerberg
  0 siblings, 0 replies; 6+ messages in thread
From: mika.westerberg @ 2019-10-23 10:43 UTC (permalink / raw)
  To: Nicholas Johnson; +Cc: linux-kernel, linux-pci, bhelgaas, corbet, benh, logang

On Wed, Oct 23, 2019 at 10:33:42AM +0000, Nicholas Johnson wrote:
> On Wed, Oct 23, 2019 at 01:03:59PM +0300, mika.westerberg@linux.intel.com wrote:
> > On Wed, Oct 23, 2019 at 09:57:17AM +0000, Nicholas Johnson wrote:
> > > On Wed, Oct 23, 2019 at 12:47:43PM +0300, mika.westerberg@linux.intel.com wrote:
> > > > On Wed, Oct 23, 2019 at 08:37:48AM +0000, Nicholas Johnson wrote:
> > > > >  			} else if (!strncmp(str, "hpmemsize=", 10)) {
> > > > > -				pci_hotplug_mem_size = memparse(str + 10, &str);
> > > > > +				pci_hotplug_mmio_size =
> > > > > +					memparse(str + 10, &str);
> > > > > +				pci_hotplug_mmio_pref_size =
> > > > > +					memparse(str + 10, &str);
> > > > 
> > > > Does this actually work correctly? The first memparse(str + 10, &str)
> > > > modifies str so the next call will not start from the correct position
> > > > anymore.
> > > I have been using this for a long time now and have not had any issues.
> > > Does it modify str? I thought that was done by the loop.
> > 
> > If you add "hpmemsize=xxx" in the command line and print both
> > pci_hotplug_mmio_size and pci_hotplug_mmio_pref_size after the
> > assignment, do they have the same value? If yes, then there is no
> > problem.
> Looking at lib/cmdline.c line 125, it looks like there is no point in me 
> testing it. It looks like you are right.
> 
> What is the better fix?
> 
> pci_hotplug_mmio_size = pci_hotplug_mmio_pref_size = memparse(str + 10, &str);
> 
> ^ Could be too long, even if we are ignoring the 80-character limit.

I prefer this:

				pci_hotplug_mmio_size = memparse(str + 10, &str);
				pci_hotplug_mmio_pref_size = pci_hotplug_mmio_size;

And you can ignore the 80-char limit. The above is much more readable
IMHO.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2019-10-23 10:43 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-10-23  8:37 [PATCH 1/1] PCI: Add hp_mmio_size and hp_mmio_pref_size parameters Nicholas Johnson
2019-10-23  9:47 ` mika.westerberg
2019-10-23  9:57   ` Nicholas Johnson
2019-10-23 10:03     ` mika.westerberg
2019-10-23 10:33       ` Nicholas Johnson
2019-10-23 10:43         ` mika.westerberg

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.