All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Miller <davem@davemloft.net>
To: Mark-MC.Lee@mediatek.com
Cc: sean.wang@mediatek.com, john@phrozen.org, matthias.bgg@gmail.com,
	andrew@lunn.ch, robh+dt@kernel.org, mark.rutland@arm.com,
	opensource@vdorst.com, devicetree@vger.kernel.org,
	netdev@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-mediatek@lists.infradead.org, linux-kernel@vger.kernel.org,
	jakub.kicinski@netronome.com
Subject: Re: [PATCH net] net: ethernet: mediatek: rework GDM setup flow
Date: Thu, 07 Nov 2019 15:49:22 -0800 (PST)	[thread overview]
Message-ID: <20191107.154922.1123372183066604716.davem@davemloft.net> (raw)
In-Reply-To: <20191107105135.1403-1-Mark-MC.Lee@mediatek.com>

From: MarkLee <Mark-MC.Lee@mediatek.com>
Date: Thu, 7 Nov 2019 18:51:35 +0800

> +	for (i = 0; i < 2; i++) {

This is a regression, because in the existing code...

> -	for (i = 0; i < MTK_MAC_COUNT; i++) {

the proper macro is used instead of a magic constant.

You're doing so many things in one change, it's hard to review
and audit.

If you're going to consolidate code, do that only in one change.

Then make other functional changes such as putting the chip into
GDMA_DROP_ALL mode during the stop operation etc.

WARNING: multiple messages have this Message-ID (diff)
From: David Miller <davem@davemloft.net>
To: Mark-MC.Lee@mediatek.com
Cc: mark.rutland@arm.com, andrew@lunn.ch,
	jakub.kicinski@netronome.com, devicetree@vger.kernel.org,
	netdev@vger.kernel.org, sean.wang@mediatek.com,
	linux-kernel@vger.kernel.org, opensource@vdorst.com,
	robh+dt@kernel.org, linux-mediatek@lists.infradead.org,
	john@phrozen.org, matthias.bgg@gmail.com,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH net] net: ethernet: mediatek: rework GDM setup flow
Date: Thu, 07 Nov 2019 15:49:22 -0800 (PST)	[thread overview]
Message-ID: <20191107.154922.1123372183066604716.davem@davemloft.net> (raw)
In-Reply-To: <20191107105135.1403-1-Mark-MC.Lee@mediatek.com>

From: MarkLee <Mark-MC.Lee@mediatek.com>
Date: Thu, 7 Nov 2019 18:51:35 +0800

> +	for (i = 0; i < 2; i++) {

This is a regression, because in the existing code...

> -	for (i = 0; i < MTK_MAC_COUNT; i++) {

the proper macro is used instead of a magic constant.

You're doing so many things in one change, it's hard to review
and audit.

If you're going to consolidate code, do that only in one change.

Then make other functional changes such as putting the chip into
GDMA_DROP_ALL mode during the stop operation etc.

_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

WARNING: multiple messages have this Message-ID (diff)
From: David Miller <davem@davemloft.net>
To: Mark-MC.Lee@mediatek.com
Cc: mark.rutland@arm.com, andrew@lunn.ch,
	jakub.kicinski@netronome.com, devicetree@vger.kernel.org,
	netdev@vger.kernel.org, sean.wang@mediatek.com,
	linux-kernel@vger.kernel.org, opensource@vdorst.com,
	robh+dt@kernel.org, linux-mediatek@lists.infradead.org,
	john@phrozen.org, matthias.bgg@gmail.com,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH net] net: ethernet: mediatek: rework GDM setup flow
Date: Thu, 07 Nov 2019 15:49:22 -0800 (PST)	[thread overview]
Message-ID: <20191107.154922.1123372183066604716.davem@davemloft.net> (raw)
In-Reply-To: <20191107105135.1403-1-Mark-MC.Lee@mediatek.com>

From: MarkLee <Mark-MC.Lee@mediatek.com>
Date: Thu, 7 Nov 2019 18:51:35 +0800

> +	for (i = 0; i < 2; i++) {

This is a regression, because in the existing code...

> -	for (i = 0; i < MTK_MAC_COUNT; i++) {

the proper macro is used instead of a magic constant.

You're doing so many things in one change, it's hard to review
and audit.

If you're going to consolidate code, do that only in one change.

Then make other functional changes such as putting the chip into
GDMA_DROP_ALL mode during the stop operation etc.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2019-11-07 23:49 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-07 10:51 [PATCH net] net: ethernet: mediatek: rework GDM setup flow MarkLee
2019-11-07 10:51 ` MarkLee
2019-11-07 10:51 ` MarkLee
2019-11-07 23:49 ` David Miller [this message]
2019-11-07 23:49   ` David Miller
2019-11-07 23:49   ` David Miller
2019-11-08  8:13   ` mtk15127
2019-11-08  8:13     ` mtk15127
2019-11-08  8:13     ` mtk15127

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191107.154922.1123372183066604716.davem@davemloft.net \
    --to=davem@davemloft.net \
    --cc=Mark-MC.Lee@mediatek.com \
    --cc=andrew@lunn.ch \
    --cc=devicetree@vger.kernel.org \
    --cc=jakub.kicinski@netronome.com \
    --cc=john@phrozen.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=mark.rutland@arm.com \
    --cc=matthias.bgg@gmail.com \
    --cc=netdev@vger.kernel.org \
    --cc=opensource@vdorst.com \
    --cc=robh+dt@kernel.org \
    --cc=sean.wang@mediatek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.