All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 00/11] RFC: [for 5.0]: HMP monitor handlers refactoring
@ 2020-01-30 12:34 Maxim Levitsky
  2020-01-30 12:34 ` [PATCH v4 01/11] usb/dev-storage: remove unused include Maxim Levitsky
                   ` (11 more replies)
  0 siblings, 12 replies; 20+ messages in thread
From: Maxim Levitsky @ 2020-01-30 12:34 UTC (permalink / raw)
  To: qemu-devel
  Cc: Kevin Wolf, Maxim Levitsky, qemu-block, Markus Armbruster,
	Dr. David Alan Gilbert, Gerd Hoffmann, Max Reitz

This patch series is bunch of cleanups to the hmp monitor code.
It mostly moves the blockdev related hmp handlers to its own file,
and does some minor refactoring.

No functional changes expected.

Changes from V1:
   * move the handlers to block/monitor/block-hmp-cmds.c
   * tiny cleanup for the commit messages

Changes from V2:
   * Moved all the function prototypes to new header (blockdev-hmp-cmds.h)
   * Set the license of blockdev-hmp-cmds.c to GPLv2+
   * Moved hmp_snapshot_* functions to blockdev-hmp-cmds.c
   * Moved hmp_drive_add_node to blockdev-hmp-cmds.c
     (this change needed some new exports, thus in separate new patch)
   * Moved hmp_qemu_io and hmp_eject to blockdev-hmp-cmds.c
   * Added 'error:' prefix to vreport, and updated the iotests
     This is invasive change, but really feels like the right one
   * Added minor refactoring patch that drops an unused #include

Changes from V3:
   * Dropped the error prefix patches for now due to fact that it seems
     that libvirt doesn't need that after all. Oh well...
     I'll send them in a separate series.

   * Hopefully correctly merged the copyright info the new files
     Both files are GPLv2 now (due to code from hmp.h/hmp-cmds.c)

   * Addressed review feedback
   * Renamed the added header to block-hmp-cmds.h

   * Got rid of checkpatch.pl warnings in the moved code
     (cosmetic code changes only)

   * I kept the reviewed-by tags, since the changes I did are minor.
     I hope that this is right thing to do.

Best regards,
	Maxim Levitsky

Maxim Levitsky (11):
  usb/dev-storage: remove unused include
  monitor/hmp: uninline add_init_drive
  monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c
  monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c
  monitor/hmp: move hmp_drive_mirror and hmp_drive_backup to
    block-hmp-cmds.c Moved code was added after 2012-01-13, thus under
    GPLv2+
  monitor/hmp: move hmp_block_job* to block-hmp-cmds.c
  monitor/hmp: move hmp_snapshot_* to block-hmp-cmds.c
    hmp_snapshot_blkdev is from GPLv2 version of the hmp-cmds.c thus
    have to change the licence to GPLv2
  monitor/hmp: move hmp_nbd_server* to block-hmp-cmds.c
  monitor/hmp: move remaining hmp_block* functions to block-hmp-cmds.c
  monitor/hmp: move hmp_info_block* to block-hmp-cmds.c
  monitor/hmp: Move hmp_drive_add_node to block-hmp-cmds.c

 MAINTAINERS                    |    1 +
 Makefile.objs                  |    2 +-
 block/Makefile.objs            |    1 +
 block/monitor/Makefile.objs    |    1 +
 block/monitor/block-hmp-cmds.c | 1002 ++++++++++++++++++++++++++++++++
 blockdev.c                     |  137 +----
 device-hotplug.c               |   91 ---
 hw/usb/dev-storage.c           |    1 -
 include/block/block-hmp-cmds.h |   54 ++
 include/block/block_int.h      |    5 +-
 include/monitor/hmp.h          |   24 -
 include/sysemu/blockdev.h      |    4 -
 include/sysemu/sysemu.h        |    3 -
 monitor/hmp-cmds.c             |  769 ------------------------
 monitor/misc.c                 |    1 +
 15 files changed, 1072 insertions(+), 1024 deletions(-)
 create mode 100644 block/monitor/Makefile.objs
 create mode 100644 block/monitor/block-hmp-cmds.c
 delete mode 100644 device-hotplug.c
 create mode 100644 include/block/block-hmp-cmds.h

-- 
2.17.2



^ permalink raw reply	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2020-03-04  8:14 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-30 12:34 [PATCH v4 00/11] RFC: [for 5.0]: HMP monitor handlers refactoring Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 01/11] usb/dev-storage: remove unused include Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 02/11] monitor/hmp: uninline add_init_drive Maxim Levitsky
2020-03-03 17:10   ` Kevin Wolf
2020-03-04  8:12     ` Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 03/11] monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 04/11] monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 05/11] monitor/hmp: move hmp_drive_mirror and hmp_drive_backup to block-hmp-cmds.c Moved code was added after 2012-01-13, thus under GPLv2+ Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 06/11] monitor/hmp: move hmp_block_job* to block-hmp-cmds.c Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 07/11] monitor/hmp: move hmp_snapshot_* to block-hmp-cmds.c hmp_snapshot_blkdev is from GPLv2 version of the hmp-cmds.c thus have to change the licence to GPLv2 Maxim Levitsky
2020-03-03 17:15   ` Kevin Wolf
2020-03-04  8:13     ` Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 08/11] monitor/hmp: move hmp_nbd_server* to block-hmp-cmds.c Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 09/11] monitor/hmp: move remaining hmp_block* functions " Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 10/11] monitor/hmp: move hmp_info_block* " Maxim Levitsky
2020-01-30 12:34 ` [PATCH v4 11/11] monitor/hmp: Move hmp_drive_add_node " Maxim Levitsky
2020-02-03 19:57 ` [PATCH v4 00/11] RFC: [for 5.0]: HMP monitor handlers refactoring Dr. David Alan Gilbert
2020-02-04  8:15   ` Maxim Levitsky
2020-02-07 18:28     ` Dr. David Alan Gilbert
2020-02-20 17:06       ` Maxim Levitsky

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.