All of lore.kernel.org
 help / color / mirror / Atom feed
* clean up the attr interface v4
@ 2020-02-17 12:59 Christoph Hellwig
  2020-02-17 12:59 ` [PATCH 01/31] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE Christoph Hellwig
                   ` (31 more replies)
  0 siblings, 32 replies; 77+ messages in thread
From: Christoph Hellwig @ 2020-02-17 12:59 UTC (permalink / raw)
  To: linux-xfs; +Cc: Allison Collins

Also available as a git tree here:

    http://git.infradead.org/users/hch/xfs.git/shortlog/refs/heads/xfs-attr-cleanup

An xfsprogs tree porting over the libxfs changes is available here:

    http://git.infradead.org/users/hch/xfsprogs.git/shortlog/refs/heads/attr-cleanup

Changes since v3:
 - clean up a cast
 - fixup a comment
 - fix a flags check to use the right flags (bisection only)
 - move a few hunks around to better spots in the series

Changes since v2:
 - add more comments
 - fix up an error handling corner case in __xfs_set_acl
 - add more cowbell^H^H^H^H^H^H^Hbool
 - add a new patch to reject invalid namespaces flags in
   XFS_IOC_ATTRLIST_BY_HANDLE
 - remove ATTR_ENTSIZE entirely

Changes since v1:
 - rebased to for-next, which includes the fixes from the first
   version

^ permalink raw reply	[flat|nested] 77+ messages in thread
* clean up the attr interface v5
@ 2020-02-21 14:11 Christoph Hellwig
  2020-02-21 14:11 ` [PATCH 09/31] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
  0 siblings, 1 reply; 77+ messages in thread
From: Christoph Hellwig @ 2020-02-21 14:11 UTC (permalink / raw)
  To: linux-xfs; +Cc: Allison Collins

Also available as a git tree here:

    http://git.infradead.org/users/hch/xfs.git/shortlog/refs/heads/xfs-attr-cleanup.5

An xfsprogs tree porting over the libxfs changes is available here:

    http://git.infradead.org/users/hch/xfsprogs.git/shortlog/refs/heads/attr-cleanup

Changes since v4:
 - rename the attr_namespace field to attr_filter
 - drop "properly type the buffer field in struct
   xfs_fsop_attrlist_handlere", this was causing too much discussion for
   a trivial cleanup
 - improve a few commit messages and comments
 - improve the ATTR_REPLACE checks a little more
 - turn the xfs_forget_acl stub into an inline function
 - fix a 0 vs NULL sparse warning in xfs_ioc_attr_list

Changes since v3:
 - clean up a cast
 - fixup a comment
 - fix a flags check to use the right flags (bisection only)
 - move a few hunks around to better spots in the series

Changes since v2:
 - add more comments
 - fix up an error handling corner case in __xfs_set_acl
 - add more cowbell^H^H^H^H^H^H^Hbool
 - add a new patch to reject invalid namespaces flags in
   XFS_IOC_ATTRLIST_BY_HANDLE
 - remove ATTR_ENTSIZE entirely

Changes since v1:
 - rebased to for-next, which includes the fixes from the first
   version

^ permalink raw reply	[flat|nested] 77+ messages in thread

end of thread, other threads:[~2020-02-24 19:56 UTC | newest]

Thread overview: 77+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-17 12:59 clean up the attr interface v4 Christoph Hellwig
2020-02-17 12:59 ` [PATCH 01/31] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE Christoph Hellwig
2020-02-17 21:48   ` Dave Chinner
2020-02-19  0:49     ` Darrick J. Wong
2020-02-17 12:59 ` [PATCH 02/31] xfs: remove the ATTR_INCOMPLETE flag Christoph Hellwig
2020-02-17 21:51   ` Dave Chinner
2020-02-18 15:19     ` Christoph Hellwig
2020-02-17 12:59 ` [PATCH 03/31] xfs: merge xfs_attr_remove into xfs_attr_set Christoph Hellwig
2020-02-17 22:02   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 04/31] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set Christoph Hellwig
2020-02-17 22:04   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 05/31] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2020-02-17 22:15   ` Dave Chinner
2020-02-18 15:24     ` Christoph Hellwig
2020-02-19  0:38       ` Darrick J. Wong
2020-02-19  4:03         ` Dave Chinner
2020-02-17 12:59 ` [PATCH 06/31] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op Christoph Hellwig
2020-02-17 22:28   ` Dave Chinner
2020-02-18 15:28     ` Christoph Hellwig
2020-02-17 12:59 ` [PATCH 07/31] xfs: remove the name == NULL check from xfs_attr_args_init Christoph Hellwig
2020-02-17 22:29   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 08/31] xfs: remove the MAXNAMELEN " Christoph Hellwig
2020-02-17 22:29   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 09/31] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
2020-02-17 12:59 ` [PATCH 10/31] xfs: turn xfs_da_args.value into a void pointer Christoph Hellwig
2020-02-17 12:59 ` [PATCH 11/31] xfs: pass an initialized xfs_da_args structure to xfs_attr_set Christoph Hellwig
2020-02-17 12:59 ` [PATCH 12/31] xfs: pass an initialized xfs_da_args to xfs_attr_get Christoph Hellwig
2020-02-17 12:59 ` [PATCH 13/31] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked Christoph Hellwig
2020-02-17 23:06   ` Dave Chinner
2020-02-18 15:30     ` Christoph Hellwig
2020-02-17 12:59 ` [PATCH 14/31] xfs: remove ATTR_KERNOVAL Christoph Hellwig
2020-02-17 23:06   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 15/31] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Christoph Hellwig
2020-02-17 23:09   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 16/31] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Christoph Hellwig
2020-02-17 23:21   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 17/31] xfs: factor out a xfs_attr_match helper Christoph Hellwig
2020-02-17 23:23   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 18/31] xfs: cleanup struct xfs_attr_list_context Christoph Hellwig
2020-02-17 23:25   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 19/31] xfs: remove the unused ATTR_ENTRY macro Christoph Hellwig
2020-02-17 23:25   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 20/31] xfs: open code ATTR_ENTSIZE Christoph Hellwig
2020-02-17 23:32   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 21/31] xfs: move the legacy xfs_attr_list to xfs_ioctl.c Christoph Hellwig
2020-02-17 23:41   ` Dave Chinner
2020-02-18 15:38     ` Christoph Hellwig
2020-02-17 12:59 ` [PATCH 22/31] xfs: rename xfs_attr_list_int to xfs_attr_list Christoph Hellwig
2020-02-17 23:42   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 23/31] xfs: properly type the buffer field in struct xfs_fsop_attrlist_handlereq Christoph Hellwig
2020-02-17 23:53   ` Dave Chinner
2020-02-18 15:39     ` Christoph Hellwig
2020-02-19  0:58       ` Darrick J. Wong
2020-02-19  4:10         ` Dave Chinner
2020-02-17 12:59 ` [PATCH 24/31] xfs: lift common checks into xfs_ioc_attr_list Christoph Hellwig
2020-02-17 23:47   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 25/31] xfs: lift buffer allocation " Christoph Hellwig
2020-02-17 23:55   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 26/31] xfs: lift cursor copy in/out " Christoph Hellwig
2020-02-18  0:03   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 27/31] xfs: improve xfs_forget_acl Christoph Hellwig
2020-02-18  1:58   ` Dave Chinner
2020-02-17 12:59 ` [PATCH 28/31] xfs: clean up the ATTR_REPLACE checks Christoph Hellwig
2020-02-18  2:06   ` Dave Chinner
2020-02-18 15:41     ` Christoph Hellwig
2020-02-17 12:59 ` [PATCH 29/31] xfs: clean up the attr flag confusion Christoph Hellwig
2020-02-17 12:59 ` [PATCH 30/31] xfs: remove XFS_DA_OP_INCOMPLETE Christoph Hellwig
2020-02-18  2:23   ` Dave Chinner
2020-02-18 15:48     ` Christoph Hellwig
2020-02-19  0:47       ` Darrick J. Wong
2020-02-19  6:53         ` Dave Chinner
2020-02-17 12:59 ` [PATCH 31/31] xfs: embedded the attrlist cursor into struct xfs_attr_list_context Christoph Hellwig
2020-02-18  2:24   ` Dave Chinner
2020-02-19  0:48 ` clean up the attr interface v4 Darrick J. Wong
2020-02-21 14:11 clean up the attr interface v5 Christoph Hellwig
2020-02-21 14:11 ` [PATCH 09/31] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
2020-02-21 22:57   ` Dave Chinner
2020-02-24 19:56     ` Christoph Hellwig

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.