All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] vfs: Rename __is_local_mountpoint to is_local_mountpoint
@ 2020-02-24 17:01 Nikolay Borisov
  2020-02-24 17:18 ` Al Viro
  0 siblings, 1 reply; 3+ messages in thread
From: Nikolay Borisov @ 2020-02-24 17:01 UTC (permalink / raw)
  To: viro; +Cc: linux-fsdevel, Nikolay Borisov

Current is_local_mountpoint is a simple wrapper with added d_mountpoint
check. However, the same check is the first thing which
__is_local_mountpoint performs. So remove the wrapper and promote the
private helper to is_local_mountpoint. No semantics changes.

Signed-off-by: Nikolay Borisov <nborisov@suse.com>
---
 fs/mount.h     | 9 +--------
 fs/namespace.c | 4 ++--
 2 files changed, 3 insertions(+), 10 deletions(-)

diff --git a/fs/mount.h b/fs/mount.h
index 711a4093e475..bdbd2ad79209 100644
--- a/fs/mount.h
+++ b/fs/mount.h
@@ -140,14 +140,7 @@ struct proc_mounts {
 
 extern const struct seq_operations mounts_op;
 
-extern bool __is_local_mountpoint(struct dentry *dentry);
-static inline bool is_local_mountpoint(struct dentry *dentry)
-{
-	if (!d_mountpoint(dentry))
-		return false;
-
-	return __is_local_mountpoint(dentry);
-}
+extern bool is_local_mountpoint(struct dentry *dentry);
 
 static inline bool is_anon_ns(struct mnt_namespace *ns)
 {
diff --git a/fs/namespace.c b/fs/namespace.c
index 85b5f7bea82e..6d1f00849ac6 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -649,7 +649,7 @@ struct vfsmount *lookup_mnt(const struct path *path)
 }
 
 /*
- * __is_local_mountpoint - Test to see if dentry is a mountpoint in the
+ * is_local_mountpoint - Test to see if dentry is a mountpoint in the
  *                         current mount namespace.
  *
  * The common case is dentries are not mountpoints at all and that
@@ -663,7 +663,7 @@ struct vfsmount *lookup_mnt(const struct path *path)
  * namespace not just a mount that happens to have some specified
  * parent mount.
  */
-bool __is_local_mountpoint(struct dentry *dentry)
+bool is_local_mountpoint(struct dentry *dentry)
 {
 	struct mnt_namespace *ns = current->nsproxy->mnt_ns;
 	struct mount *mnt;
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] vfs: Rename __is_local_mountpoint to is_local_mountpoint
  2020-02-24 17:01 [PATCH] vfs: Rename __is_local_mountpoint to is_local_mountpoint Nikolay Borisov
@ 2020-02-24 17:18 ` Al Viro
  2020-02-24 17:32   ` Nikolay Borisov
  0 siblings, 1 reply; 3+ messages in thread
From: Al Viro @ 2020-02-24 17:18 UTC (permalink / raw)
  To: Nikolay Borisov; +Cc: linux-fsdevel

On Mon, Feb 24, 2020 at 07:01:42PM +0200, Nikolay Borisov wrote:
> Current is_local_mountpoint is a simple wrapper with added d_mountpoint
> check. However, the same check is the first thing which
> __is_local_mountpoint performs. So remove the wrapper and promote the
> private helper to is_local_mountpoint. No semantics changes.

NAK.  "No semantics changes" does not cut it - inline helper that checks
some unlikely condition and calls an out-of-line version is a fairly
common pattern, with legitimate uses.  It *may* be unwarranted here,
but you need more serious analysis than that.  I'm not saying that
the patch is wrong, but you'll also need to explain why removing the
check from __is_local_mountpoint() (and marking the condition unlikely
in the wrapper) would be worse than what you propose.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] vfs: Rename __is_local_mountpoint to is_local_mountpoint
  2020-02-24 17:18 ` Al Viro
@ 2020-02-24 17:32   ` Nikolay Borisov
  0 siblings, 0 replies; 3+ messages in thread
From: Nikolay Borisov @ 2020-02-24 17:32 UTC (permalink / raw)
  To: Al Viro; +Cc: linux-fsdevel



On 24.02.20 г. 19:18 ч., Al Viro wrote:
> On Mon, Feb 24, 2020 at 07:01:42PM +0200, Nikolay Borisov wrote:
>> Current is_local_mountpoint is a simple wrapper with added d_mountpoint
>> check. However, the same check is the first thing which
>> __is_local_mountpoint performs. So remove the wrapper and promote the
>> private helper to is_local_mountpoint. No semantics changes.
> 
> NAK.  "No semantics changes" does not cut it - inline helper that checks
> some unlikely condition and calls an out-of-line version is a fairly
> common pattern, with legitimate uses.  It *may* be unwarranted here,
> but you need more serious analysis than that.  I'm not saying that
> the patch is wrong, but you'll also need to explain why removing the
> check from __is_local_mountpoint() (and marking the condition unlikely
> in the wrapper) would be worse than what you propose.
> 

My main motivation was to collapse the number of functions so it's
easier to see what's going on and removing duplicate check. If you are
going to accept the alternative version you proposed I'm fine sending it.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-02-24 17:32 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-24 17:01 [PATCH] vfs: Rename __is_local_mountpoint to is_local_mountpoint Nikolay Borisov
2020-02-24 17:18 ` Al Viro
2020-02-24 17:32   ` Nikolay Borisov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.