All of lore.kernel.org
 help / color / mirror / Atom feed
* clean up the attr interface v7
@ 2020-02-26 20:22 Christoph Hellwig
  2020-02-26 20:22 ` [PATCH 01/32] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE Christoph Hellwig
                   ` (31 more replies)
  0 siblings, 32 replies; 37+ messages in thread
From: Christoph Hellwig @ 2020-02-26 20:22 UTC (permalink / raw)
  To: linux-xfs

Also available as a git tree here:

    http://git.infradead.org/users/hch/xfs.git/shortlog/refs/heads/xfs-attr-cleanup.7

An xfsprogs tree porting over the libxfs changes is available here:

    http://git.infradead.org/users/hch/xfsprogs.git/shortlog/refs/heads/attr-cleanup

Changes since v6:
 - spelling fixes
 - better set acl buffer sizing (new patch)
 - lazy allocation in the attrmulti ioctl (new patch)
 - use unsigned int for attr_filter everywhere
 - trace attr_flags

Changes since v5:
 - don't move xfs_da_args

Changes since v4:
 - rename the attr_namespace field to attr_filter
 - drop "properly type the buffer field in struct
   xfs_fsop_attrlist_handlere", this was causing too much discussion for
   a trivial cleanup
 - improve a few commit messages and comments
 - improve the ATTR_REPLACE checks a little more
 - turn the xfs_forget_acl stub into an inline function
 - fix a 0 vs NULL sparse warning in xfs_ioc_attr_list

Changes since v3:
 - clean up a cast
 - fixup a comment
 - fix a flags check to use the right flags (bisection only)
 - move a few hunks around to better spots in the series

Changes since v2:
 - add more comments
 - fix up an error handling corner case in __xfs_set_acl
 - add more cowbell^H^H^H^H^H^H^Hbool
 - add a new patch to reject invalid namespaces flags in
   XFS_IOC_ATTRLIST_BY_HANDLE
 - remove ATTR_ENTSIZE entirely

Changes since v1:
 - rebased to for-next, which includes the fixes from the first
   version

^ permalink raw reply	[flat|nested] 37+ messages in thread

end of thread, other threads:[~2020-02-26 21:40 UTC | newest]

Thread overview: 37+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-02-26 20:22 clean up the attr interface v7 Christoph Hellwig
2020-02-26 20:22 ` [PATCH 01/32] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE Christoph Hellwig
2020-02-26 20:22 ` [PATCH 02/32] xfs: remove the ATTR_INCOMPLETE flag Christoph Hellwig
2020-02-26 20:22 ` [PATCH 03/32] xfs: merge xfs_attr_remove into xfs_attr_set Christoph Hellwig
2020-02-26 20:22 ` [PATCH 04/32] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set Christoph Hellwig
2020-02-26 20:22 ` [PATCH 05/32] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2020-02-26 20:22 ` [PATCH 06/32] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op Christoph Hellwig
2020-02-26 20:22 ` [PATCH 07/32] xfs: remove the name == NULL check from xfs_attr_args_init Christoph Hellwig
2020-02-26 20:22 ` [PATCH 08/32] xfs: remove the MAXNAMELEN " Christoph Hellwig
2020-02-26 20:22 ` [PATCH 09/32] xfs: turn xfs_da_args.value into a void pointer Christoph Hellwig
2020-02-26 20:22 ` [PATCH 10/32] xfs: pass an initialized xfs_da_args structure to xfs_attr_set Christoph Hellwig
2020-02-26 20:22 ` [PATCH 11/32] xfs: pass an initialized xfs_da_args to xfs_attr_get Christoph Hellwig
2020-02-26 20:22 ` [PATCH 12/32] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked Christoph Hellwig
2020-02-26 20:22 ` [PATCH 13/32] xfs: remove ATTR_KERNOVAL Christoph Hellwig
2020-02-26 20:22 ` [PATCH 14/32] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Christoph Hellwig
2020-02-26 20:22 ` [PATCH 15/32] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Christoph Hellwig
2020-02-26 20:22 ` [PATCH 16/32] xfs: factor out a xfs_attr_match helper Christoph Hellwig
2020-02-26 20:22 ` [PATCH 17/32] xfs: cleanup struct xfs_attr_list_context Christoph Hellwig
2020-02-26 20:22 ` [PATCH 18/32] xfs: remove the unused ATTR_ENTRY macro Christoph Hellwig
2020-02-26 20:22 ` [PATCH 19/32] xfs: open code ATTR_ENTSIZE Christoph Hellwig
2020-02-26 20:22 ` [PATCH 20/32] xfs: move the legacy xfs_attr_list to xfs_ioctl.c Christoph Hellwig
2020-02-26 20:22 ` [PATCH 21/32] xfs: rename xfs_attr_list_int to xfs_attr_list Christoph Hellwig
2020-02-26 20:22 ` [PATCH 22/32] xfs: lift common checks into xfs_ioc_attr_list Christoph Hellwig
2020-02-26 20:22 ` [PATCH 23/32] xfs: lift buffer allocation " Christoph Hellwig
2020-02-26 20:22 ` [PATCH 24/32] xfs: lift cursor copy in/out " Christoph Hellwig
2020-02-26 20:22 ` [PATCH 25/32] xfs: improve xfs_forget_acl Christoph Hellwig
2020-02-26 20:23 ` [PATCH 26/32] xfs: clean up the ATTR_REPLACE checks Christoph Hellwig
2020-02-26 20:23 ` [PATCH 27/32] xfs: clean up the attr flag confusion Christoph Hellwig
2020-02-26 20:23 ` [PATCH 28/32] xfs: remove XFS_DA_OP_INCOMPLETE Christoph Hellwig
2020-02-26 20:23 ` [PATCH 29/32] xfs: embedded the attrlist cursor into struct xfs_attr_list_context Christoph Hellwig
2020-02-26 20:23 ` [PATCH 30/32] xfs: clean up bufsize alignment in xfs_ioc_attr_list Christoph Hellwig
2020-02-26 20:23 ` [PATCH 31/32] xfs: only allocate the buffer size actually needed in __xfs_set_acl Christoph Hellwig
2020-02-26 20:37   ` Darrick J. Wong
2020-02-26 21:35   ` Dave Chinner
2020-02-26 20:23 ` [PATCH 32/32] xfs: switch xfs_attrmulti_attr_get to lazy attr buffer allocation Christoph Hellwig
2020-02-26 20:33   ` Darrick J. Wong
2020-02-26 21:40   ` Dave Chinner

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.