All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] arm64: bring Image header in line with latest Arm brand guidelines
@ 2020-04-01  6:56 Ard Biesheuvel
  2020-04-01  7:51 ` Will Deacon
  2020-04-01  9:23 ` Catalin Marinas
  0 siblings, 2 replies; 3+ messages in thread
From: Ard Biesheuvel @ 2020-04-01  6:56 UTC (permalink / raw)
  To: linux-arm-kernel; +Cc: catalin.marinas, will, Ard Biesheuvel

The Arm brand guidelines are pretty clear when it comes to the way
the brand name 'arm' should be displayed: it should be all lowercase,
and there should be sufficient whitespace around it on all sides.

Let's use the reserved space we have available in the Image header to
bring it in compliance with this.

Signed-off-by: Ard Biesheuvel <ardb@kernel.org>
---
 arch/arm64/include/asm/image.h | 2 +-
 arch/arm64/kernel/head.S       | 7 +++----
 2 files changed, 4 insertions(+), 5 deletions(-)

diff --git a/arch/arm64/include/asm/image.h b/arch/arm64/include/asm/image.h
index c2b13213c720..a52e6eca8118 100644
--- a/arch/arm64/include/asm/image.h
+++ b/arch/arm64/include/asm/image.h
@@ -3,7 +3,7 @@
 #ifndef __ASM_IMAGE_H
 #define __ASM_IMAGE_H
 
-#define ARM64_IMAGE_MAGIC	"ARM\x64"
+#define ARM64_IMAGE_MAGIC	"arm\x64"
 
 #define ARM64_IMAGE_FLAG_BE_SHIFT		0
 #define ARM64_IMAGE_FLAG_PAGE_SIZE_SHIFT	(ARM64_IMAGE_FLAG_BE_SHIFT + 1)
diff --git a/arch/arm64/kernel/head.S b/arch/arm64/kernel/head.S
index 57a91032b4c2..e70d3f96dfe4 100644
--- a/arch/arm64/kernel/head.S
+++ b/arch/arm64/kernel/head.S
@@ -78,10 +78,9 @@ _head:
 	le64sym	_kernel_offset_le		// Image load offset from start of RAM, little-endian
 	le64sym	_kernel_size_le			// Effective size of kernel image, little-endian
 	le64sym	_kernel_flags_le		// Informative flags, little-endian
-	.quad	0				// reserved
-	.quad	0				// reserved
-	.quad	0				// reserved
-	.ascii	ARM64_IMAGE_MAGIC		// Magic number
+	.ascii		 "         "
+	.ascii	"   " ARM64_IMAGE_MAGIC "   "	// Magic number
+	.ascii		 "         "
 #ifdef CONFIG_EFI
 	.long	pe_header - _head		// Offset to the PE header.
 
-- 
2.17.1


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] arm64: bring Image header in line with latest Arm brand guidelines
  2020-04-01  6:56 [PATCH] arm64: bring Image header in line with latest Arm brand guidelines Ard Biesheuvel
@ 2020-04-01  7:51 ` Will Deacon
  2020-04-01  9:23 ` Catalin Marinas
  1 sibling, 0 replies; 3+ messages in thread
From: Will Deacon @ 2020-04-01  7:51 UTC (permalink / raw)
  To: Ard Biesheuvel; +Cc: catalin.marinas, linux-arm-kernel

Hi Ard,

On Wed, Apr 01, 2020 at 08:56:36AM +0200, Ard Biesheuvel wrote:
> The Arm brand guidelines are pretty clear when it comes to the way
> the brand name 'arm' should be displayed: it should be all lowercase,
> and there should be sufficient whitespace around it on all sides.
> 
> Let's use the reserved space we have available in the Image header to
> bring it in compliance with this.
> 
> Signed-off-by: Ard Biesheuvel <ardb@kernel.org>
> ---
>  arch/arm64/include/asm/image.h | 2 +-
>  arch/arm64/kernel/head.S       | 7 +++----
>  2 files changed, 4 insertions(+), 5 deletions(-)
> 
> diff --git a/arch/arm64/include/asm/image.h b/arch/arm64/include/asm/image.h
> index c2b13213c720..a52e6eca8118 100644
> --- a/arch/arm64/include/asm/image.h
> +++ b/arch/arm64/include/asm/image.h
> @@ -3,7 +3,7 @@
>  #ifndef __ASM_IMAGE_H
>  #define __ASM_IMAGE_H
>  
> -#define ARM64_IMAGE_MAGIC	"ARM\x64"
> +#define ARM64_IMAGE_MAGIC	"arm\x64"
>  
>  #define ARM64_IMAGE_FLAG_BE_SHIFT		0
>  #define ARM64_IMAGE_FLAG_PAGE_SIZE_SHIFT	(ARM64_IMAGE_FLAG_BE_SHIFT + 1)
> diff --git a/arch/arm64/kernel/head.S b/arch/arm64/kernel/head.S
> index 57a91032b4c2..e70d3f96dfe4 100644
> --- a/arch/arm64/kernel/head.S
> +++ b/arch/arm64/kernel/head.S
> @@ -78,10 +78,9 @@ _head:
>  	le64sym	_kernel_offset_le		// Image load offset from start of RAM, little-endian
>  	le64sym	_kernel_size_le			// Effective size of kernel image, little-endian
>  	le64sym	_kernel_flags_le		// Informative flags, little-endian
> -	.quad	0				// reserved
> -	.quad	0				// reserved
> -	.quad	0				// reserved
> -	.ascii	ARM64_IMAGE_MAGIC		// Magic number
> +	.ascii		 "         "
> +	.ascii	"   " ARM64_IMAGE_MAGIC "   "	// Magic number
> +	.ascii		 "         "
>  #ifdef CONFIG_EFI
>  	.long	pe_header - _head		// Offset to the PE header.

Thanks for the patch. As you know, we take this kind of thing very seriously
in the kernel community, which is why I'm disappointed not to see you taking
this work to its natural conclusion by introducing a new printk format
specifier for "   arm   ", complete with the relevant escapes to ensure the
correct shade of blue on terminal emulators that support it.

But since the bootloader communities will probably be over the moon with
this patch on its own, I see no reason to hold it up:

Acked-until-noon-by: Will Deacon <will@kernel.org>

Will

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] arm64: bring Image header in line with latest Arm brand guidelines
  2020-04-01  6:56 [PATCH] arm64: bring Image header in line with latest Arm brand guidelines Ard Biesheuvel
  2020-04-01  7:51 ` Will Deacon
@ 2020-04-01  9:23 ` Catalin Marinas
  1 sibling, 0 replies; 3+ messages in thread
From: Catalin Marinas @ 2020-04-01  9:23 UTC (permalink / raw)
  To: Ard Biesheuvel; +Cc: will, linux-arm-kernel

On Wed, Apr 01, 2020 at 08:56:36AM +0200, Ard Biesheuvel wrote:
> The Arm brand guidelines are pretty clear when it comes to the way
> the brand name 'arm' should be displayed: it should be all lowercase,
> and there should be sufficient whitespace around it on all sides.
> 
> Let's use the reserved space we have available in the Image header to
> bring it in compliance with this.
> 
> Signed-off-by: Ard Biesheuvel <ardb@kernel.org>

Queued for 5.7-rc1. Thanks.

-- 
Catalin

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-04-01  9:24 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-01  6:56 [PATCH] arm64: bring Image header in line with latest Arm brand guidelines Ard Biesheuvel
2020-04-01  7:51 ` Will Deacon
2020-04-01  9:23 ` Catalin Marinas

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.