All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/4] libceph/ceph: cleanups and move more into ceph.ko
@ 2020-07-01 15:54 Jeff Layton
  2020-07-01 15:54 ` [PATCH 1/4] libceph: just have osd_req_op_init return a pointer Jeff Layton
                   ` (3 more replies)
  0 siblings, 4 replies; 17+ messages in thread
From: Jeff Layton @ 2020-07-01 15:54 UTC (permalink / raw)
  To: ceph-devel; +Cc: idryomov

This is just a small set of cleanups, with a final patch that moves a
chunk of cephfs-specific code out of libceph.ko and into ceph.ko. There
should be no functional changes here.

Jeff Layton (4):
  libceph: just have osd_req_op_init return a pointer
  libceph: refactor osdc request initialization
  libceph: rename __ceph_osdc_alloc_messages to ceph_osdc_alloc_num_messages
  libceph/ceph: move ceph_osdc_new_request into ceph.ko

 fs/ceph/Makefile                |   2 +-
 fs/ceph/addr.c                  |   1 +
 fs/ceph/file.c                  |   1 +
 fs/ceph/osdc.c                  | 113 +++++++++++++++++++
 fs/ceph/osdc.h                  |  16 +++
 include/linux/ceph/osd_client.h |  19 ++--
 net/ceph/osd_client.c           | 185 ++++++--------------------------
 7 files changed, 173 insertions(+), 164 deletions(-)
 create mode 100644 fs/ceph/osdc.c
 create mode 100644 fs/ceph/osdc.h

-- 
2.26.2

^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2020-07-08 10:17 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-01 15:54 [PATCH 0/4] libceph/ceph: cleanups and move more into ceph.ko Jeff Layton
2020-07-01 15:54 ` [PATCH 1/4] libceph: just have osd_req_op_init return a pointer Jeff Layton
2020-07-06 16:41   ` Jeff Layton
2020-07-08 10:18     ` Ilya Dryomov
2020-07-01 15:54 ` [PATCH 2/4] libceph: refactor osdc request initialization Jeff Layton
2020-07-01 18:08   ` Ilya Dryomov
2020-07-01 18:24     ` Jeff Layton
2020-07-01 19:25       ` Ilya Dryomov
2020-07-01 15:54 ` [PATCH 3/4] libceph: rename __ceph_osdc_alloc_messages to ceph_osdc_alloc_num_messages Jeff Layton
2020-07-01 18:48   ` Ilya Dryomov
2020-07-01 19:17     ` Jeff Layton
2020-07-01 19:40       ` Ilya Dryomov
2020-07-01 19:51         ` Jeff Layton
2020-07-01 15:54 ` [PATCH 4/4] libceph/ceph: move ceph_osdc_new_request into ceph.ko Jeff Layton
2020-07-01 19:15   ` Ilya Dryomov
2020-07-01 19:22     ` Jeff Layton
2020-07-01 20:04       ` Ilya Dryomov

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.