All of lore.kernel.org
 help / color / mirror / Atom feed
From: Larry Finger <Larry.Finger@lwfinger.net>
To: kvalo@codeaurora.org
Cc: linux-wireless@vger.kernel.org, Larry Finger <Larry.Finger@lwfinger.net>
Subject: [PATCH v2 01/15] rtlwifi: Start changing RT_TRACE into rtl_dbg
Date: Thu, 23 Jul 2020 15:42:30 -0500	[thread overview]
Message-ID: <20200723204244.24457-2-Larry.Finger@lwfinger.net> (raw)
In-Reply-To: <20200723204244.24457-1-Larry.Finger@lwfinger.net>

The macro name RT_TRACE makes it seem that it is used for tracing, when
is actually used for debugging. Change the name to RT_DEBUG.

This step creates the new macro while keeping the old RT_TRACE to allow
building. It will be removed at the end of the patch series.

Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>
---
v2 - This patch only defines rtl_dbg as suggested by Joe Perches
---
 drivers/net/wireless/realtek/rtlwifi/debug.h | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/drivers/net/wireless/realtek/rtlwifi/debug.h b/drivers/net/wireless/realtek/rtlwifi/debug.h
index 69f169d4d4ae..dbfb4d67ca31 100644
--- a/drivers/net/wireless/realtek/rtlwifi/debug.h
+++ b/drivers/net/wireless/realtek/rtlwifi/debug.h
@@ -160,6 +160,10 @@ void _rtl_dbg_print_data(struct rtl_priv *rtlpriv, u64 comp, int level,
 			 const char *titlestring,
 			 const void *hexdata, int hexdatalen);
 
+#define rtl_dbg(rtlpriv, comp, level, fmt, ...)			\
+	_rtl_dbg_trace(rtlpriv, comp, level,				\
+		       fmt, ##__VA_ARGS__)
+
 #define RT_TRACE(rtlpriv, comp, level, fmt, ...)			\
 	_rtl_dbg_trace(rtlpriv, comp, level,				\
 		       fmt, ##__VA_ARGS__)
@@ -176,6 +180,13 @@ void _rtl_dbg_print_data(struct rtl_priv *rtlpriv, u64 comp, int level,
 
 struct rtl_priv;
 
+__printf(4, 5)
+static inline void rtl_dbg(struct rtl_priv *rtlpriv,
+			   u64 comp, int level,
+			   const char *fmt, ...)
+{
+}
+
 __printf(4, 5)
 static inline void RT_TRACE(struct rtl_priv *rtlpriv,
 			    u64 comp, int level,
-- 
2.27.0


  reply	other threads:[~2020-07-23 20:42 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-23 20:42 [PATCH v2 00/15] rtlwifi: Change RT_TRACE into rtl_dbg for all drivers Larry Finger
2020-07-23 20:42 ` Larry Finger [this message]
2020-08-31 15:27   ` [PATCH v2 01/15] rtlwifi: Start changing RT_TRACE into rtl_dbg Kalle Valo
2020-07-23 20:42 ` [PATCH v2 02/15] rtlwifi: Replace RT_TRACE with rtl_dbg Larry Finger
2020-07-23 20:42 ` [PATCH v2 03/15] rtlwifi: btcoexist: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 04/15] rtlwifi: rtl8188ee: Rename RT_TRACE to rtl_dbg Larry Finger
2020-07-23 20:42 ` [PATCH v2 05/15] rtlwifi: rtl8192-common: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 06/15] rtlwifi: rtl8192ce: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 07/15] rtlwifi: rtl8192cu: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 08/15] rtlwifi: rtl8192de: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 09/15] rtlwifi: rtl8192ee: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 10/15] rtlwifi: rtl8192se " Larry Finger
2020-07-23 20:42 ` [PATCH v2 11/15] rtlwifi: rtl8723ae " Larry Finger
2020-07-23 20:42 ` [PATCH v2 12/15] rtlwifi: rtl8723be " Larry Finger
2020-07-23 20:42 ` [PATCH v2 13/15] rtlwifi: rtl8723-common: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 14/15] rtlwifi: rtl8821ae: " Larry Finger
2020-07-23 20:42 ` [PATCH v2 15/15] rtlwifi: Remove temporary definition of RT_TRACE Larry Finger
2020-07-24  6:34   ` kernel test robot
2020-07-24  6:34     ` kernel test robot
2020-07-24  9:43   ` kernel test robot
2020-07-24  9:43     ` kernel test robot
2020-08-27  9:42   ` Kalle Valo
     [not found]   ` <20200827094217.72A9BC433CB@smtp.codeaurora.org>
2020-08-27 18:31     ` Larry Finger
2020-08-28 12:34       ` Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200723204244.24457-2-Larry.Finger@lwfinger.net \
    --to=larry.finger@lwfinger.net \
    --cc=kvalo@codeaurora.org \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.