All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/5 v2] KVM: x86: Fill in conforming {vmx|svm}_x86_ops and {vmx|svm}_nested_ops via macros
@ 2020-07-25  3:26 Krish Sadhukhan
  2020-07-25  3:26 ` [PATCH 1/5 v2] KVM: x86: Change names of some of the kvm_x86_ops functions to make them more semantical and readable Krish Sadhukhan
                   ` (4 more replies)
  0 siblings, 5 replies; 10+ messages in thread
From: Krish Sadhukhan @ 2020-07-25  3:26 UTC (permalink / raw)
  To: kvm; +Cc: jmattson, sean.j.christopherson, pbonzini, vkuznets

v1 -> v2:
	v2 has split v1 into five patches as follows:
		Patch# 1: Changes to kvm_x86_ops
		Patch# 2: Changes to svm_x86_ops
		Patch# 3: Changes to svm_nested_ops
		Patch# 4: Changes to vmx_x86_ops
		Patch# 5: Changes to vmx_nested_ops


[PATCH 1/5 v2] KVM: x86: Change names of some of the kvm_x86_ops
[PATCH 2/5 v2] KVM: SVM: Fill in conforming svm_x86_ops via macro
[PATCH 3/5 v2] KVM: nSVM: Fill in conforming svm_nested_ops via macro
[PATCH 4/5 v2] KVM: VMX: Fill in conforming vmx_x86_ops via macro
[PATCH 5/5 v2] KVM: nVMX: Fill in conforming vmx_nested_ops via macro

 arch/x86/include/asm/kvm_host.h |  12 +-
 arch/x86/kvm/svm/avic.c         |   4 +-
 arch/x86/kvm/svm/nested.c       |  18 +--
 arch/x86/kvm/svm/sev.c          |   6 +-
 arch/x86/kvm/svm/svm.c          | 218 ++++++++++++++++++------------------
 arch/x86/kvm/svm/svm.h          |   8 +-
 arch/x86/kvm/vmx/nested.c       |  26 +++--
 arch/x86/kvm/vmx/nested.h       |   2 +-
 arch/x86/kvm/vmx/vmx.c          | 238 ++++++++++++++++++++--------------------
 arch/x86/kvm/vmx/vmx.h          |   2 +-
 arch/x86/kvm/x86.c              |  22 ++--
 include/linux/kvm_host.h        |   2 +-
 virt/kvm/kvm_main.c             |   4 +-
 13 files changed, 285 insertions(+), 277 deletions(-)

Krish Sadhukhan (5):
      KVM: x86: Change names of some of the kvm_x86_ops functions to make them m
      KVM: SVM: Fill in conforming svm_x86_ops via macro
      KVM: nSVM: Fill in conforming svm_nested_ops via macro
      KVM: VMX: Fill in conforming vmx_x86_ops via macro
      KVM: nVMX: Fill in conforming vmx_nested_ops via macro

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2020-07-27 17:33 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-25  3:26 [PATCH 0/5 v2] KVM: x86: Fill in conforming {vmx|svm}_x86_ops and {vmx|svm}_nested_ops via macros Krish Sadhukhan
2020-07-25  3:26 ` [PATCH 1/5 v2] KVM: x86: Change names of some of the kvm_x86_ops functions to make them more semantical and readable Krish Sadhukhan
2020-07-25 18:41   ` kernel test robot
2020-07-25 18:41     ` kernel test robot
2020-07-27  9:39   ` Vitaly Kuznetsov
2020-07-27 17:30     ` Krish Sadhukhan
2020-07-25  3:26 ` [PATCH 2/5 v2] KVM: SVM: Fill in conforming svm_x86_ops via macro Krish Sadhukhan
2020-07-25  3:26 ` [PATCH 3/5 v2] KVM: nSVM: Fill in conforming svm_nested_ops " Krish Sadhukhan
2020-07-25  3:26 ` [PATCH 4/5 v2] KVM: VMX: Fill in conforming vmx_x86_ops " Krish Sadhukhan
2020-07-25  3:26 ` [PATCH 5/5 v2] KVM: nVMX: Fill in conforming vmx_nested_ops " Krish Sadhukhan

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.