All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac
@ 2020-08-04  0:27 Peter Collingbourne
  2020-08-04  9:34 ` Peter Maydell
  0 siblings, 1 reply; 2+ messages in thread
From: Peter Collingbourne @ 2020-08-04  0:27 UTC (permalink / raw)
  To: Richard Henderson, qemu-devel, qemu-arm; +Cc: Peter Collingbourne

The name disas_ldst_pac is misleading as it implies the existence
of authenticating store instructions, so rename it to avoid that
implication.

Signed-off-by: Peter Collingbourne <pcc@google.com>
---
 target/arm/translate-a64.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/target/arm/translate-a64.c b/target/arm/translate-a64.c
index 8c0764957c..749de2e509 100644
--- a/target/arm/translate-a64.c
+++ b/target/arm/translate-a64.c
@@ -3408,8 +3408,8 @@ static void disas_ldst_atomic(DisasContext *s, uint32_t insn,
  * W: pre-indexing flag
  * S: sign for imm9.
  */
-static void disas_ldst_pac(DisasContext *s, uint32_t insn,
-                           int size, int rt, bool is_vector)
+static void disas_ld_pac(DisasContext *s, uint32_t insn,
+                         int size, int rt, bool is_vector)
 {
     int rn = extract32(insn, 5, 5);
     bool is_wback = extract32(insn, 11, 1);
@@ -3562,7 +3562,7 @@ static void disas_ldst_reg(DisasContext *s, uint32_t insn)
             disas_ldst_reg_roffset(s, insn, opc, size, rt, is_vector);
             return;
         default:
-            disas_ldst_pac(s, insn, size, rt, is_vector);
+            disas_ld_pac(s, insn, size, rt, is_vector);
             return;
         }
         break;
-- 
2.28.0.163.g6104cc2f0b6-goog



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac
  2020-08-04  0:27 [PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac Peter Collingbourne
@ 2020-08-04  9:34 ` Peter Maydell
  0 siblings, 0 replies; 2+ messages in thread
From: Peter Maydell @ 2020-08-04  9:34 UTC (permalink / raw)
  To: Peter Collingbourne; +Cc: qemu-arm, Richard Henderson, QEMU Developers

On Tue, 4 Aug 2020 at 01:27, Peter Collingbourne <pcc@google.com> wrote:
>
> The name disas_ldst_pac is misleading as it implies the existence
> of authenticating store instructions, so rename it to avoid that
> implication.
>
> Signed-off-by: Peter Collingbourne <pcc@google.com>

The use of ldst here matches the name of this group of instructions
in the Arm ARM (DDI0487F.c page C4-308, "Load/store register (pac)"),
I think.

thanks
-- PMM


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-08-04  9:35 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-04  0:27 [PATCH] target/arm: Rename function disas_ldst_pac to disas_ld_pac Peter Collingbourne
2020-08-04  9:34 ` Peter Maydell

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.