All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v4 00/14] block/nvme: Various cleanups required to use multiple queues
@ 2020-08-12 18:50 Philippe Mathieu-Daudé
  2020-08-12 18:50 ` [PATCH v4 01/14] block/nvme: Replace magic value by SCALE_MS definition Philippe Mathieu-Daudé
                   ` (13 more replies)
  0 siblings, 14 replies; 15+ messages in thread
From: Philippe Mathieu-Daudé @ 2020-08-12 18:50 UTC (permalink / raw)
  To: qemu-devel
  Cc: Fam Zheng, Kevin Wolf, qemu-block, Max Reitz, Stefan Hajnoczi,
	Philippe Mathieu-Daudé

Hi,

This series is mostly code rearrangement (cleanups) to be
able to split the hardware code from the block driver code,
to be able to use multiple queues on the same hardware, or
multiple block drivers on the same hardware.

All this series is reviewed.

Since v3:
- renamed QUEUE_INDEX_{ADMIN/IO} -> INDEX{ADMIN/IO}
- added stefanha tags

Since v2:
- addressed stefanha review comments
- added 4 trivial patches (to simplify the last one)
- register IRQ notifier for each queuepair (admin and io)

Since v1:
- rebased
- use SCALE_MS definition
- added Stefan's R-b
- addressed Stefan's review comments
  - use union { NvmeIdCtrl / NvmeIdNs }
  - move irq_notifier to NVMeQueuePair
  - removed patches depending on "a tracable hardware stateo
    object instead of BDRVNVMeState".

Phil.

Philippe Mathieu-Daudé (14):
  block/nvme: Replace magic value by SCALE_MS definition
  block/nvme: Avoid further processing if trace event not enabled
  block/nvme: Let nvme_create_queue_pair() fail gracefully
  block/nvme: Define INDEX macros to ease code review
  block/nvme: Improve error message when IO queue creation failed
  block/nvme: Use common error path in nvme_add_io_queue()
  block/nvme: Rename local variable
  block/nvme: Use union of NvmeIdCtrl / NvmeIdNs structures
  block/nvme: Replace qemu_try_blockalign0 by qemu_try_blockalign/memset
  block/nvme: Replace qemu_try_blockalign(bs) by
    qemu_try_memalign(pg_sz)
  block/nvme: Simplify nvme_init_queue() arguments
  block/nvme: Replace BDRV_POLL_WHILE by AIO_WAIT_WHILE
  block/nvme: Simplify nvme_create_queue_pair() arguments
  block/nvme: Extract nvme_poll_queue()

 block/nvme.c | 180 +++++++++++++++++++++++++++++----------------------
 1 file changed, 104 insertions(+), 76 deletions(-)

-- 
2.21.3



^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2020-08-12 18:59 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-12 18:50 [PATCH v4 00/14] block/nvme: Various cleanups required to use multiple queues Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 01/14] block/nvme: Replace magic value by SCALE_MS definition Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 02/14] block/nvme: Avoid further processing if trace event not enabled Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 03/14] block/nvme: Let nvme_create_queue_pair() fail gracefully Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 04/14] block/nvme: Define INDEX macros to ease code review Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 05/14] block/nvme: Improve error message when IO queue creation failed Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 06/14] block/nvme: Use common error path in nvme_add_io_queue() Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 07/14] block/nvme: Rename local variable Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 08/14] block/nvme: Use union of NvmeIdCtrl / NvmeIdNs structures Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 09/14] block/nvme: Replace qemu_try_blockalign0 by qemu_try_blockalign/memset Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 10/14] block/nvme: Replace qemu_try_blockalign(bs) by qemu_try_memalign(pg_sz) Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 11/14] block/nvme: Simplify nvme_init_queue() arguments Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 12/14] block/nvme: Replace BDRV_POLL_WHILE by AIO_WAIT_WHILE Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 13/14] block/nvme: Simplify nvme_create_queue_pair() arguments Philippe Mathieu-Daudé
2020-08-12 18:50 ` [PATCH v4 14/14] block/nvme: Extract nvme_poll_queue() Philippe Mathieu-Daudé

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.