All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jacob Pan <jacob.jun.pan@linux.intel.com>
To: Auger Eric <eric.auger@redhat.com>
Cc: iommu@lists.linux-foundation.org,
	LKML <linux-kernel@vger.kernel.org>,
	Joerg Roedel <joro@8bytes.org>,
	Alex Williamson <alex.williamson@redhat.com>,
	Lu Baolu <baolu.lu@linux.intel.com>,
	David Woodhouse <dwmw2@infradead.org>,
	Yi Liu <yi.l.liu@intel.com>, "Tian, Kevin" <kevin.tian@intel.com>,
	Raj Ashok <ashok.raj@intel.com>,
	Christoph Hellwig <hch@infradead.org>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Jonathan Corbet <corbet@lwn.net>,
	jacob.jun.pan@linux.intel.com
Subject: Re: [PATCH v7 5/7] iommu/uapi: Rename uapi functions
Date: Mon, 17 Aug 2020 16:16:15 -0700	[thread overview]
Message-ID: <20200817161615.35dac072@jacob-builder> (raw)
In-Reply-To: <310ebf1c-02d6-b31f-e92e-619d46fa94aa@redhat.com>

On Thu, 13 Aug 2020 10:58:53 +0200
Auger Eric <eric.auger@redhat.com> wrote:

> Hi Jacob,
> 
> On 7/30/20 2:21 AM, Jacob Pan wrote:
> > User APIs such as iommu_sva_unbind_gpasid() may also be used by the
> > kernel. Since we introduced user pointer to the UAPI functions,  
> Practically this is done in the next patch. What about something like:
> 
> We plan to have two flavors of the same API functions, one called
> through ioctls, carrying a user pointer and one called directly with
> valid IOMMU UAPI structs. To differentiate both, let's rename existing
> functions with an iommu_uapi_ prefix.
> 
will do. Thanks!

> Besides
> Reviewed-by: Eric Auger <eric.auger@redhat.com>
> 
> 
> Thanks
> 
> Eric
> > in-kernel callers cannot share the same APIs. In-kernel callers are
> > also trusted, there is no need to validate the data.
> > 
> > This patch renames all UAPI functions with iommu_uapi_ prefix such
> > that is clear to the intended callers.
> > 
> > Suggested-by: Alex Williamson <alex.williamson@redhat.com>
> > Signed-off-by: Jacob Pan <jacob.jun.pan@linux.intel.com>
> > ---
> >  drivers/iommu/iommu.c | 18 +++++++++---------
> >  include/linux/iommu.h | 31 ++++++++++++++++---------------
> >  2 files changed, 25 insertions(+), 24 deletions(-)
> > 
> > diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
> > index b6858adc4f17..3a913ce94a3d 100644
> > --- a/drivers/iommu/iommu.c
> > +++ b/drivers/iommu/iommu.c
> > @@ -1950,35 +1950,35 @@ int iommu_attach_device(struct iommu_domain
> > *domain, struct device *dev) }
> >  EXPORT_SYMBOL_GPL(iommu_attach_device);
> >  
> > -int iommu_cache_invalidate(struct iommu_domain *domain, struct
> > device *dev,
> > -			   struct iommu_cache_invalidate_info
> > *inv_info) +int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain, struct device *dev,
> > +				struct iommu_cache_invalidate_info
> > *inv_info) {
> >  	if (unlikely(!domain->ops->cache_invalidate))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->cache_invalidate(domain, dev,
> > inv_info); }
> > -EXPORT_SYMBOL_GPL(iommu_cache_invalidate);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_cache_invalidate);
> >  
> > -int iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -			   struct device *dev, struct
> > iommu_gpasid_bind_data *data) +int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +			       struct device *dev, struct
> > iommu_gpasid_bind_data *data) {
> >  	if (unlikely(!domain->ops->sva_bind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_bind_gpasid(domain, dev, data);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_bind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_bind_gpasid);
> >  
> > -int iommu_sva_unbind_gpasid(struct iommu_domain *domain, struct
> > device *dev,
> > -			     ioasid_t pasid)
> > +int iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > struct device *dev,
> > +				 ioasid_t pasid)
> >  {
> >  	if (unlikely(!domain->ops->sva_unbind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_unbind_gpasid(dev, pasid);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_unbind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_unbind_gpasid);
> >  
> >  static void __iommu_detach_device(struct iommu_domain *domain,
> >  				  struct device *dev)
> > diff --git a/include/linux/iommu.h b/include/linux/iommu.h
> > index 5f0b7859d2eb..2dcc1a33f6dc 100644
> > --- a/include/linux/iommu.h
> > +++ b/include/linux/iommu.h
> > @@ -430,13 +430,13 @@ extern int iommu_attach_device(struct
> > iommu_domain *domain, struct device *dev);
> >  extern void iommu_detach_device(struct iommu_domain *domain,
> >  				struct device *dev);
> > -extern int iommu_cache_invalidate(struct iommu_domain *domain,
> > -				  struct device *dev,
> > -				  struct
> > iommu_cache_invalidate_info *inv_info); -extern int
> > iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -		struct device *dev, struct iommu_gpasid_bind_data
> > *data); -extern int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, ioasid_t
> > pasid); +extern int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain,
> > +				       struct device *dev,
> > +				       struct
> > iommu_cache_invalidate_info *inv_info); +extern int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +				      struct device *dev, struct
> > iommu_gpasid_bind_data *data); +extern int
> > iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > +					struct device *dev,
> > ioasid_t pasid); extern struct iommu_domain
> > *iommu_get_domain_for_dev(struct device *dev); extern struct
> > iommu_domain *iommu_get_dma_domain(struct device *dev); extern int
> > iommu_map(struct iommu_domain *domain, unsigned long iova, @@
> > -1054,21 +1054,22 @@ static inline int iommu_sva_get_pasid(struct
> > iommu_sva *handle) return IOMMU_PASID_INVALID; }
> >  
> > -static inline int
> > -iommu_cache_invalidate(struct iommu_domain *domain,
> > -		       struct device *dev,
> > -		       struct iommu_cache_invalidate_info
> > *inv_info) +static inline int iommu_uapi_cache_invalidate(struct
> > iommu_domain *domain,
> > +					      struct device *dev,
> > +					      struct
> > iommu_cache_invalidate_info *inv_info) {
> >  	return -ENODEV;
> >  }
> > -static inline int iommu_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, struct
> > iommu_gpasid_bind_data *data) +
> > +static inline int iommu_uapi_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > +					     struct device *dev,
> > +					     struct
> > iommu_gpasid_bind_data *data) {
> >  	return -ENODEV;
> >  }
> >  
> > -static inline int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -					   struct device *dev, int
> > pasid) +static inline int iommu_uapi_sva_unbind_gpasid(struct
> > iommu_domain *domain,
> > +					       struct device *dev,
> > int pasid) {
> >  	return -ENODEV;
> >  }
> >   
> 

[Jacob Pan]

WARNING: multiple messages have this Message-ID (diff)
From: Jacob Pan <jacob.jun.pan@linux.intel.com>
To: Auger Eric <eric.auger@redhat.com>
Cc: "Tian, Kevin" <kevin.tian@intel.com>,
	Raj Ashok <ashok.raj@intel.com>, Jonathan Corbet <corbet@lwn.net>,
	Jean-Philippe Brucker <jean-philippe@linaro.com>,
	Alex Williamson <alex.williamson@redhat.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Christoph Hellwig <hch@infradead.org>,
	iommu@lists.linux-foundation.org,
	David Woodhouse <dwmw2@infradead.org>
Subject: Re: [PATCH v7 5/7] iommu/uapi: Rename uapi functions
Date: Mon, 17 Aug 2020 16:16:15 -0700	[thread overview]
Message-ID: <20200817161615.35dac072@jacob-builder> (raw)
In-Reply-To: <310ebf1c-02d6-b31f-e92e-619d46fa94aa@redhat.com>

On Thu, 13 Aug 2020 10:58:53 +0200
Auger Eric <eric.auger@redhat.com> wrote:

> Hi Jacob,
> 
> On 7/30/20 2:21 AM, Jacob Pan wrote:
> > User APIs such as iommu_sva_unbind_gpasid() may also be used by the
> > kernel. Since we introduced user pointer to the UAPI functions,  
> Practically this is done in the next patch. What about something like:
> 
> We plan to have two flavors of the same API functions, one called
> through ioctls, carrying a user pointer and one called directly with
> valid IOMMU UAPI structs. To differentiate both, let's rename existing
> functions with an iommu_uapi_ prefix.
> 
will do. Thanks!

> Besides
> Reviewed-by: Eric Auger <eric.auger@redhat.com>
> 
> 
> Thanks
> 
> Eric
> > in-kernel callers cannot share the same APIs. In-kernel callers are
> > also trusted, there is no need to validate the data.
> > 
> > This patch renames all UAPI functions with iommu_uapi_ prefix such
> > that is clear to the intended callers.
> > 
> > Suggested-by: Alex Williamson <alex.williamson@redhat.com>
> > Signed-off-by: Jacob Pan <jacob.jun.pan@linux.intel.com>
> > ---
> >  drivers/iommu/iommu.c | 18 +++++++++---------
> >  include/linux/iommu.h | 31 ++++++++++++++++---------------
> >  2 files changed, 25 insertions(+), 24 deletions(-)
> > 
> > diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
> > index b6858adc4f17..3a913ce94a3d 100644
> > --- a/drivers/iommu/iommu.c
> > +++ b/drivers/iommu/iommu.c
> > @@ -1950,35 +1950,35 @@ int iommu_attach_device(struct iommu_domain
> > *domain, struct device *dev) }
> >  EXPORT_SYMBOL_GPL(iommu_attach_device);
> >  
> > -int iommu_cache_invalidate(struct iommu_domain *domain, struct
> > device *dev,
> > -			   struct iommu_cache_invalidate_info
> > *inv_info) +int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain, struct device *dev,
> > +				struct iommu_cache_invalidate_info
> > *inv_info) {
> >  	if (unlikely(!domain->ops->cache_invalidate))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->cache_invalidate(domain, dev,
> > inv_info); }
> > -EXPORT_SYMBOL_GPL(iommu_cache_invalidate);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_cache_invalidate);
> >  
> > -int iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -			   struct device *dev, struct
> > iommu_gpasid_bind_data *data) +int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +			       struct device *dev, struct
> > iommu_gpasid_bind_data *data) {
> >  	if (unlikely(!domain->ops->sva_bind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_bind_gpasid(domain, dev, data);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_bind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_bind_gpasid);
> >  
> > -int iommu_sva_unbind_gpasid(struct iommu_domain *domain, struct
> > device *dev,
> > -			     ioasid_t pasid)
> > +int iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > struct device *dev,
> > +				 ioasid_t pasid)
> >  {
> >  	if (unlikely(!domain->ops->sva_unbind_gpasid))
> >  		return -ENODEV;
> >  
> >  	return domain->ops->sva_unbind_gpasid(dev, pasid);
> >  }
> > -EXPORT_SYMBOL_GPL(iommu_sva_unbind_gpasid);
> > +EXPORT_SYMBOL_GPL(iommu_uapi_sva_unbind_gpasid);
> >  
> >  static void __iommu_detach_device(struct iommu_domain *domain,
> >  				  struct device *dev)
> > diff --git a/include/linux/iommu.h b/include/linux/iommu.h
> > index 5f0b7859d2eb..2dcc1a33f6dc 100644
> > --- a/include/linux/iommu.h
> > +++ b/include/linux/iommu.h
> > @@ -430,13 +430,13 @@ extern int iommu_attach_device(struct
> > iommu_domain *domain, struct device *dev);
> >  extern void iommu_detach_device(struct iommu_domain *domain,
> >  				struct device *dev);
> > -extern int iommu_cache_invalidate(struct iommu_domain *domain,
> > -				  struct device *dev,
> > -				  struct
> > iommu_cache_invalidate_info *inv_info); -extern int
> > iommu_sva_bind_gpasid(struct iommu_domain *domain,
> > -		struct device *dev, struct iommu_gpasid_bind_data
> > *data); -extern int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, ioasid_t
> > pasid); +extern int iommu_uapi_cache_invalidate(struct iommu_domain
> > *domain,
> > +				       struct device *dev,
> > +				       struct
> > iommu_cache_invalidate_info *inv_info); +extern int
> > iommu_uapi_sva_bind_gpasid(struct iommu_domain *domain,
> > +				      struct device *dev, struct
> > iommu_gpasid_bind_data *data); +extern int
> > iommu_uapi_sva_unbind_gpasid(struct iommu_domain *domain,
> > +					struct device *dev,
> > ioasid_t pasid); extern struct iommu_domain
> > *iommu_get_domain_for_dev(struct device *dev); extern struct
> > iommu_domain *iommu_get_dma_domain(struct device *dev); extern int
> > iommu_map(struct iommu_domain *domain, unsigned long iova, @@
> > -1054,21 +1054,22 @@ static inline int iommu_sva_get_pasid(struct
> > iommu_sva *handle) return IOMMU_PASID_INVALID; }
> >  
> > -static inline int
> > -iommu_cache_invalidate(struct iommu_domain *domain,
> > -		       struct device *dev,
> > -		       struct iommu_cache_invalidate_info
> > *inv_info) +static inline int iommu_uapi_cache_invalidate(struct
> > iommu_domain *domain,
> > +					      struct device *dev,
> > +					      struct
> > iommu_cache_invalidate_info *inv_info) {
> >  	return -ENODEV;
> >  }
> > -static inline int iommu_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > -				struct device *dev, struct
> > iommu_gpasid_bind_data *data) +
> > +static inline int iommu_uapi_sva_bind_gpasid(struct iommu_domain
> > *domain,
> > +					     struct device *dev,
> > +					     struct
> > iommu_gpasid_bind_data *data) {
> >  	return -ENODEV;
> >  }
> >  
> > -static inline int iommu_sva_unbind_gpasid(struct iommu_domain
> > *domain,
> > -					   struct device *dev, int
> > pasid) +static inline int iommu_uapi_sva_unbind_gpasid(struct
> > iommu_domain *domain,
> > +					       struct device *dev,
> > int pasid) {
> >  	return -ENODEV;
> >  }
> >   
> 

[Jacob Pan]
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

  reply	other threads:[~2020-08-17 23:09 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-30  0:21 [PATCH v7 0/7] IOMMU user API enhancement Jacob Pan
2020-07-30  0:21 ` Jacob Pan
2020-07-30  0:21 ` [PATCH v7 1/7] docs: IOMMU user API Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-12 16:38   ` Auger Eric
2020-08-12 16:38     ` Auger Eric
2020-08-17 22:07     ` Jacob Pan
2020-08-17 22:07       ` Jacob Pan
2020-07-30  0:21 ` [PATCH v7 2/7] iommu/uapi: Add argsz for user filled data Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-12 16:59   ` Auger Eric
2020-08-12 16:59     ` Auger Eric
2020-08-17 22:48     ` Jacob Pan
2020-08-17 22:48       ` Jacob Pan
2020-07-30  0:21 ` [PATCH v7 3/7] iommu/uapi: Introduce enum type for PASID data format Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-13  9:29   ` Auger Eric
2020-08-13  9:29     ` Auger Eric
2020-07-30  0:21 ` [PATCH v7 4/7] iommu/uapi: Use named union for user data Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-07-30  0:21 ` [PATCH v7 5/7] iommu/uapi: Rename uapi functions Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-13  8:58   ` Auger Eric
2020-08-13  8:58     ` Auger Eric
2020-08-17 23:16     ` Jacob Pan [this message]
2020-08-17 23:16       ` Jacob Pan
2020-07-30  0:21 ` [PATCH v7 6/7] iommu/uapi: Handle data and argsz filled by users Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-13  9:11   ` Auger Eric
2020-08-13  9:11     ` Auger Eric
2020-08-13  9:25     ` Liu, Yi L
2020-08-13  9:25       ` Liu, Yi L
2020-08-13  9:30       ` Auger Eric
2020-08-13  9:30         ` Auger Eric
2020-08-13  9:38         ` Liu, Yi L
2020-08-13  9:38           ` Liu, Yi L
2020-08-13 10:03           ` Auger Eric
2020-08-13 10:03             ` Auger Eric
2020-07-30  0:21 ` [PATCH v7 7/7] iommu/vt-d: Check UAPI data processed by IOMMU core Jacob Pan
2020-07-30  0:21   ` Jacob Pan
2020-08-13  9:19   ` Auger Eric
2020-08-13  9:19     ` Auger Eric
2020-08-31 17:52     ` Jacob Pan
2020-08-31 17:52       ` Jacob Pan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200817161615.35dac072@jacob-builder \
    --to=jacob.jun.pan@linux.intel.com \
    --cc=alex.williamson@redhat.com \
    --cc=ashok.raj@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=corbet@lwn.net \
    --cc=dwmw2@infradead.org \
    --cc=eric.auger@redhat.com \
    --cc=hch@infradead.org \
    --cc=iommu@lists.linux-foundation.org \
    --cc=jean-philippe@linaro.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=yi.l.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.