All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicolin Chen <nicoleotsuka@gmail.com>
To: Dmitry Osipenko <digetx@gmail.com>
Cc: thierry.reding@gmail.com, joro@8bytes.org, krzk@kernel.org,
	vdumpa@nvidia.com, jonathanh@nvidia.com,
	linux-tegra@vger.kernel.org, iommu@lists.linux-foundation.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/3] iommu/tegra-smmu: Rework .probe_device and .attach_dev
Date: Tue, 29 Sep 2020 23:13:52 -0700	[thread overview]
Message-ID: <20200930061351.GA16460@Asurada-Nvidia> (raw)
In-Reply-To: <b74f96cf-0edc-c7f2-3a0e-2a4fe51e3b2e@gmail.com>

On Wed, Sep 30, 2020 at 09:10:38AM +0300, Dmitry Osipenko wrote:
> 30.09.2020 08:49, Nicolin Chen пишет:
> > On Wed, Sep 30, 2020 at 08:11:52AM +0300, Dmitry Osipenko wrote:
> >> 30.09.2020 03:30, Nicolin Chen пишет:
> >>> +	/* An invalid mc pointer means mc and smmu drivers are not ready */
> >>> +	if (IS_ERR_OR_NULL(mc))
> >>
> >> tegra_get_memory_controller() doesn't return NULL.
> > 
> > Well, I don't want to assume that it'd do that forever, and the
> > NULL check of IS_ERR_OR_NULL is marked "unlikely" so it doesn't
> > hurt to have.
> > 
> 
> I don't see any reasons why it won't do that forever.
> 
> Secondly, public function can't be changed randomly without updating all
> the callers.
> 
> Hence there is no need to handle cases that can't ever happen and it
> hurts readability of the code + original error code is missed.

I don't quite understand why an extra "_OR_NULL" would hurt
readability....but I'd take a step back and use IS_ERR().

WARNING: multiple messages have this Message-ID (diff)
From: Nicolin Chen <nicoleotsuka@gmail.com>
To: Dmitry Osipenko <digetx@gmail.com>
Cc: linux-kernel@vger.kernel.org, iommu@lists.linux-foundation.org,
	krzk@kernel.org, jonathanh@nvidia.com, thierry.reding@gmail.com,
	linux-tegra@vger.kernel.org
Subject: Re: [PATCH v2 2/3] iommu/tegra-smmu: Rework .probe_device and .attach_dev
Date: Tue, 29 Sep 2020 23:13:52 -0700	[thread overview]
Message-ID: <20200930061351.GA16460@Asurada-Nvidia> (raw)
In-Reply-To: <b74f96cf-0edc-c7f2-3a0e-2a4fe51e3b2e@gmail.com>

On Wed, Sep 30, 2020 at 09:10:38AM +0300, Dmitry Osipenko wrote:
> 30.09.2020 08:49, Nicolin Chen пишет:
> > On Wed, Sep 30, 2020 at 08:11:52AM +0300, Dmitry Osipenko wrote:
> >> 30.09.2020 03:30, Nicolin Chen пишет:
> >>> +	/* An invalid mc pointer means mc and smmu drivers are not ready */
> >>> +	if (IS_ERR_OR_NULL(mc))
> >>
> >> tegra_get_memory_controller() doesn't return NULL.
> > 
> > Well, I don't want to assume that it'd do that forever, and the
> > NULL check of IS_ERR_OR_NULL is marked "unlikely" so it doesn't
> > hurt to have.
> > 
> 
> I don't see any reasons why it won't do that forever.
> 
> Secondly, public function can't be changed randomly without updating all
> the callers.
> 
> Hence there is no need to handle cases that can't ever happen and it
> hurts readability of the code + original error code is missed.

I don't quite understand why an extra "_OR_NULL" would hurt
readability....but I'd take a step back and use IS_ERR().
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

  reply	other threads:[~2020-09-30  6:19 UTC|newest]

Thread overview: 76+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-30  0:30 [PATCH v2 0/3] iommu/tegra-smmu: Add PCI support Nicolin Chen
2020-09-30  0:30 ` Nicolin Chen
2020-09-30  0:30 ` [PATCH v2 1/3] memory: tegra: Add helper function tegra_get_memory_controller Nicolin Chen
2020-09-30  0:30   ` Nicolin Chen
2020-09-30  5:12   ` Dmitry Osipenko
2020-09-30  5:12     ` Dmitry Osipenko
2020-09-30  5:44     ` Nicolin Chen
2020-09-30  5:44       ` Nicolin Chen
2020-09-30  6:32       ` Dmitry Osipenko
2020-09-30  6:32         ` Dmitry Osipenko
2020-09-30  6:38         ` Nicolin Chen
2020-09-30  6:38           ` Nicolin Chen
2020-09-30  7:31           ` Dmitry Osipenko
2020-09-30  7:31             ` Dmitry Osipenko
2020-09-30  7:21   ` Krzysztof Kozlowski
2020-09-30  7:21     ` Krzysztof Kozlowski
2020-09-30  7:25     ` Nicolin Chen
2020-09-30  7:25       ` Nicolin Chen
2020-09-30  7:50       ` Krzysztof Kozlowski
2020-09-30  7:50         ` Krzysztof Kozlowski
2020-09-30  0:30 ` [PATCH v2 2/3] iommu/tegra-smmu: Rework .probe_device and .attach_dev Nicolin Chen
2020-09-30  0:30   ` Nicolin Chen
2020-09-30  5:10   ` Dmitry Osipenko
2020-09-30  5:10     ` Dmitry Osipenko
2020-09-30  5:20     ` Dmitry Osipenko
2020-09-30  5:20       ` Dmitry Osipenko
2020-09-30  5:50       ` Nicolin Chen
2020-09-30  5:50         ` Nicolin Chen
2020-09-30  6:34       ` Nicolin Chen
2020-09-30  6:34         ` Nicolin Chen
2020-09-30  5:11   ` Dmitry Osipenko
2020-09-30  5:11     ` Dmitry Osipenko
2020-09-30  5:49     ` Nicolin Chen
2020-09-30  5:49       ` Nicolin Chen
2020-09-30  6:10       ` Dmitry Osipenko
2020-09-30  6:10         ` Dmitry Osipenko
2020-09-30  6:13         ` Nicolin Chen [this message]
2020-09-30  6:13           ` Nicolin Chen
2020-09-30  6:33           ` Dmitry Osipenko
2020-09-30  6:33             ` Dmitry Osipenko
2020-09-30  5:24   ` Dmitry Osipenko
2020-09-30  5:24     ` Dmitry Osipenko
2020-09-30  5:39     ` Nicolin Chen
2020-09-30  5:39       ` Nicolin Chen
2020-09-30  5:48       ` Dmitry Osipenko
2020-09-30  5:48         ` Dmitry Osipenko
2020-09-30  5:39   ` Dmitry Osipenko
2020-09-30  5:39     ` Dmitry Osipenko
2020-09-30  5:41     ` Nicolin Chen
2020-09-30  5:41       ` Nicolin Chen
2020-09-30  5:59       ` Dmitry Osipenko
2020-09-30  5:59         ` Dmitry Osipenko
2020-09-30  6:19         ` Nicolin Chen
2020-09-30  6:19           ` Nicolin Chen
2020-09-30  0:30 ` [PATCH v2 3/3] iommu/tegra-smmu: Add PCI support Nicolin Chen
2020-09-30  0:30   ` Nicolin Chen
2020-09-30  5:10   ` Dmitry Osipenko
2020-09-30  5:10     ` Dmitry Osipenko
2020-09-30  5:28     ` Nicolin Chen
2020-09-30  5:28       ` Nicolin Chen
2020-09-30  5:10   ` Dmitry Osipenko
2020-09-30  5:10     ` Dmitry Osipenko
2020-09-30  5:29     ` Nicolin Chen
2020-09-30  5:29       ` Nicolin Chen
2020-09-30  5:58       ` Dmitry Osipenko
2020-09-30  5:58         ` Dmitry Osipenko
2020-09-30  7:16         ` Nicolin Chen
2020-09-30  7:16           ` Nicolin Chen
2020-09-30  5:10   ` Dmitry Osipenko
2020-09-30  5:10     ` Dmitry Osipenko
2020-09-30  5:34     ` Nicolin Chen
2020-09-30  5:34       ` Nicolin Chen
2020-09-30  6:01       ` Dmitry Osipenko
2020-09-30  6:01         ` Dmitry Osipenko
2020-09-30  7:12         ` Nicolin Chen
2020-09-30  7:12           ` Nicolin Chen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200930061351.GA16460@Asurada-Nvidia \
    --to=nicoleotsuka@gmail.com \
    --cc=digetx@gmail.com \
    --cc=iommu@lists.linux-foundation.org \
    --cc=jonathanh@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=krzk@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=thierry.reding@gmail.com \
    --cc=vdumpa@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.