All of lore.kernel.org
 help / color / mirror / Atom feed
* [Intel-gfx] [PATCH v2 0/3] Gen12 forcewake and multicast updates
@ 2020-10-09 19:44 Matt Roper
  2020-10-09 19:44 ` [Intel-gfx] [PATCH v2 1/3] drm/i915: Rename FORCEWAKE_BLITTER to FORCEWAKE_GT Matt Roper
                   ` (6 more replies)
  0 siblings, 7 replies; 11+ messages in thread
From: Matt Roper @ 2020-10-09 19:44 UTC (permalink / raw)
  To: intel-gfx

The hardware architects have finally provided an updated MMIO table for                                                                                                                           
gen12 platforms (TGL, RKL, DG1).  We should update our driver's                                                                                                                                   
forcewake and MCR programming accordingly.                                                                                                                                                        

v2:
 - Include a rename of FORCEWAKE_BLITTER to FORCEWAKE_GT
 - Add comments to aggregated forcewake ranges showing the sub-ranges
   that we've combined.  (Jose)
                                                                                                                                                                                                  
Bspec: 66696                                                                                                                                                                                      
Cc: Caz Yokoyama <caz.yokoyama@intel.com>                                                                                                                                                         
Cc: Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>                                                                                                                                      
Cc: José Roberto de Souza <jose.souza@intel.com>


Matt Roper (3):
  drm/i915: Rename FORCEWAKE_BLITTER to FORCEWAKE_GT
  drm/i915: Update gen12 forcewake table
  drm/i915: Update gen12 multicast register ranges

 drivers/gpu/drm/i915/gt/intel_workarounds.c |  28 ++-
 drivers/gpu/drm/i915/gt/uc/intel_guc.c      |   6 +-
 drivers/gpu/drm/i915/gvt/handlers.c         |   8 +-
 drivers/gpu/drm/i915/gvt/reg.h              |   4 +-
 drivers/gpu/drm/i915/i915_reg.h             |   4 +-
 drivers/gpu/drm/i915/intel_uncore.c         | 203 +++++++++++++-------
 drivers/gpu/drm/i915/intel_uncore.h         |   4 +-
 7 files changed, 171 insertions(+), 86 deletions(-)

-- 
2.24.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2020-10-10  1:59 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-09 19:44 [Intel-gfx] [PATCH v2 0/3] Gen12 forcewake and multicast updates Matt Roper
2020-10-09 19:44 ` [Intel-gfx] [PATCH v2 1/3] drm/i915: Rename FORCEWAKE_BLITTER to FORCEWAKE_GT Matt Roper
2020-10-09 22:09   ` Souza, Jose
2020-10-09 19:44 ` [Intel-gfx] [PATCH v2 2/3] drm/i915: Update gen12 forcewake table Matt Roper
2020-10-09 22:21   ` Souza, Jose
2020-10-09 19:44 ` [Intel-gfx] [PATCH v2 3/3] drm/i915: Update gen12 multicast register ranges Matt Roper
2020-10-09 20:40 ` [Intel-gfx] ✗ Fi.CI.CHECKPATCH: warning for Gen12 forcewake and multicast updates (rev2) Patchwork
2020-10-09 20:41 ` [Intel-gfx] ✗ Fi.CI.SPARSE: " Patchwork
2020-10-09 21:02 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2020-10-10  0:06 ` [Intel-gfx] ✓ Fi.CI.IGT: " Patchwork
2020-10-10  1:59   ` Matt Roper

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.