All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] xfs: introduce xfs_validate_stripe_factors()
@ 2020-10-09  5:05 Gao Xiang
  2020-10-12 13:05 ` Brian Foster
  0 siblings, 1 reply; 4+ messages in thread
From: Gao Xiang @ 2020-10-09  5:05 UTC (permalink / raw)
  To: linux-xfs; +Cc: Darrick J. Wong, Eric Sandeen, Gao Xiang

Introduce a common helper to consolidate stripe validation process.
Also make kernel code xfs_validate_sb_common() use it first.

Signed-off-by: Gao Xiang <hsiangkao@redhat.com>
---

kernel side of:
https://lore.kernel.org/r/20201007140402.14295-3-hsiangkao@aol.com
with update suggested by Darrick:
 - stretch columns for commit message;
 - add comments to hasdalign check;
 - break old sunit / swidth != 0 check into two seperate checks;
 - update an error message description.

also use bytes for sunit / swidth representation, so users can
see values in the unique unit.

see
https://lore.kernel.org/r/20201007140402.14295-1-hsiangkao@aol.com
for the background.

 fs/xfs/libxfs/xfs_sb.c | 65 +++++++++++++++++++++++++++++++++++-------
 fs/xfs/libxfs/xfs_sb.h |  3 ++
 2 files changed, 57 insertions(+), 11 deletions(-)

diff --git a/fs/xfs/libxfs/xfs_sb.c b/fs/xfs/libxfs/xfs_sb.c
index 5aeafa59ed27..cb2a7aa0ad51 100644
--- a/fs/xfs/libxfs/xfs_sb.c
+++ b/fs/xfs/libxfs/xfs_sb.c
@@ -360,21 +360,18 @@ xfs_validate_sb_common(
 		}
 	}
 
-	if (sbp->sb_unit) {
-		if (!xfs_sb_version_hasdalign(sbp) ||
-		    sbp->sb_unit > sbp->sb_width ||
-		    (sbp->sb_width % sbp->sb_unit) != 0) {
-			xfs_notice(mp, "SB stripe unit sanity check failed");
-			return -EFSCORRUPTED;
-		}
-	} else if (xfs_sb_version_hasdalign(sbp)) {
+	/*
+	 * Either (sb_unit and !hasdalign) or (!sb_unit and hasdalign)
+	 * would imply the image is corrupted.
+	 */
+	if (!sbp->sb_unit ^ !xfs_sb_version_hasdalign(sbp)) {
 		xfs_notice(mp, "SB stripe alignment sanity check failed");
 		return -EFSCORRUPTED;
-	} else if (sbp->sb_width) {
-		xfs_notice(mp, "SB stripe width sanity check failed");
-		return -EFSCORRUPTED;
 	}
 
+	if (!xfs_validate_stripe_factors(mp, XFS_FSB_TO_B(mp, sbp->sb_unit),
+					 XFS_FSB_TO_B(mp, sbp->sb_width), 0))
+		return -EFSCORRUPTED;
 
 	if (xfs_sb_version_hascrc(&mp->m_sb) &&
 	    sbp->sb_blocksize < XFS_MIN_CRC_BLOCKSIZE) {
@@ -1233,3 +1230,49 @@ xfs_sb_get_secondary(
 	*bpp = bp;
 	return 0;
 }
+
+/*
+ * sunit, swidth, sectorsize(optional with 0) should be all in bytes,
+ * so users won't be confused by values in error messages.
+ */
+bool
+xfs_validate_stripe_factors(
+	struct xfs_mount	*mp,
+	__s64			sunit,
+	__s64			swidth,
+	int			sectorsize)
+{
+	if (sectorsize && sunit % sectorsize) {
+		xfs_notice(mp,
+"stripe unit (%lld) must be a multiple of the sector size (%d)",
+			   sunit, sectorsize);
+		return false;
+	}
+
+	if (sunit && !swidth) {
+		xfs_notice(mp,
+"invalid stripe unit (%lld) and stripe width of 0", sunit);
+		return false;
+	}
+
+	if (!sunit && swidth) {
+		xfs_notice(mp,
+"invalid stripe width (%lld) and stripe unit of 0", swidth);
+		return false;
+	}
+
+	if (sunit > swidth) {
+		xfs_notice(mp,
+"stripe unit (%lld) is larger than the stripe width (%lld)", sunit, swidth);
+		return false;
+	}
+
+	if (sunit && (swidth % sunit)) {
+		xfs_notice(mp,
+"stripe width (%lld) must be a multiple of the stripe unit (%lld)",
+			   swidth, sunit);
+		return false;
+	}
+	return true;
+}
+
diff --git a/fs/xfs/libxfs/xfs_sb.h b/fs/xfs/libxfs/xfs_sb.h
index 92465a9a5162..2d3504eb9886 100644
--- a/fs/xfs/libxfs/xfs_sb.h
+++ b/fs/xfs/libxfs/xfs_sb.h
@@ -42,4 +42,7 @@ extern int	xfs_sb_get_secondary(struct xfs_mount *mp,
 				struct xfs_trans *tp, xfs_agnumber_t agno,
 				struct xfs_buf **bpp);
 
+extern bool	xfs_validate_stripe_factors(struct xfs_mount *mp,
+				__s64 sunit, __s64 swidth, int sectorsize);
+
 #endif	/* __XFS_SB_H__ */
-- 
2.18.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] xfs: introduce xfs_validate_stripe_factors()
  2020-10-09  5:05 [PATCH] xfs: introduce xfs_validate_stripe_factors() Gao Xiang
@ 2020-10-12 13:05 ` Brian Foster
  2020-10-12 13:55   ` Gao Xiang
  0 siblings, 1 reply; 4+ messages in thread
From: Brian Foster @ 2020-10-12 13:05 UTC (permalink / raw)
  To: Gao Xiang; +Cc: linux-xfs, Darrick J. Wong, Eric Sandeen

On Fri, Oct 09, 2020 at 01:05:46PM +0800, Gao Xiang wrote:
> Introduce a common helper to consolidate stripe validation process.
> Also make kernel code xfs_validate_sb_common() use it first.
> 
> Signed-off-by: Gao Xiang <hsiangkao@redhat.com>
> ---
> 
> kernel side of:
> https://lore.kernel.org/r/20201007140402.14295-3-hsiangkao@aol.com
> with update suggested by Darrick:
>  - stretch columns for commit message;
>  - add comments to hasdalign check;
>  - break old sunit / swidth != 0 check into two seperate checks;
>  - update an error message description.
> 
> also use bytes for sunit / swidth representation, so users can
> see values in the unique unit.
> 
> see
> https://lore.kernel.org/r/20201007140402.14295-1-hsiangkao@aol.com
> for the background.
> 
>  fs/xfs/libxfs/xfs_sb.c | 65 +++++++++++++++++++++++++++++++++++-------
>  fs/xfs/libxfs/xfs_sb.h |  3 ++
>  2 files changed, 57 insertions(+), 11 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_sb.c b/fs/xfs/libxfs/xfs_sb.c
> index 5aeafa59ed27..cb2a7aa0ad51 100644
> --- a/fs/xfs/libxfs/xfs_sb.c
> +++ b/fs/xfs/libxfs/xfs_sb.c
...
> @@ -1233,3 +1230,49 @@ xfs_sb_get_secondary(
>  	*bpp = bp;
>  	return 0;
>  }
> +
> +/*
> + * sunit, swidth, sectorsize(optional with 0) should be all in bytes,
> + * so users won't be confused by values in error messages.
> + */
> +bool
> +xfs_validate_stripe_factors(

xfs_validate_stripe_geometry() perhaps?

> +	struct xfs_mount	*mp,
> +	__s64			sunit,
> +	__s64			swidth,
> +	int			sectorsize)
> +{
> +	if (sectorsize && sunit % sectorsize) {
> +		xfs_notice(mp,
> +"stripe unit (%lld) must be a multiple of the sector size (%d)",
> +			   sunit, sectorsize);
> +		return false;
> +	}
> +
> +	if (sunit && !swidth) {
> +		xfs_notice(mp,
> +"invalid stripe unit (%lld) and stripe width of 0", sunit);
> +		return false;
> +	}
> +
> +	if (!sunit && swidth) {
> +		xfs_notice(mp,
> +"invalid stripe width (%lld) and stripe unit of 0", swidth);
> +		return false;
> +	}

Seems like these two could be combined into one check that prints
something like:

	invalid stripe width (%lld) and stripe unit (%lld)

> +
> +	if (sunit > swidth) {
> +		xfs_notice(mp,
> +"stripe unit (%lld) is larger than the stripe width (%lld)", sunit, swidth);
> +		return false;
> +	}
> +
> +	if (sunit && (swidth % sunit)) {
> +		xfs_notice(mp,
> +"stripe width (%lld) must be a multiple of the stripe unit (%lld)",
> +			   swidth, sunit);
> +		return false;
> +	}
> +	return true;
> +}
> +

Trailing whitespace here.

Otherwise looks reasonable outside of those nits.

Brian

> diff --git a/fs/xfs/libxfs/xfs_sb.h b/fs/xfs/libxfs/xfs_sb.h
> index 92465a9a5162..2d3504eb9886 100644
> --- a/fs/xfs/libxfs/xfs_sb.h
> +++ b/fs/xfs/libxfs/xfs_sb.h
> @@ -42,4 +42,7 @@ extern int	xfs_sb_get_secondary(struct xfs_mount *mp,
>  				struct xfs_trans *tp, xfs_agnumber_t agno,
>  				struct xfs_buf **bpp);
>  
> +extern bool	xfs_validate_stripe_factors(struct xfs_mount *mp,
> +				__s64 sunit, __s64 swidth, int sectorsize);
> +
>  #endif	/* __XFS_SB_H__ */
> -- 
> 2.18.1
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] xfs: introduce xfs_validate_stripe_factors()
  2020-10-12 13:05 ` Brian Foster
@ 2020-10-12 13:55   ` Gao Xiang
  2020-10-12 14:17     ` Brian Foster
  0 siblings, 1 reply; 4+ messages in thread
From: Gao Xiang @ 2020-10-12 13:55 UTC (permalink / raw)
  To: Brian Foster; +Cc: linux-xfs, Darrick J. Wong, Eric Sandeen

Hi Brian,

On Mon, Oct 12, 2020 at 09:05:24AM -0400, Brian Foster wrote:
> On Fri, Oct 09, 2020 at 01:05:46PM +0800, Gao Xiang wrote:
> > Introduce a common helper to consolidate stripe validation process.
> > Also make kernel code xfs_validate_sb_common() use it first.
> > 
> > Signed-off-by: Gao Xiang <hsiangkao@redhat.com>
> > ---

...

> > diff --git a/fs/xfs/libxfs/xfs_sb.c b/fs/xfs/libxfs/xfs_sb.c
> > index 5aeafa59ed27..cb2a7aa0ad51 100644
> > --- a/fs/xfs/libxfs/xfs_sb.c
> > +++ b/fs/xfs/libxfs/xfs_sb.c
> ...
> > @@ -1233,3 +1230,49 @@ xfs_sb_get_secondary(
> >  	*bpp = bp;
> >  	return 0;
> >  }
> > +
> > +/*
> > + * sunit, swidth, sectorsize(optional with 0) should be all in bytes,
> > + * so users won't be confused by values in error messages.
> > + */
> > +bool
> > +xfs_validate_stripe_factors(
> 
> xfs_validate_stripe_geometry() perhaps?

Thanks for the review!

Ok, I'm fine with the naming, since I had no better name
about it at that time :)

> 
> > +	struct xfs_mount	*mp,
> > +	__s64			sunit,
> > +	__s64			swidth,
> > +	int			sectorsize)
> > +{
> > +	if (sectorsize && sunit % sectorsize) {
> > +		xfs_notice(mp,
> > +"stripe unit (%lld) must be a multiple of the sector size (%d)",
> > +			   sunit, sectorsize);
> > +		return false;
> > +	}
> > +
> > +	if (sunit && !swidth) {
> > +		xfs_notice(mp,
> > +"invalid stripe unit (%lld) and stripe width of 0", sunit);
> > +		return false;
> > +	}
> > +
> > +	if (!sunit && swidth) {
> > +		xfs_notice(mp,
> > +"invalid stripe width (%lld) and stripe unit of 0", swidth);
> > +		return false;
> > +	}
> 
> Seems like these two could be combined into one check that prints
> something like:
> 
> 	invalid stripe width (%lld) and stripe unit (%lld)

Hmm, that was in response to Darrick's previous review... see,
https://lore.kernel.org/linux-xfs/20201007222942.GH6540@magnolia

so I'd like to know further direction of this...

> 
> > +
> > +	if (sunit > swidth) {
> > +		xfs_notice(mp,
> > +"stripe unit (%lld) is larger than the stripe width (%lld)", sunit, swidth);
> > +		return false;
> > +	}
> > +
> > +	if (sunit && (swidth % sunit)) {
> > +		xfs_notice(mp,
> > +"stripe width (%lld) must be a multiple of the stripe unit (%lld)",
> > +			   swidth, sunit);
> > +		return false;
> > +	}
> > +	return true;
> > +}
> > +
> 
> Trailing whitespace here.

That is trailing newline (I personally prefer that),
yeah, I will remove it in the next version.

Thanks,
Gao Xiang

> 
> Otherwise looks reasonable outside of those nits.
> 
> Brian


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] xfs: introduce xfs_validate_stripe_factors()
  2020-10-12 13:55   ` Gao Xiang
@ 2020-10-12 14:17     ` Brian Foster
  0 siblings, 0 replies; 4+ messages in thread
From: Brian Foster @ 2020-10-12 14:17 UTC (permalink / raw)
  To: Gao Xiang; +Cc: linux-xfs, Darrick J. Wong, Eric Sandeen

On Mon, Oct 12, 2020 at 09:55:36PM +0800, Gao Xiang wrote:
> Hi Brian,
> 
> On Mon, Oct 12, 2020 at 09:05:24AM -0400, Brian Foster wrote:
> > On Fri, Oct 09, 2020 at 01:05:46PM +0800, Gao Xiang wrote:
> > > Introduce a common helper to consolidate stripe validation process.
> > > Also make kernel code xfs_validate_sb_common() use it first.
> > > 
> > > Signed-off-by: Gao Xiang <hsiangkao@redhat.com>
> > > ---
> 
> ...
> 
> > > diff --git a/fs/xfs/libxfs/xfs_sb.c b/fs/xfs/libxfs/xfs_sb.c
> > > index 5aeafa59ed27..cb2a7aa0ad51 100644
> > > --- a/fs/xfs/libxfs/xfs_sb.c
> > > +++ b/fs/xfs/libxfs/xfs_sb.c
> > ...
> > > @@ -1233,3 +1230,49 @@ xfs_sb_get_secondary(
> > >  	*bpp = bp;
> > >  	return 0;
> > >  }
> > > +
> > > +/*
> > > + * sunit, swidth, sectorsize(optional with 0) should be all in bytes,
> > > + * so users won't be confused by values in error messages.
> > > + */
> > > +bool
> > > +xfs_validate_stripe_factors(
> > 
> > xfs_validate_stripe_geometry() perhaps?
> 
> Thanks for the review!
> 
> Ok, I'm fine with the naming, since I had no better name
> about it at that time :)
> 
> > 
> > > +	struct xfs_mount	*mp,
> > > +	__s64			sunit,
> > > +	__s64			swidth,
> > > +	int			sectorsize)
> > > +{
> > > +	if (sectorsize && sunit % sectorsize) {
> > > +		xfs_notice(mp,
> > > +"stripe unit (%lld) must be a multiple of the sector size (%d)",
> > > +			   sunit, sectorsize);
> > > +		return false;
> > > +	}
> > > +
> > > +	if (sunit && !swidth) {
> > > +		xfs_notice(mp,
> > > +"invalid stripe unit (%lld) and stripe width of 0", sunit);
> > > +		return false;
> > > +	}
> > > +
> > > +	if (!sunit && swidth) {
> > > +		xfs_notice(mp,
> > > +"invalid stripe width (%lld) and stripe unit of 0", swidth);
> > > +		return false;
> > > +	}
> > 
> > Seems like these two could be combined into one check that prints
> > something like:
> > 
> > 	invalid stripe width (%lld) and stripe unit (%lld)
> 
> Hmm, that was in response to Darrick's previous review... see,
> https://lore.kernel.org/linux-xfs/20201007222942.GH6540@magnolia
> 
> so I'd like to know further direction of this...
> 

Oh, Ok. No problem, I don't feel strongly about it. It just looked like
a potential code reduction.

> > 
> > > +
> > > +	if (sunit > swidth) {
> > > +		xfs_notice(mp,
> > > +"stripe unit (%lld) is larger than the stripe width (%lld)", sunit, swidth);
> > > +		return false;
> > > +	}
> > > +
> > > +	if (sunit && (swidth % sunit)) {
> > > +		xfs_notice(mp,
> > > +"stripe width (%lld) must be a multiple of the stripe unit (%lld)",
> > > +			   swidth, sunit);
> > > +		return false;
> > > +	}
> > > +	return true;
> > > +}
> > > +
> > 
> > Trailing whitespace here.
> 
> That is trailing newline (I personally prefer that),
> yeah, I will remove it in the next version.
> 

git (at least my configuration) tends to show this as a whitespace
error. I.e., it's highlighted in red and stands out similar to other
whitespace errors (such as tab after space, etc.). I thought that was a
fairly common config and thus something we tried to avoid, but could be
mistaken.

Brian

> Thanks,
> Gao Xiang
> 
> > 
> > Otherwise looks reasonable outside of those nits.
> > 
> > Brian
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-10-12 14:18 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-09  5:05 [PATCH] xfs: introduce xfs_validate_stripe_factors() Gao Xiang
2020-10-12 13:05 ` Brian Foster
2020-10-12 13:55   ` Gao Xiang
2020-10-12 14:17     ` Brian Foster

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.